8 Replies Latest reply: Dec 5, 2013 12:13 AM by fiddlemcwiddle
AppleMacCider Level 1 Level 1 (0 points)

After importing video to FCP X, I find it takes ages for the background rendering to move from 0% to 1%, but if I quit the app then reopen, it is so much faster to render.  Is this normal for FCP X?

 

Thanks in advance.

Matt


Mac Pro, OS X Mountain Lion (10.8.3)
  • innocentius Level 4 Level 4 (1,715 points)

    I have not had that issue. But it is best practice to turn off background render, and just render when you need it

  • BenB Level 6 Level 6 (8,170 points)

    Because you interupt the background rendering and at re-launch it isn't starting up immediatly.  Turn it off.  It is more of a pain than it is worth.

  • Tom Wolsky Level 10 Level 10 (110,135 points)

    Or set the start time to something like 600, so it only kicks in when you go to lunch or whatever, not while you're still editing and having a little think about something.

  • innocentius Level 4 Level 4 (1,715 points)

    Well did those replies help ? It has been quite common on this forum that users who have problems ask questions and never replies. Nobody here is paid for answering and it would help  others in this community if the the help seeker gives an answer. This is a bad manner.

  • AppleMacCider Level 1 Level 1 (0 points)

    Thanks to everyone's replies. I posted the question just before I left home for a few hours (as in the UK so at least 5 hours ahead of most people in this forum), as didn't think I would get any replies before the time I got home.

     

    I appreciate all the comments and how quick everyone replied. 

     

    I did not consider "not having background rendering on" until this post.  However, feel Tom's point about setting the delay to say 600 seconds is probably the best option so if I am away from my Mac for a while, it will start rendering in the background, but not when I'm using it.

     

    I only have 10GB of RAM so background rendering slows down my machine.  It's definitely not been so slow since I have used it again now.

     

     

    Thanks again

    Matt

  • fiddlemcwiddle Level 1 Level 1 (10 points)

    I have very similar problem - if FCPX has to render or share or what have you it seems to almost stop if the application is in the background (ie,, if you have made a project and waiting for it to share so your on safari) it seems to go VERY slowly, and uses only a small percentage of the CPU. As soon as you bring FCPX to the foreground the percentage CPU used jumps to 2-300% and the whole process speeds up.

     

    Would turning background render off or setting a long time delay help this?

  • Luis Sequeira1 Level 5 Level 5 (6,805 points)

    fiddlemcwiddle wrote:

     

    I have very similar problem - if FCPX has to render or share or what have you it seems to almost stop if the application is in the background (ie,, if you have made a project and waiting for it to share so your on safari) it seems to go VERY slowly, and uses only a small percentage of the CPU. As soon as you bring FCPX to the foreground the percentage CPU used jumps to 2-300% and the whole process speeds up.

     

    Would turning background render off or setting a long time delay help this?

     

    No - this is a different issue. I bet you are using Mavericks. Mavericks introduced a feature called "App Nap" that reduces power consumption and devotes more resources to the foreground application by "napping" any apps in the background. This is something you DON'T want with FCP X, but it is easy to fix.

     

    In the Finder, go the Applications folder (Cmd-Shift-A will open this folder automatically for you); select the Final Cut Pro icon; hit Cmd-I (this opens the "Get Info" window); check the box that says "Prevent App Nap".

     

    Note: this is likely to be a transient situation, as the current version of FCP X dates back from before the Mavericks introduction; newer applications are supposed to inform the OS that they don't want to nap.

  • fiddlemcwiddle Level 1 Level 1 (10 points)

    Thanks Luis!