10 Replies Latest reply: May 2, 2013 2:15 PM by ChrisBedford
ChrisBedford Level 1 Level 1 (0 points)

I have just acquired an elderly (no idea just *how* old) mac mini (says underneath 1.66/2x256/60/comb q/ap/bt which I presume means it has a 1.66 GHz cpu, 512 MB ram, a 60 GB hard disk, some other stuff, and bluetooth) with who knows what version of OSX on it. Also no-one knows the user or admin passwords.


I have tried booting using all the key combinations listed in the kb article (HT1533) and *none* of them produce any results other than what I get without pressing anything; i.e. the machine boots off the internal HDD and prompts for password. Needless to say having a Snow Leopard install disk in the DVD drive also has no effect.


It's a genuine Apple keyboard, the wide 104-key style. I know it is working because if I type anything at the password prompt, dots appear and when I press the [Enter] key I get the "head-shake" response that says "Uh-uh, Buddy, you got that wrong". The computer also successfully paired with the genuine Apple mouse (old style with the little track ball where a Microsoft mouse would have a scroll wheel. I think this is the same model mouse this computer would have shipped with). The box only has 4 USB ports, I've tried the keyboard in all of them. There's nothing else connected, except power and DVI screen.


How to get it booted off the SL disk and install from scratch? Ideas??



iPhone 4S, iOS 6.1
  • lllaass Level 10 Level 10 (153,965 points)

    What happens when you first insert the install disk in the drive and then hold the C key while booting up?

  • ChrisBedford Level 1 Level 1 (0 points)

    Nothing at all! Except the drive swallows the disk, and you can hear it spinning. Nothing appears on screen, and the C key (like all others) has no effect when booting.


    One other thing I forgot to mention is that it doesn't matter if I press & hold the key (or key combination) *immediately* on pressing the Power button, or wait a second, or wait until the "chime" sound - no result.

  • Eustace Mendis Level 7 Level 7 (25,300 points)

    Is it possible this is a G4 Mini, one that cannot go past OS 10.5?

  • ChrisBedford Level 1 Level 1 (0 points)

    Well, I have no idea :-( but it's possible.


    However, even if that was the reason for not booting the SL install DVD, that doesn't account for not being able to get any other boot key to work - e.g. Cmd-Option-R-P is supposed to reset NVRAM... nothing. Cmd-S for "single user mode" - nada. Doesn't make sense.

  • lllaass Level 10 Level 10 (153,965 points)

    - So you get the same login screen when yu press and hod the Option key during bootup? You should get the screen wher yu select your startup drive.

    - If yes I would try another keyboard.

  • Eustace Mendis Level 7 Level 7 (25,300 points)

    Of course, you're right... regardless of which model it is, it shuld respond to keyboard demands on bootup.


    Try entering Admin as the User name and leave the password field blank. This used to be a default setting.


    Beyond that, could you try booting from Snow Leopard in an external optical drive?

  • lllaass Level 10 Level 10 (153,965 points)

    Googling and other information shows it is an Intel Core Duo Mac Mini. Those can go as high as Snow Leopard. Thus it should boot from the SL install disk.

  • ChrisBedford Level 1 Level 1 (0 points)

    Thanks, both of you guys


    I will try both of your suggestions later today. Now that you mention about trying a different keyboard, I originally tried a generic PC keyboard which didn't work at all. I thought at the time maybe some Macs just might need a Mac keyboard so I switched and didn't think of it again. But maybe there is something fundamentally wrong with the computer... it has been lying in a store-room ofr over a year, and the ex user (I seem to recall) complained about problems but no idea what his issues were.


    Anyway... worth a couple more minutes of experimenting, isn't it!

  • ChrisBedford Level 1 Level 1 (0 points)

    Eustace Mendis wrote:


    Try entering Admin as the User name and leave the password field blank. This used to be a default setting.


    ...uhh, how do you do that?


    All I get is an 8-ball & next to that "Grant's Mac", then below it the password block.


    If I click "back" the options are Sleep, Restart, or Shut Down. Here "Grant's Mac" is clickable, and that of course takes me back to the logon screen.


    I don't see any option to change the logon user name...??


    [Ohhhhh... I just spotted that on this screen it tells me it's on Version 10.4.11 but I don't think that really matters does it]

  • ChrisBedford Level 1 Level 1 (0 points)

    OK, to answer all my own questions then ;-)


    - to try logging on as administrator, just enter the wrong password for the default user anumber of times (keep hitting enter on a blank pw I guess) until you are prompted for the "master" unlock password or words to that effect. Hmm well anyway.


    That also didn't work BTW, no default passwords were set on this machine.


    - the problem was the keyboard, but not a faulty one: a later model one. The computer was running 10.4 and has / had older firmware which didn't recognise the newer slim aluminium keyboard...I took it in to my local guru bar and they found one of them old chunky curved models which worked first time. Used that to reset the user password, and once i got it home I was able to use the System Preferences -> Startup Disk app to boot it from the Snow Leopard install DVD. Yayyyyyy....


    Thanks to you guys for your helpful suggestions - if it weren't for people like you we'd all be floundering helplessly! Hip-hip - Hooray