9 Replies Latest reply: May 21, 2013 5:05 AM by BadTinkerTec
BadTinkerTec Level 1 (0 points)

I was concerned about hackers getting credit card info and foolishly removed what looked like bogus certificates in my browser, now I get all sorts of cookies blocked messages continuously, any  way to repair my mistake?  I looked for repair in Safari & Firefox but there does not appear to be an option for that.  Any suggestions?


MacBook (13-inch Mid 2010), Mac OS X (10.6.8), expired certificates removed, oops
  • Level 5 (4,015 points)

    Hi BadTinkerTec,

     

    It sounds like we may have the option of Blocking Cookies set to "Always". Lets see if this resolves your issue:

     

    Safari 5.1 (OS X Lion): Manage cookies

    http://support.apple.com/kb/PH5042

     

    1. Open Safari if it is not already open.

     

    2. Choose Safari > Preferences, and then click Privacy.

     

    3. In the “Block cookies” section, specify if and when Safari should accept cookies from websites. To see an explanation of the options, click the Help button (question mark).

     

    4. If you want to see which websites store cookies on your computer, click Details.

     

    If you set Safari to block cookies, you may need to temporarily accept cookies to open a page. Repeat the above steps, selecting Never. When you’re done with the page, block cookies again, and then remove the page’s cookies.

     

     

    Thanks,

     

    Matt M.

  • WZZZ Level 6 (12,855 points)

    Do you remember which ones you removed in Firefox? When do the cookies blocked messages appear? Is that only  when you're trying to view or log in to an SSL/https ecnrypted site? Can you give the URL of a site where this is happening?

     

    I think FF might block those cookies if the certificates for those sites have been placed on the Revocation List. I'm not certain of this, but there might be a way to move them back as trusted.

     

    Or you might just delete, then reinstall a new FF app. Unless the Certificates are stored in your Profile.

  • WZZZ Level 6 (12,855 points)

    Screen shot 2013-05-03 at 9.43.10 PM.png

  • WZZZ Level 6 (12,855 points)

    OK, the certificates for Firefox are located in your Firefox Profile>cert8.db. What you can do at least for Firefox is to first download a new Firefox app and put it on the Desktop. Next quit Firefox and navigate to the Firefox folder in your user Library>Application Support. Make a backup copy of the entire folder by Option-click-dragging it to your Desktop, then move the original to the Trash (don't empty the Trash.)

     

    Next open the new Firefox dmg and install it, which will create a new Firefox folder with a new, complete cert8.db. Navigate to the Profile inside the Firefox folder and make a copy of the cert8.db (Option-cick-drag to the Desktop again.) Then trash the new Firefox folder and replace it with the old one (you can just use File>Put Back for this for the one in the Trash) and then finally replace the problematic cert8.db from the old folder with the copy you just made from the new folder.

     

    There probably is a less complicated way of doing this, but I can't think of one right now.

  • WZZZ Level 6 (12,855 points)

    Yes, much easier way. Do this and see if the cookies problem is resolved. (And ignore what I said above about moving items out of the Revocation List. That's something else entirely.)

    The file cert8.db in your profile folder may have become corrupted. Delete this file while Firefox is closed.

     

        Open your profile folder:

     

        On the menu bar, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.

        Under the Application Basics section, click on Show in Finder. A window with your profile folder will open.

        Note: If you are unable to open or use Fire​fox, follow the instructions in Finding your profile without opening Firefox.

     

        On the menu bar, click on the Firefox menu and select Quit Firefox

        Click on the file named cert8.db.

        Press command+Delete.

        Restart Firefox.

     

    cert8.db will be recreated when you restart Firefox. This is normal.

    https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

     

    For Safari, ask over here.

     

    https://discussions.apple.com/community/mac_os/safari?view=discussions#/?per_pag e=50

     

    Message was edited by: WZZZ

  • BadTinkerTec Level 1 (0 points)

    No, too many, they all looked foreign, maybe Checkoslavakian or Russion or something like that, odd alphabet lettering on some as well.  Anyway they had expired dates so I thought they were nothing I needed.  Maybe that was short-sighted of me.  I did try re downloading Firefox but I had not done anything special to remove it first.  I did try allowing cookies with the helpful tips from Matt M.  Funny it seemed so much easier to turn them off than to locate the very same place to turn them back on.  I looked for half an hour the other day and just couldn't seem to get to the correct tab.  Bad mind cramp, sigh....

  • BadTinkerTec Level 1 (0 points)

    Thanks Matt, cookie errors are gone now, nit sure if I need the certificates I removed or not, things appear to be working alright so maybe they were ok delete.  No idea how they got loaded in to begin with.  I sure don't remember givign approval to install them which is how I thought certificates get loaded.. ?  Maybe they came with Firefox...

  • WZZZ Level 6 (12,855 points)

    If you are concerned that you removed any legitimate certificates, the instructions in my last post give you a very simple way to get a new, default set. FWIW, I have none in Your Certificates, People, Others. Just in the other categories.

     

    Screen shot 2013-05-04 at 6.24.48 AM.png

  • BadTinkerTec Level 1 (0 points)

    OOPS!  I tried to close out this question by indicating your suggestion solved my issue but I did it in the wrong place.  Sorry. You should get the point credit on this. 

     

    Newbies, humbug :-|