3 Replies Latest reply: Jul 14, 2013 1:28 AM by got2surf
jaspalm Level 1 Level 1 (0 points)
  • On xcode 4.6.2 Assistant Editor does not show the corresponding .h file for a storyboard - Message is No Assistant Results
  • When i manually open the ViewController.h file and try to control drag from a button to the .h (or .m) file i get the message - "Could not create new outlet connection : Cound not find any information for the class named MyViewController"

 

I have looked at numerous stackoverflow forum posts and tried the following

  • close project & restart xcode
  • Creating a new project and testing the functionality
  • deleting the .m file (reference only) then adding it back in to the project
  • clean project - restart xcode
  • add a "Copy Headers" build phase to the target
  • followed the Utilities navigation view of Xcode, in the Target membership section, uncheck & check the checkbox
  • Deleting and recreating the nibs and View Controllers with the same names as before
  • Deleting derived data from ~/Library/Developer/XCode/DerivedData folder and REMOVE all subfolders there referencing the project
  • In the Identity Inspector for the storyboard the custom class is the name of the .h file

 

I am just short of reinstalling OSX as i have even tried reinstalling xcode by deleting all settings. (even tried 2 earlier versions) and i still have the same issue!

 

Help!!!


MacBook Pro, OS X Mountain Lion (10.8.3), xcode version 4.6.2 (4H1003)