12 Replies Latest reply: Mar 30, 2014 12:05 PM by toebinator Branched to a new discussion.
Vicngtor Level 1 Level 1 (0 points)

I have an old macbookpro:

 

 

Model Name: MacBook Pro

Model Identifier:   MacBookPro6,2

Processor Name: Intel Core i5

Processor Speed:    2.53 GHz

Boot ROM Version:   MBP61.0057.B0F

 

 

I created a windows usb with bootcamp assistant, "Create a Windows 7 or later version install disk" with a windows 7 ISO image.

 

 

I went through bootcamp's "Install or remove Windows 7" option and partitioned 21GB from my harddisk for my windows partition (it's named "BOOTCAMP", MS-DOS (FAT)).

 

 

I plugged in my usb and restarted my laptop. I pressed option during boot to go into the boot menu. Somehow, my usb stick doesn't show up in the boot menu. I only see my normal boot partition and a recover partition. I tried removing the USB stick while I am still in that menu and plugging it back to see if that will fix the problem. It did not.

 

 

Strangely, I noticed that my USB stick does not light up when I unplugged it and reinserted it when my mac is in the boot menu. Normally the usb stick will light up when inserted into this usb port.

 

 

I thought my ISO is not bootable so I tried another windows 7 ISO and the results remain the same.

 

 

Is it possible that my model is too old such that it doesn't allow booting from USB during boot time? Is it possible that older ROMS do not check for USB drives during boot time (hence explaining why my usb doesn't light up)?

 

 

I can assure you that my usb port is functioning correctly (at least during Mac OS X run time).


MacBook Pro, Mac OS X (10.6.7)