Announcement: Update to iOS 12

Enjoy a faster and more responsive experience as well as fun new features, like Memoji and Camera Effects.
Get iOS 12 > https://support.apple.com/ios/update

Related Article

If you can't use AirPlay or mirror your device's screen

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: No Airplay icon on iPad 2.

My wife has an iPad2 w/ iOS 6.1.3 we just purchased AppleTV, but have no AirPlay icon on the iPad. I have read the posts, tried troubleshooting, both are on the same network. AirPlay is enabled on AppleTV. But still no icon on th iPad.

iPad 2, iOS 6.1.3

Posted on

Reply
Question marked as Helpful

May 7, 2013 9:08 PM in response to Texas Mac Man In response to Texas Mac Man

I found this fix from 2010 when someone upgraded their software and ended up loosing Airplay....sounded crazy but totally worked! My airplay icon is back, and working!!


On your iPad, iPhone or iPod touch, navigate to Settings > General > International > Language and change to a different language (e.g. if you are using English, switch to French). The device will go through a language switch/reset process, and your AirPlay icon should be restored.


Next navigate back to Settings > General > International > Language (translated into the new language, of course) and switch back to your original language.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

May 7, 2013 9:08 PM in response to Texas Mac Man In response to Texas Mac Man

I found this fix from 2010 when someone upgraded their software and ended up loosing Airplay....sounded crazy but totally worked! My airplay icon is back, and working!!


On your iPad, iPhone or iPod touch, navigate to Settings > General > International > Language and change to a different language (e.g. if you are using English, switch to French). The device will go through a language switch/reset process, and your AirPlay icon should be restored.


Next navigate back to Settings > General > International > Language (translated into the new language, of course) and switch back to your original language.

May 7, 2013 9:08 PM

Reply Helpful (7)

May 8, 2013 9:57 AM in response to aellis1519 In response to aellis1519

Thank you sooooo much for that solution aellis1519, I have been trying to sort out my own lost icon for weeks now with no luck.

By sheer chance I came across the same question (after discovering this forum) and then I read your reply.


🙂 So I tried it and it WORKED...yippee! ...now all I can hope for now is that the wretched thing stays put. lol

May 8, 2013 9:57 AM

Reply Helpful

Aug 15, 2013 12:00 PM in response to Jasonr7974 In response to Jasonr7974

Hi,

Was so hopeful this would resolve my problem with no airplay icon on iPad 2 or iPhone 4S after IOS upgrade and installation of ATV. Have tried all the recommendations-rebooting the modem and router, unplugging ATV, reboot iPad, iPhone. ATV has airplay on and all devices set to same network. Tried the language change trick mentioned above and no luck. - no airplay option/icon showing up on either device. Downloaded some tv shows using my ATV so Network connection appears to work ok on the ATV setup. Just can't get my devices to interact with the ATV which was the main reason I installed the ATV. My router is an AirPort Extreme.


Any other suggestions? don't know if the latest IOS upgrade caused the problem or not because I wasn't using ATV before the upgrade. Any help much appreciated.

Aug 15, 2013 12:00 PM

Reply Helpful

Nov 9, 2014 5:27 PM in response to aellis1519 In response to aellis1519

This solution worked!

After upgrading an iPad Mini to iOS 8, I no longer could see my audio devices in Airplay.

After following aellis1519 suggestion....Now I see them consistently: Phillip Fidelio and Pioneer X-SMC3


--------------------

aellis1519 May 7, 2013 9:08 PM
Re: No Airplay icon on iPad 2. in response to Texas Mac Man


I found this fix from 2010 when someone upgraded their software and ended up loosing Airplay....sounded crazy but totally worked! My airplay icon is back, and working!!


On your iPad, iPhone or iPod touch, navigate to Settings > General > International > Language and change to a different language (e.g. if you are using English, switch to French). The device will go through a language switch/reset process, and your AirPlay icon should be restored.


Next navigate back to Settings > General > International > Language (translated into the new language, of course) and switch back to your original language.

Nov 9, 2014 5:27 PM

Reply Helpful
User profile for user: Jasonr7974

Question: No Airplay icon on iPad 2.