1 Reply Latest reply: May 3, 2013 6:46 PM by Niel
jdbzmum4 Level 1 Level 1 (0 points)

I'm not a very confident user of my computer when it comes to updating or installing new software.  I have not long brought an i phone and it tells me that it is not compatible with my Mac.  I have been told that I have to go thru every update till I get to the latest one ... is this true?


iMac, Mac OS X (10.5.8)