Previous 1 2 3 4 Next 44 Replies Latest reply: May 6, 2014 7:29 AM by DEWnVA Go to original post Branched to a new discussion.
  • pdroth Level 5 (5,100 points)

    #3 works 100% of the time when #1 and #2 has failed.

  • Lana207 Level 1 (0 points)

    I had the same problem when I switched from iPhone to Samsung galaxy 4S. We tried several of the suggestions on this post what seemed to finally work for me was going into the settings of my iphone and iPad and turning off iMessage, mms messaging and group messaging. I am now receiving text messages from iPhones.

  • NetEng33 Level 1 (0 points)

    Nice bias apple user response....c'mon.  Just because I am not an apple user doesn't mean I bash them.  I am a S4 user as well and a lot of friends, family, and business contacts have iPhones - so yes it is pretty frustrating that a popular phone/software company attempts to force all into a single box.  I am sure you can imagine how I educate my Apple contacts so we can communicate the way we would expect to.

     

    There is a standard and when adhered to then all providers/manufacturers can provide their user base the access and ability to communicate with all.  This is just another example of how any company can get the engineering wrong because they only included their own user base and didn't even consider the rest of the population - or they simply don't care about their stuff working with others.  That is what we purchase as a customer - if our provider provides solutions under this mindset.

     

    I am sure iMessage is cool, but you excluded scalability and usability in order to enable communication.  iPhone is by far not a monopoly on mobile computing.  C'mon guys...just fix it, make defaults scalable solutions, then market the heck out of your "nifty" things and how to turn them on or engineer them so it still works with the standards that all providers are using right out of the box - the first time.

  • mosambo Level 1 (0 points)

    I followed krivera'a advice, and iphone's were able to text me after step #1.  When you go to iCloud, click on the "find my iPhone" icon, then look under the "devices" tab.  My old iphone (acutually both my old iphones) were listed there.  I deleted them, and my S4 Galaxy started recieving tests from iPhone. 

    Thanks for the advice Krivera.

  • krivera77381 Level 1 (0 points)

    I'm glad I could help. It drove me crazy for a day or so before I figured it out.

  • code monkey Level 1 (0 points)

    is there a buffer time between when you unregister and when the texts start sendin normally? i unregistered all imessage devices a few minutes ago but i am still receiving as imessage (aka not receiving)

  • Bmxracer546 Level 1 (0 points)

    That is very interesting. i have never heard of anything like that before. but yes, do call apple and see what they can do. they are very helpful. they will help you as much as they can. samsung doesnt really seem to care just as long as you have there phone. thats why i do not like samsung or android/droid

  • krivera77381 Level 1 (0 points)

    Well I tried three things that finally took care of the issue. It could have been any one of the three or all three. It is possible that it needs a while to replicate the change that you made by removing the device, but I would try the other two as well, I won't hurt anything to do so.

     

    1. Logged into iCloud and removed my old iPhone from my profile.

    2. Reset the password on my apple ID so that any other ios device that used my profile would be forced to resynch.

    3. Removed the phone from my support profile by going to https://daw.apple.com, logging in and removing the phone.

  • krivera77381 Level 1 (0 points)

    That's because it's not an issue on Samsung's side, it's on apple's side. It only affects iPhone users with iMessage enabled. I had my friend turn iMessage off and I received his text just fine, when he enabled it again, I didn't receive any of them. Sounds like an iPhone issue to me... How would Samsung be able to do anything about it? I kept poking around and trying different things to make it work, hence my three recommendations.

  • Sheais7725 Level 1 (0 points)

    Finally fixed as well!

     

    Unregistered old iphone: didn't work

     

    Had friends change to "send as SMS' on their iphones: Didn't work

     

    Turned off iMessage in my iPad (had already traded in my old IPhone 4S): Didn't work

     

    Changed my Apple ID password: FINALLY WORKED.

     

    I think it's incredibly sneaky of Apple to do this. To many people, it would seem the new phone is to blame. It's not. It's Apple's proprietary crap. Never going back to Apple as this wasted most of my day trying to fix.

  • rramon Level 1 (0 points)

    This is the way I got mine to work. I went into iTunes and went to my account settings and under the section titled iTunes in the Cloud there is a Manage Devices link, I clicked on that and then removed the iPhone.

  • JeffDR Level 1 (0 points)

    Just wanted to say thanks for all of the advice given here. It helped me resolve the issue. My AT&T rep was not very helpful. Polite and friendly, but not helpful. She kept lying to me. Whatever the phone did, she would be like "oh, that's how it's supposed to work". I'm like "But...my wife can't text me. That's how it's supposed to work?!?" Sigh.

     

    Anyway, thanks to you smart people, I was able to get the issue resolved.

    My fix was:

    1) Reset my apple ID password.

    2) Boot my old iPhone, and verify it no longer knew how to iMessage.

    3) Make sure my iPhone friends turn on "send as sms" in the iMessage settings for a more seamless experience (rather than manually re-sending as txt sms).

  • Lill0ne Level 1 (0 points)

    I had to do all 3 too. I believe you need to do all 3 to make it work. Thanks for the info you made my day

  • Flacco10 Level 1 (0 points)

    A friend of mine had this issue.  The problem corrects itself in time.  I think it has something to do with the fact that the phone was an iphone and it still in the cel provider as such untill their "cache or dns" or whatever other settings need to be reset.  Not saying thats what happens, just assuming since the problem corrected itself after like 20 days or so.

  • Onne Level 1 (0 points)

    I have a simple solution.

    The person who has the iPhone sending you the text messages your are not getting, has to press and hold the blue message box until the menu pops up and one option is to "Send as Text Message" tap that - have them send another new message to you, if it is blue, not green, repeat. I beleieve if you do that twice, the iPone will always send you a text message, not an iMessage.