Previous 1 2 Next 19 Replies Latest reply: May 7, 2013 6:55 AM by Linc Davis
JeremyinPDX Level 1 (0 points)

Alright, I've scowered the internet and read several other topics, but none of the suggestions presented there helped fix my problem, so I'm throwing this at the support discussions. Thanks in advance for your help/suggestions/advice!


My wife and I live in an apartment building that provides wifi for the entire building. It's password protected, and about every 24 hours, you'll get a splash page (I don't know if that's the proper term) where you have to scroll through the building's terms & conditions and click "I Agree" before you can continue surfing. We had absolutely no problems with this setup for 9 months, then suddenly we lost all connection in our unit about 10 days ago. Between my wife and I, we have a Macbook Pro, iMac, Windows 7 laptop, 2 iPhones, iPod touch, and iPad mini, and none of these devices could connect. Unfortunately, the router and modem for our building's connection is located in another renter's unit, so I can't just reset them whenever I want. However, we did have them try this several times, but it didn't help. I even asked them to rotate the antennas on the wifi router, to see if somehow they got bumped and our unit became a dead-spot. Unfortunately this didn't work either. I even purchased a brand-new iPad mini and it never connected, right out of the box.


If I wander the halls of our building, I am able to get online in Safari and browse the internet on both the Macbook Pro and the iOS devices. However, once I go back into my apartment, I get the message that I am no longer connected to the internet, despite having the full signal at the top of my screen. Then, for no apparent reason two days ago, our Windows 7 laptop regained connection in our unit, and has consistantly worked since then. Just today, I renewed the DHCP lease on the iMac, and it has been connected for several hours. Occasionally, the Macbook Pro will connect in our apartment until, but the connection literally lasts for about 60 seconds before it goes back into the "You're not connected to the internet" mode. I've tried renewing the DHCP lease on the Macbook Pro as well as the iOS devices, but it doesn't seem to do anything.


Here's what my wifi connection page on the Macbook Pro looked like yesterday when I was in my apartment and I didn't have internet connection, despite the fact it said I was connected:

Screen Shot 2013-05-03 at 6.43.48 PM.png


and then here's the MacBook Pro's wifi connection page looks like when I am out in the hallway and able to connect to pages on Safari:


Screen Shot 2013-05-04 at 8.06.03 PM.png


Lastly, (I don't know if this is helpful or not) but here's the connection page on the iMac, when it is working...taken at the same time as when the Macbook Pro was connected when I was out in the hallway:

Screen Shot 2013-05-04 at 8.10.13 PM.png



A couple of thoughts:


Does the iMac have a larger wifi range than the other devices? It seems that in the past, I've been able to see/connect to more wifi networks on my iMac than I have on my Macbook or iOS devices. Could it just be that the Windows laptop and the iMac are able to reach our network, while the iOS devices are having a hard time for some reason? Particularly odd that all devices worked for 9 months then suddenly stopped.


I'm asking the apartment manager if they she contact our local cable company about replacing the modem and/or wireless router. Given that I've never seen these (they're in someone else's unit) I have no idea how old they are, or if they need firmware updates.


Do you think this is a problem with the wifi network (range/dead spots), the router/modem hardware, or a problem with my computer/devices?


I'd love to get all my devices connected again (seriously, they all worked for 9 months before stopping suddenly), but I'm kind of working on the MacBook Pro first, and then will try and get the other things sorted out.


Thanks for your help!

-J- (writing from the hallway of my apartment complex!)

MacBook Pro, Mac OS X (10.7.5)
  • Linc Davis Level 10 (184,525 points)

    There are at least two different wireless networks in the building. The one you connect to in the hallway is served by a router at, and the one you connect to inside the apartment is served by a router at The latter is the one that doesn't work. If you remove it from your list of preferred networks in the Network preference pane, you may be able to connect to the other network.

  • JeremyinPDX Level 1 (0 points)

    Thanks Linc. But isn't it odd then that the iMac is connected to that same router ( and was still working yesterday when the Macbook wouldn't connect to the same router? (Yes, the iMac lost connection overnight when I put the computer to sleep. Renewing the lease hasn't helped either). I went ahead and followed your advice on forgetting the network in my building, but that raised a few more quetsions:


    First, it should be noted that there is only one network name, despite the fact that it looks like there are several networks on the building's router. Does that make sense? It's not like I have "BuildingWifi 1", "BuildingWifi 2", and "BuildingWifi 3" on my list of available networks. It just says "BuildingWifi," even though it looks like I'm connecting to the router on different addresses throughout the building.


    Also, when I went to forget the network, it remained connected until I turned wifi off, then turned it back on. Then, when I selected "BuildingWifi" from the list of available networks, it didn't ask me for the password for the network. I thought it should, since we had to enter this when we first moved into the building or added a new device. Am I doing something wrong in forgetting the network? I selected the network and then hit the "-" button.


    Thanks for your help!

  • Linc Davis Level 10 (184,525 points)

    First, it should be noted that there is only one network name, despite the fact that it looks like there are several networks on the building's router. Does that make sense?


    Conflicting network names may cause the wrong stored password to be sent from the Keychain. Since you're not now being prompted for the password, that may be what was happening.

  • JeremyinPDX Level 1 (0 points)

    So what should I do? Clear the keychain? I haven't looked into how to do that yet. I tried to forget the network both in my apartment and out in the hallway, then went back to the hallway to try and reconnect to the network, an it works in the hallway, but not when I get back to my apartment. I'm not sure how these types of routers work (longer range/more users online). I would imagine that they are similar to the type of routers used in hotels?

  • Linc Davis Level 10 (184,525 points)

    Take each of the following steps that you haven't already tried, until the problem is resolved.

    Step 1

    Ask whoever is in charge of the router to restart it. Many problems are solved that way.

    Step 2

    Back up all data.

    Launch the Keychain Access application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid.

    Enter the name of your wireless network in the search box. You should have one or more "AirPort network password" items with that name. Make a note of the name and password, then delete all the items. Quit Keychain Access. Turn Wi-Fi off and then back on. Reconnect to the network.

    Step 3

    The administrator may need to change other settings on the router. See the guidelines linked below:

    Recommended settings for Wi-Fi routers and access points

    Step 4

    Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

  • JeremyinPDX Level 1 (0 points)

    Well...I worked my way down the list and am still having the problems persist.  I don't really know how these type of connections work, but if I understand correctly, you're saying that the single router is sending out multiple connections throughout the building. It seems like the connection we are getting in our individual unit is down or having interference problems. When I go in the hallway, the router IP number is consistent and works properly. When I go sit on our front stoop, it's a new router IP number, but it consistently works as well. The router IP number we are getting in our apartment doesn't seem to be working right. Could this be caused by a bad router? I guess my question is, would it be useful if I convinced management to contact the cable provider an request a new router?


    Also, new tenants have moved into the building and some have brought their own paid wireless connections with. Perhaps there is some interference from this? Thanks again for your help!

  • CMCSK Level 6 (10,640 points)

    My wife and I live in an apartment building that provides wifi for the entire building.


    First contact your ISP.  You need to confirm that the issue is not on their end.


    Change your router channel.  Sometimes this is all you will have to do.


    Power cycling the router.  Read the router's user manual or contact their tech support for instructions.


    System Preferences/Internet & Network/Network

    Unlock the padlock

    Locations:  Automatic

    Highlight Airport

    Click the Assist Me button

    In the popup window click the Diagnostic button.


    System Preferences/Network- Unlock padlock.  Highlight Airport.  Network Name-select your name.  Click on the Advanced button.  Airport/Preferred Networks-delete all that is not your network.

    Place a check mark next to "Remember networks this computer has joined."  Click the OK button and lock the padlock.  Restart your computer.


  Mac OS: How to release and renew a DHCP lease



    No internet connection (wireless)

    Check to see if an extra entry is present in the DNS Tab for your wireless connection (System Preferences/Network/Airport/Advanced/DNS).

    Delete all extra entries that you find.

    Place a check mark next to "Remember networks this computer has joined."



    Other resources to check into:

    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6


    Configuring 802.1X in Mac OS X Lion and Later


    Non-responsive DNS server or invalid DNS configuration can cause long delay before webpages load




    How to diagnose and resolve Wi-Fi slow-downs


    Pv6 troubleshooting


    What Affects Wireless Internet?


    Solutions for connecting to the Internet, setting up a small network, and troubleshooting



    If using one of Apple's Airport routers, read its user manual or post in its forum area. If using a 3rd party router, read its user manual, contact their tech support department/website or post in its forum area.













  • Linc Davis Level 10 (184,525 points)

    The router has been restarted?

  • JeremyinPDX Level 1 (0 points)

    Well, not today. But this was the first thing that we tried when the issue occured several days ago, and has been done several times since. It's difficult because I don't have access to the router as it's in another person's unit. Maybe I should specifically ask them to unplug and replug in the router? I don't know what they're doing for sure when they tell me "Yeah, we reset the wireless for you."

  • JeremyinPDX Level 1 (0 points)

    First contact your ISP.  You need to confirm that the issue is not on their end.


    The manager called the ISP and they said it wasn't anything on their end (of course). They offered the "tell the tenant to run a software update on their computer" as the solution.



    Change your router channel.  Sometimes this is all you will have to do.

    How do I do this without having physical access to the router? It's in another person's unit, and I don't know them. I don't think they're very tech-savvy either.

  • Linc Davis Level 10 (184,525 points)

    If you took all the steps above, I don't know of anything else you can do without having control over the network. That's why it's a bad idea to depend on someone else's wireless network. If possible, you should try to get your own Internet service instead of using the building's network.

  • mcsound Level 2 (285 points)



    How many units are in your apartment complex?  Depending on the type of equipment they are using to create the wireless network, the ROUTER could be running out of connections.  The access point may be limiting the number of dhcp leases it hands out.  You posted that you have 7 internet devices in your apartment alone.  How many does everybody else have?  Perhaps you need to adjust the router to shorten the lease time for DHCP leases. 

  • JeremyinPDX Level 1 (0 points)

    There are 20 units in the building. I know some people have their own, private connections (we are thinking we might need to do that too). It's just so weird that the provided wifi connection worked with no problems for 9 months, then suddenly stopped for us. The manager has said that no one else has reported any problems. Is there a way for me to adjust the router settings you're referring to remotely, like through Safari? Can I just log into it and increase the number of ports allowed?

  • Linc Davis Level 10 (184,525 points)

    Is there a way for me to adjust the router settings you're referring to remotely


    Not without knowing the password.

Previous 1 2 Next