Skip navigation

MacBook Pro Can't find home wireless network

12358 Views 18 Replies Latest reply: Apr 13, 2014 11:42 AM by RamArun66 RSS
1 2 Previous Next
zambeezy Calculating status...
Currently Being Moderated
May 5, 2013 11:20 AM

I've been having some issues getting my macbook pro, running OS 10.7.5, to find my home wireless network. The network doesn't show up when it searches automatically, and when I type the network name in to find it manually, it says no network found. The computer connects to all other networks and finds then with no issues, and other MacBooks are able to find my home network and connect to it again with no issues.

 

The computer used to be able to find the network, and then it just stopped working. I have tried all the standard fixes, resetting the router, computer, PRAM, forgetting the network, deleting the key from keychain, but nothing seems to work. I tried googling the issue, but wasn't able to find a problem similar to the one I have.

 

Any advice would be greatly appreciated.

 

Thanks

MacBook Pro, Mac OS X (10.7.5)
  • portiao Calculating status...
    Currently Being Moderated
    May 11, 2013 12:50 AM (in response to zambeezy)

    I had this EXACT problem with my mac and it was frustrating me for days!

     

    Check into what channels your airport can pick up. My problem was that my router was set to "auto", ie choosing to pick up from 1 - 12 and had been on 12 for the last few days and as it turns out, my mac only picks up 1 - 11! Once I changed the router channel to 11, all was fixed!

  • TropicalDawn Calculating status...
    Currently Being Moderated
    May 11, 2013 1:40 AM (in response to portiao)

    Thanks! I was having exactly this same issue and your solution worked! We changed the router channel to something below 11 (we just picked 8), and my MacBook Pro instantly found my home network and connected as it always used to.

  • nickraj Calculating status...
    Currently Being Moderated
    Jul 2, 2013 12:17 PM (in response to TropicalDawn)

    Finally, a post that helped resolve a very annoying issue. Did the exact same thing: logged into my router from a different computer that was picking up the wi-fi, changed the channel to 01 and now the MBA picks it up just fine. Thanks all.

  • Oliver At home Calculating status...
    Currently Being Moderated
    Jul 27, 2013 6:54 PM (in response to portiao)

    This is great! It worked for me! I logged in with my apple id just to thank you!

  • prasanthfromind Calculating status...
    Currently Being Moderated
    Sep 26, 2013 4:55 AM (in response to nickraj)

    nickraj, can you please mark the above answer as accepted?

  • Maz K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2013 4:38 AM (in response to zambeezy)

    Hi there,

     

    I realise the issue has been solved but I had a similar problem with my MB using a WiFi router. I was playing about with trying to create a home network and I'm pretty certain I didn't play with any network config settings, but anyway, I couldn't connect to my router nor could I see any available networks.

     

    When I switched to bootcamp, I could connect.

     

    Checked as much as I could and after several restarts, of MB and router, it still couldn't connect.

     

    So I SHUTDOWN the MB and restarted it and it worked. I don't know why this would work because I thought a shutdown was part of the restart process.

     

    Perhaps someone can correct me please.

     

     

    Regards,

     

    Maz

  • Firstpost Calculating status...
    Currently Being Moderated
    Oct 31, 2013 11:08 PM (in response to portiao)

    thanks a lot buddy this prob was bugging me since few days no other thread has this solution cheers !

  • Maz K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 2:34 AM (in response to Firstpost)

    Still having problems with this.

     

    I have upgraded to Mavericks, hoping that the problem would be fixed, but it hasn't. I still get all networks completely disappearing - even if I search for them they are not found.

     

    But I reboot the computer and it works! But when I am in OS or Bootcamp mode and put the Mac to sleep, it does not see the networks again! I have to reboot the computer for it to work.

     

    I have even got a new router which can receive the b,g and n signals etc. as I was told by a Mac techie here that Macs 'look' for the n signal but can also work with the b and g signals and THAT maybe my old router only transmits b and g or something like that .

     

    This, to me, sounds like a Mac software problem. I had a similar problem on a previous Mac on my "old router" and a totally different router in a different country's telephone system.

     

    I now have the same problem with a new MBP on a new router!

     

     

    Maz

  • Maz K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2013 2:24 PM (in response to Maz K)

    This is a very irritating problem and Apple should fix this. 1 hour to actually see the WiFi networks and finally connect.... I thought Mavericks would address this issue as it is definitely software.

     

    This really needs to be looked at      and resolved once and for all.

     

     

    Maz

  • Sepehr.E Calculating status...
    Currently Being Moderated
    Nov 9, 2013 12:44 AM (in response to Maz K)

    Dear Maz K,
    I think you haven't seen the answer by Portiao. I had the same issue you are having right now for months and I had to turn wifi on/off for a bunch of times (sometimes I had to do it for 20+ times) untill MBP could finally find my network. But a week ago I saw Portiao's answer which is the fix for this problem.

    All you have to do is going to your router setup page and change the number of channels in the wireless sections from "auto" to something below 12. In my case even 11 didn't work, so I changed it to 8 and everything is fine now.
    Thank you so much Portiao for finally solving this irritating issue.

  • Maz K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2013 1:00 AM (in response to Sepehr.E)

    Hi there Sepehr,

     

    Actually I have seen this method on several websites as well. Changing the channel number to 6 and 11 as had been suggested has not resolved this issue.

     

    I was told that I needed a router that was 'n' setup by a couple of techie guys and this hasn't worked.

     

    Although, I am currently setup in my router as Auto channels and I have not had this problem for a good few days now but I'm not sure how long this will last for!

     

     

    Thanks,

     

    Maz

  • jdames Calculating status...
    Currently Being Moderated
    Nov 23, 2013 2:17 PM (in response to portiao)

    Thanks portiao. That worked just fine for me too. My router was running on ch 13. I changed it to 8 and wi fi was back instantly.

  • Maz K Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2013 3:25 PM (in response to jdames)

    I haven't had this problem in ages and my router is in Auto mode.

     

    However, I have a utility called iStumbler which scans the local networks and lets me know which is the least used channel. I then configure my router to that channel. saying that, my Mac  has been ok for the last two weeks.

     

     

    Maz

  • VFHL Calculating status...
    Currently Being Moderated
    Dec 6, 2013 11:18 PM (in response to portiao)

    I had the similar problem. Your solution worked in a jiff!! Thanks alot.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.