1 Reply Latest reply: May 5, 2013 7:47 PM by Linc Davis
AppleJason Level 1 Level 1 (10 points)

When attempting to connect calendar to my business's gmail server (google apps) I'm getting "certificate mismatch" and "couldn't establish secure server connection" error. 


The cert that it sees for our domain is really a cert provided by our web hosting provider, for our website. 


I have no problems connecting to our gmail via a browser (it's secure, no cert problems), as we connect to https://mail.google.com and login with our full "name@domainname.com".  But it appears calendar is using the "domain name" to try and find a cert and using the mx record to find a secure server at @domainname.com - instead of using mail.google.com.


Any ideas where to begin? 

MacBook Air, OS X Mountain Lion (10.8.3), 2012 Model (1.8ghz i7)
  • Linc Davis Level 10 Level 10 (173,735 points)

    Back up all data.


    Launch the Keychain Access application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid.



    In the upper left corner of the window, you should see a list headed Keychains. If not, click the button in the lower left corner that looks like a triangle inside a square.
    In the Keychains list, there should be an item named System. If not, select
    File Add Keychain
    from the menu bar and add the following item:
    From the Category list in the lower left corner of the window, select Certificates. Look carefully at the list of certificates in the right side of the window. If any of them has a a blue-and-white plus sign or a red "X" in the icon, double-click it. An inspection window will open. Click the disclosure triangle labeled Trust to disclose the trust settings for the certificate. From the menu at the top, select
    When using this certificate: Use System Defaults
    Close the inspection window. You'll be prompted for your administrator password to update the settings. Revert all the certificates with non-default trust settings.

    From the menu bar, select


    Keychain Access Preferences Certificates


    There are three menus in the window. Change the selection in the top two to Best attempt, and in the bottom one to  CRL.


    Log out, log back in, and test.