Previous 1 2 Next 27 Replies Latest reply: Oct 3, 2014 3:11 PM by EdwardApple
DianeReno Level 1 (0 points)

I have a pair of Nokia BH-905i bluetooth deadphones which have apt-x codec compatibility.  Regardless of what I try, only the SBC codec shows up as being used in my 2012 MAcbook Air.  I've gone through the threads here and have tried that various terminal commands ( set the min bitpool size to 53 , etc.), , used bluetootk explorer with the appropriate settings, paused and restarted the stream, rebooted numerous times and ...  nada.  Regardless of what I have tried (and I am using no other bluetooth devices) I have bo apt-x codec showing up - only SBC shows up when i alt-click the bluetooth icon, etc.

 

Why is the Macbook air being advertised with apt-x capibility when apparently it does not have this??   

Does anyone else have any other suggestions as to why this is not working?


MacBook Air, 2012
  • Techn0lady Level 1 (0 points)

    Same situation with the new Macbook 2013.  OSX 10.8 does NOT support APT-X 

  • phatmatt Level 1 (5 points)

    APT-X doesn't get used when other Bluetooth devices are connected, or you are on b/g (2.4GHz) WiFi. Could that be why you aren't seeing it used?

  • Techn0lady Level 1 (0 points)

    Thanks for the info but this test was on a clean install of a 2013 MBA and I don't use b/g wifi - only N.  BTW where did you get the info regarding the b/g issue?  I'd appreciate a link if available.

  • rideMTB Level 1 (0 points)

    It may be necessary to turn on the aptX codec via Bluetooth Explorer -> Utilities -> Special Options

     

    That did the trick for me.

     

    The bluetooth explorer used to be available by pressing option then the bluetooth button, but now its bundled seperatly either with xcode or here : https://developer.apple.com/downloads/index.action?name=bluetooth%20explorer

  • Techn0lady Level 1 (0 points)

    As was mentioned in my original post, I already tried Bluetooth explorer.

  • rideMTB Level 1 (0 points)

    Is the aptX option available under special options? I checked the box, exited bluetooth explorer, turned bluetooth off and on, and then aptX was in use.

  • Techn0lady Level 1 (0 points)

    You're not really listening are you?

  • sjstone Level 1 (5 points)

    I have a similar problem.  I used the Bluetooth explorer from the October HW IO Toolkit download and went to "Tools->Audio Options" and checked "Force use of aptX", but it still shows the codec is "SBC" when using the "alt/option + click" on the Bluetooth icon.  I'm currently running OSX 10.9 on a 2012 MacBook Pro w/ Retina Display.

     

    Does anyone have this working?

  • Raffael M. Level 1 (0 points)

    same problem with macbook air mid 2012. tried every solution i've found here in the forum. nothing worked. :-(

  • basic Mac user Level 1 (0 points)

    Hi All,

     

    I've had a go at this, my MacBook Pro is a 13-inch, Early 2011 running OS X 10.9.1 (13B42).

     

    I am not using Bluetooth headphones, but am using a QED uPlay Plus. Should be the same process anyway ?!

     

    So sign up as a developer on the above link that one of the posters added, download the DMG file and open up Bluetooth explorer.

     

     

    Screen Shot 2013-12-18 at 11.06.13.png

    Select audio options

    Screen Shot 2013-12-18 at 11.06.54.png

    Make sure aptX is ticked then disconnect from device and re-connect

    Once you have done that hold down option key and select your Bluetooth option on the top of the desktop

    Screen Shot 2013-12-18 at 11.10.23.png

    You will see your paired device if you hover over it then on the left you will see the codac being used as below

    Screen Shot 2013-12-18 at 11.16.11.png

     

    My QED uPlay glows blue when using standard codac then purple when using aptX

  • Raffael M. Level 1 (0 points)

    that's exactly what i did and tried again and again, but it doesn't work for me. =(

    MacBook Air 13" mid 2012 with OSX 10.9 (will try it under 10.9.1 at the evenening)

  • sigamore1 Level 1 (0 points)

    well it should work... please follow the instructions above.

     

  • Techn0lady Level 1 (0 points)

    It still does not work (following the above instructions once again)  on a late 2013 Macbook 15 Retina with the Nokia BH-905i (apt-x) headphones and Mavericks 10.9.1 as of today .  I downloaded the latest version of Bluetooth Explorer (Oct '13) with no sucess

  • basic Mac user Level 1 (0 points)

    Hi,

     

    I did notice that the codec was only listed when playing music. Also i had to disconnect and re-connect Bluetooth after selecting the aptX codec in Bluetooth explorer. Only then was it listed!

     

    Maybe this is down to incompatibility? Have you contacted Nokia? Although i doubt their support even know what aptX is

Previous 1 2 Next