6 Replies Latest reply: May 16, 2013 5:54 AM by rkaufmann87
Budm17 Level 1 Level 1 (0 points)

A few days ago my iMac gave me the "pinwheel of death" so I cold shutdown and rebooted. I heard the chime and then I got this flashing folder with a question mark on it. I quickly jumped on my Macbook pro and researched what it meant. I tried booting while holding the option key and would get a blank white screen with a mouse pointer and nothing else. I tried resetting my PRAM and still nothing! Then I saw someone say to restart my iMac while holding down R to start into disk utility. It worked! I went through the repair disk process and it said there was nothing to repair. I then repaired disk permissions, and bingo it had to repair a few different things that needed to be repaired. Once the repair process finished I rebooted to my main drive and everything worked fine. That night I shutdown my computer and the next morning I got the flashing folder again. This time however, after shutting down and rebooting everything worked fine. Now today my iMac froze and I cold shutdown and rebooted. I got the flashing folder and question mark again. This time nothing is responding. I tried rebooting while holding the option key, tried booting into disk utility and still nothing. The only thing that the iMac will recognize is when I reboot while holding the 'option' key and put in the Mac OS X Lion install disc It lets me click that disc and it starts the install cycle... I really don't want to do this as it would wipe everything on the drive and I do not have a lot of documents backed up. What do I do? Am I screwed? Help would be greatly appreciated!

 

Thanks much!


iMac, Mac OS X (10.7.5)