6 Replies Latest reply: May 16, 2013 12:37 AM by Akominatus
Akominatus Level 1 Level 1 (5 points)

A few months ago I upgraded my system to OS X 10.6.8. Yesterday, I tried to use my Epson Stylus Pro 3800 inkjet printer fro the first time since the upgrade, but wasn't too surprised when I got an error message saying I needed to install software. I found the latest driver software for the 3800 on the Epson (USA) site, dated 5/3/13 and installed it. After re-booting, I tried again to print with the 3800, only to get the same error message: "You need to install software to use this printer. To install the softweare, choose Software Update from the Apple menu. If the software for yor printer isn't available in Software Update, contact the manufacturer of your printer".

 

Well, there is nothing relevant at all listed under"Software Update", and I reckon I have already carried out the second suggestion by downloading the latest Epson driver. Can anybody help? I depend on the 3800 for professional work, and certainly can't afford to replace it...

 

Thanks in advance.


iPad 2, iOS 6.0.1
  • Akominatus Level 1 Level 1 (5 points)

    Perhaps I should add that:

     

    1. I am using Adobe Photoshop CS5;

    2. I could not download a driver from the Epson UK site because... well, because the 3800 is not listed at all on the Epson UK site, even though the printer was bought in Europe. Go figure...

  • LilyLC Level 4 Level 4 (2,635 points)

    Akominatus wrote:

     

    ...I found the latest driver software for the 3800 on the Epson (USA) site, dated 5/3/13 and installed it. After re-booting, I tried again to print with the 3800, only to get the same error message: "You need to install software to use this printer.

     

    There is no such driver "dated 5/3/13" for the Epson Stylus Pro 3800. The latest driver released in the USA was version 8.64 on 10/10/2011.  It is compatible with OS X 10.8.x, 10.7.x, 10.6.x, and 10.5.8. You did not state which OS you upgraded from and what version of the print driver you had before the OS upgrade. That said, did you repair disk permissions after upgrading to 10.6.8?

     

    I depend on the 3800 for professional work, and certainly can't afford to replace it...

    but you stated

    A few months ago I upgraded my system to OS X 10.6.8. Yesterday, I tried to use my Epson Stylus Pro 3800 inkjet printer fro the first time since the upgrade,

    which implies that you use the Epson 3800 occasionally, so "depend" seems...

     

    HTH

  • Akominatus Level 1 Level 1 (5 points)

    Thank you for your response.

     

    1. I have downloaded and installed printer driver version 8.64 from the site suggested;

    2. I have repaired disk permissions again;

    3. I am still getting the same error message as above: "You need to install software to use this printer....";

    4. My previous operating system was OS X 10.5;

    5. Other Epson printers work correctly; it is only the 3800 which refuses to perform.

     

    Any further suggestions gratefully received.

  • Baby Boomer (USofA) Level 9 Level 9 (56,815 points)

    Check this list:  http://support.apple.com/kb/HT3669 Printer and scanner software available for download

     

    If the above is not applicable, call Epson tech support.

     

     

     

     

     

     

     

     

     

     

    2ue5vgy.gif

  • Akominatus Level 1 Level 1 (5 points)

    Further to this problem:

     

    I removed all the existing Epson printer files from my computer.

    I also downloaded from the same Epson site Common Updater v.7.0. Once this was installed, a new and different error appeared:

     

    Error: /Library/Printers/EPSON/InkjetPrinter/Filter/rastertoescp.app/Contents/MacOS/ra stertoescp failed

     

    A Problem Report also appears when attempting to print:

     

    rastertoescp quit unexpectedly

     

    The opening lines of the detailed problem report are as follows:

     

    Process:     rastertoescp [232]
    Path:        /Library/Printers/EPSON/InkjetPrinter/Filter/rastertoescp.app/Contents/MacOS/ras tertoescp
    Identifier:  rastertoescp
    Version:     ??? (???)
    Code Type:   X86 (Native)

    Parent Process:  cupsd [21]

     

    Date/Time:   2013-05-16 09:43:12.737 +0300
    OS Version:  Mac OS X 10.6.8 (10K549)

    Report Version:  6

     

    Anonymous UUID:                  D9027E0F-CD1F-4E69-9DCC-3EED71B6FAF0

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x000000005d8918ec

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

    Thread 0 Crashed:  Dispatch queue: com.apple.main-thread

    0   ???                       0x5d8918ec 0 + 1569265900
    1   ...pson.ijprinter.rastertoescp0x0000297a main + 230
    2   ...pson.ijprinter.rastertoescp0x00002522 start + 54
  • Akominatus Level 1 Level 1 (5 points)

    Finally - combination of all the above, plus the sudden appearence of an Epson update from Apple's update seems to have solved the problem.

     

    My thanks to all who took the trouble to respond.