8 Replies Latest reply: Jul 8, 2014 1:54 PM by William Williams
monireh Level 1 Level 1 (0 points)

I have a Macbook Pro 2010 OS X 10.8.3.  I cannot connect to internet via wifi (Air por).  My Macbook Pro does not recognize my network and when I select it from the list of network it asks for my network password.  when I type in my password a dialog box gives me timeout error.  Please could anyone help me.  I am using ethernet for my connection at the moment.  Do I need to reset my macbookpro?  if yes, what will happen to my applications and operating system (mountain lion)?

 

Monireh


MacBook Pro, Mac OS X (10.6)
  • The hatter Level 9 Level 9 (60,795 points)

    When you use the Airport utility what happens?

    What is in the System Preferences control panel for Network settings?

     

    http://www.apple.com/support/airport - there is a forum just for Airport Community

     

    Airport Express FAQ

    http://support.apple.com/kb/HT1515

     

    Wi-Fi Setup Considerations

     

    Things to consider before you begin

    • Start with a plan for the physical layout. Depending on whether you have an existing Wi-Fi network, or if you are using your AirPort Express as a standalone Wi-Fi device, there are several options available for you to choose from.
    • When using Ethernet, Cat6 cable is recommended.
    • The layout you choose should take into account environmental factors such as physical access, location, range, radio frequency interference, etc.
    • You will need to consider what AirPort Utility settings to adopt.
    • You will need to know whether you are using an AirPort Express (802.11b/g) or an AirPort Express (802.11a/b/g/n).

    If you will be using more than one Wi-Fi base station, it may be helpful to read the article Extending the range of your wireless network by adding additional Wi-Fi base stations.

     

     

    AirPort Discussions

    Discuss your AirPort Base Station, Time Capsule and Wi-Fi questions with fellow community members.
    More

     

     

    Direct you to the proper forum for MacBook :

  • Sazzarocksdahouse Level 1 Level 1 (0 points)

    I have the same problem - however I am able to connect to the same wifi with my iPhone and iPad in the same location and the signal strength is full on all three devices.  This suggest to me that its some setting in the MacBook. The answer below is no help to me.

  • miccet Level 1 Level 1 (15 points)

    Try this:

     

    1. Turn off Airport.

    2. Open System Preferences / Network.

    3. Click Advanced

    4. In the list over networks, remove the one you're having trouble with.

    5. Click ok and close System Preferences.

    6. Open Finder.

    7. Press CMD + Shift + G

    8. Enter ~/Library/Preferences into the field that came up.

    9. Search this folder for com.apple.airport (the real file name will be longer, but this is the beginning of it)

    10. Move this file out of the folder (to the desktop or something).

    11. Try connecting again after turning on Airport.

  • ChiBh Level 1 Level 1 (0 points)

    my macbook is able to see and connect to wireless, but cant browse, cant get internet.

    My iPhone is connected to the same wireless but able to browse.

     

    I do have the same issues.

  • pitchfork Level 1 Level 1 (0 points)

    Im having exactly the same issues today

     

    I always intermittently had "Connection timeout" on my Macbook Pro but a router reset always cured it.

     

    Now today I have the "Connection timeout" and cant connect at all to my Router?

     

    I am using ethernet for the time being?

     

    I have upgraded to Mavericks, deleted and reset my router in Network and nothing  -  i;ve got no idea?

     

    My iPhone 5c is online fine, but my Mac wont connect?

  • Max Staudinger Level 1 Level 1 (55 points)

    Same problem suddenly with on MacBook Pro running iOs 10.9.2. This will by no means connect to the network and internet. The wireless nework is set up throug a Time Capsule

    Have no idea where this problem originates. Have in the same network a MacBook Air, iMac 27", iPad, 3 iPhones and even a very old iMac. These connect without any problem !

    Grateful for possible ideas how to solve this. Tryed already to delete old network settings and also the preference file.

  • arthurbikemad Level 1 Level 1 (0 points)

    Quite often in towns etc WiFi is cluttered, if you have a Android phone you can download a WiFi scanner (not seen a good obe for mac etc), it will show you who is who and where they are transmitting, WiFi has channels 1 - 11 but the only "pure" channels are 1,6 and 11, the others share radio space with the three main ones, the scanner may show your WiFi on the same channel as many others, if you log into your router you can change from auto to a fixed channel, select one away from other strong signals if poss, if you have no scanner then try random channels like 1, 6 or 11, new routers like the BT homehub also have 5Ghz, it can be set to transmit on its own 5Ghz channel for your devices, then you have say "mywifi" on 2.5Ghz and "mywifi 5ghz" as less people have 5Ghz routers it can be better for your device, the point of my post is that most WiFi problems are from cluttered radio space, if you wonder why some devices work and others dont its often as the data being sent to each is sometimes recieved better on one than it is on another, radio is funny and reacts in strange ways, walls and other electrical devices play havoc with it so often there is no patturn, its an excelent move to try the WiFi scanner and see who is transmitting what, you'll be shocked to see how busy it can be in town etc.

     

    Arthur

  • William Williams Level 1 Level 1 (10 points)

    Very similar problem here, however at my friend's house, not at home (thank goodness!).He can connect his MacBook Pro (don't know what system version), and my iPhone connects just fine, but my MacBook Pro (10.9.3) gives an exclamation point in the WiFi icon. When I run diagnostics, it says that the wireless router cannot connect to the modem, however, they are the same device (Westel wireless DSL modem). And of course that wouldn't explain why my friend (and others who visit him) can connect just fine. There's obviously something wrong with the configuration on my MacBook Pro, and only on my MacBook Pro. Tried restarting and that didn't help. Other suggestions?