13 Replies Latest reply: Dec 31, 2013 4:56 AM by pkeew
Silver Lighting Level 1 (0 points)

I have rebuilt my Iphoto library following all teh instructions many time now and every time i close and re-open it says it is damaged again. How can I make a permeant fix?

  • LarryHN Level 9 (76,810 points)

    Well that would depend on several thing including what version of iPhoto and of the OS you have, exactly what instructions you have followed and that is happening


    We only know what you tell us so please share enough information that we can assist


    And if you really have followed "all of the instrutions" then it logically follows that there is no possible solution since you have done every thing possible



  • léonie Level 10 (90,471 points)

    And tell, where your iPhoto library is stored. In its default location in the Pictures folder or somewhere else?

  • Silver Lighting Level 1 (0 points)

    Thank you for your reply.


    Iphoto informs me the library is damged when loading teh thumbnails when you first open the app and asks me to quit.


    I have the lastest version of Iphoto, I have transfred the library to a hard drive and back, didint work. Worked from hard drive when i first tried it but then that didnt work either later wither. I have been through all the options on the IP manager for repairing and rebuilding etc. It works after a re-build but when I close and re-open Iphoto it stops working with the same message.


    My mac book is one year old and just out of warranty, I have 10.3gb of pcitures and I emptied the trash as I heard this might work, it didnt.


    If you need any more info to assit I am happy to provide.

  • Silver Lighting Level 1 (0 points)

    Library is stored on the hard drive on my mac book pro, I havent moved it before the error happened or tried to alter it in anyway.

  • Silver Lighting Level 1 (0 points)

    Sorry yes, default location.

  • Silver Lighting Level 1 (0 points)



    Software  Mac OS X Lion 10.7.5 (11G63b)

    Processor  2.4 GHz Intel Core i5

    Memory  4 GB 1333 MHz DDR3

    Graphics  Intel HD Graphics 3000 384 MB

  • léonie Level 10 (90,471 points)

    Have you by any chance enabled file vault for your home folder? Then your photo libraries may have permission problems when your photo library is inside the vault.


    Do you have the same problem with a new iPhoto library? Create a new iPhoto library for testing and add a few images. Does that get corrupted as well? (File > Switch to Library > Other/New)


    I'd also test with a new library in a different user account, for example the  guest account.


    These tests will tell us, if the problem is with your library, your user account, or some system wide problem.

  • Old Toad Level 10 (135,314 points)

    Have you rebooted since this problem started?   If not do so.


    How much free space do you have on the boot drive?.  Also give this fix a try:


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button,

        iPhoto Library Manager002.jpg 

        navigate to your Home/Pictures folder and select your iPhoto Library folder.

      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option

        iPhoto Library Manager001.jpg

      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments. However, books, calendars, cards and slideshows will be lost.

    Note:  your current library will be left untouched for further attempts at a fix if so desired.




  • Silver Lighting Level 1 (0 points)

    First message:


    iPhoto is not responding to commands being sent by iPhoto Library Manager. Please check to see if iPhoto is displaying any error messages or other windows that need to be dismissed. Close any such windows, then click “Continue” to continue the operation, or click “Cancel” to halt the operation.


    2nd Message:


    The photo library needs to be upgraded to work with this version of iPhoto.


    Your photo library will not be readable by previous versions of iPhoto after the upgrade. The upgrade process for very large libraries may take an hour or more to complete.


    When I try to upgrade Iphoto I tune reopen with no library. Working on it still though.

  • Silver Lighting Level 1 (0 points)

    Hi Old Toad,


    Thank you very much I now have a working IPhoto app and library again. I have lost a few photos and folders etc as you said. I now have 1,480 photos to file but I have a working system!


    So Thank you very much again.

  • pkeew Level 1 (0 points)

    Sorry to jump in this thread so late. I have been scouring the forums, and this was the most helpful post I could find about using the iPhoto Library Manager.


    I am currently rebuilding an iPhoto 9 library using the above steps, but I didn't have enough disk space to save the rebuilt library in the native "Pictures" folder. I am saving it to an external hard drive.


    My question is: How should I replace the "damaged" library with the rebuilt library? Is it as simple as dragging it over to the native "User/Pictures" folder? I didn't want to mess up the process at this point.


    Thanks for any pointers you can give!

  • Old Toad Level 10 (135,314 points)

    First verify that the rebuild library is fully operational with all of your photos.  Once you do that you can delete the original library and then drag the rebuild library into the Pictures folder.

  • pkeew Level 1 (0 points)

    This did the trick! I'm glad it really was that simple.


    Thanks so much! I guess all the points for this discussion were already awarded, or I'd give you some more.