4 Replies Latest reply: Oct 24, 2013 2:21 PM by cursed binny
Dave1234567890 Level 1 Level 1 (0 points)

at work we use a proxy server.

 

some icloud programs work, but Messages does not.

 

any idea how to get this to work through a proxy server?

 

thanks.

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    Hi,

     

    In iChat there used to be an option in the Server Settings tab for AIM accounts to use a Proxy or to use the System (Preferences) one.

     

    There was never anything added to the Jabber side.

     

    It never really worked in AIM or Jabber with the App version or the System Preferences setting.

     

    This was when the AIM Logins were on port 5190 using TCP

     

    It did do better if the Server login port was changed to 443

    iChat 6 and Messages have already made the change to port 443 for AIM logins.

     

    Realistically iChat has always tried to remove itself from possible "man in the middle" attacks.

     

    Messages in Mountain Lion removes the option of listing a Proxy for any of the accounts.

     

    I know little of proxies myself to offer anything constructive on this.

     

    3Sigcopy2.png
    10:13 PM      Wednesday; May 8, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • EricS Level 1 Level 1 (5 points)

    Ralph, Messages in Mountain Lion does in fact have the option to set a proxy for AIM accounts.  I have not been successful in getting it to work, using either port 5190 or 443.  Whether this is a problem with the Messages App or my corporate VPN/proxy setup is something I'm still trying to sort out.

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    Hi,

     

    Now I feel really silly.

    I remember the pane looking like this though:-

    serversettings4Proxy.png

     

    As there used to be two iChat forums here at Apple Support Communities  and the older iChat 2.1 one has disappeared I am not sure how many threads might be available for scrutiny on this matter.

     

    AS I said I don't ever recall someone reporting that they got it  to work.

     

    During early version of iChat it was found that the AIM server would accept a login on almost any port.

    It became popular to suggest port 443  as this was a well known port known to be open on most routers "out-of-the-box" and likely to be open in campus situations where students may not have any control over what ports were open.

     

    An AIM Login can also do "Direct IMs" for which is switches to port 5190 on the UDP Protocol.

    At this point the chat is peer to peer.

    It does this if you send a pic in the Chat or send a file.

     

    It uses port 5190 for this no matter what is used for the Login.

     

    3Sigcopy2.png
    7:27 PM      Thursday; May 9, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • cursed binny Level 1 Level 1 (0 points)

    you need to contact your service administrator for the enabling of the ports mentioned in this article.
    http://support.apple.com/kb/HT4245