6 Replies Latest reply: Sep 8, 2013 8:27 PM by FREEZER_should_come_with_IPhone
LHReynolds Level 1 (0 points)

Iphone 4s Wifi problem

 

For some reason I cannot connect to wifi with my iphone 4s!

 

When I access the wifi tab in settings and its greyed out?! I am unable to swtich wifi on at all.

 

I havent always experienced this problem but Im sure it happened a result of upgrading the handset software.

 

Im desperate to get it fixed. Please can someone help?

 

Thanks in advance.


iPhone 4S
  • fizzDripper Level 2 (335 points)

    you will need to do a Restore and backup using iTunes on your computer.

    if tht does not fix the issue visit the apple store and get the handset replaced if it is in the warranty period which is generally 1 yr from the date of purchase

    Good Luck

  • JimHdk Level 7 (28,340 points)

    Try the suggestions here to see if they resolve your problem:

     

    http://support.apple.com/kb/ts1559

     

    If these don't work you may have a hardware problem. Visit an Apple store for an evaluation or contact Apple Support.

  • LHReynolds Level 1 (0 points)

    Thanks for the swift response guys.

     

    I'll take a look at it this evening. I am hoping it can be solved without replacing the handset as I think the warranty has expired.

     

    I'll report back

  • Coralkillah Level 1 (0 points)

    POSSIBLE FIX....DISCONNECT THE BATTERY (4 Prong connector). Kind of like resetting the CPU.

     

    I, like alot of folks have a 4S which was out of warranty but working fine.  Updated with 6.1.3 and one day, poof, no Wi-Fi.  Just wouldn't let me switch on....anywhere, open and secured, Nada!  This is a similar symptom of many 4S owners.

     

    AT&T guys couldnt help (suggested resetting the Settings)  Everyone on here that went to Genius Bar said no genius could help except suggest buying a new phone!  Not wanting to spend $400 for a 64GB 5, I decided to tough it out with 4G alone and buy a new battery online for 10$ and change it myself (ifixit.com).  Wouldn't you know it that right after I had a new battery in my 4S and switched it back on, it asked me for my Wi-Fi password!

     

    Wi-Fi and BT are now working like a champ and I will spend my $400 on some other gadget!  Hope this helps someone.

  • Deadcatchan Level 1 (0 points)

    hi Reynolds -- and i want to YELL for the world to hear:

    I had the same problem, NONE of the reset suggestions work, as Apple would suggest- I hope they stop treating us as idiots- reset network setting only let me use Wifi for a night, and total delete data and restore - 15 minutes.

     

    staff I met in Apple store simply said a hardware problem was impossible! See the long list of "iphone 4s wifi problem" in google or in Apple support to prove they are wrong!

     

    Now i have it perfectly working (after having to pay a shocking 3G bill for the past month) guess what I did (my phone is past warranty)-- I simply took it to a local unauthorized mobile phone repair man (in a seedy mall in Hong Kong), and for about the equivalent for 50 USD and 1 hour, it came alive!

     

    For the rest of the world if such repair guys were not available, you'd probably have to go back to Apple, but ... it is really a problem that Apple has to face!

     

    Good luck!

  • FREEZER_should_come_with_IPhone Level 1 (0 points)

    As crazy as it may sound!! The FREEZER trick worked (seen in another post)!

    1) IPhone in a zip bag in FREEZER for 15min

    2) Reboot the IPhone

    3) WIFI no longer grayed out, and all working fine and connected

    I guess this is the magic of APPLE and I-Phone...

     

    I was more than sceptical, and tried everything before (Upgrade from IOS 6.1.2 to 6.1.3, Restore the I-Phone a few times, reset Network settings, enable Flight mode and Do Not Disturb + hard reboot...), and nothing worked!

    15min in the FREEZER and hey Presto!!

     

    FYI, I have an I-Phone 4s (now IOS 6.1.3), and this is a 4S that has been replaced about 3 months ago (because of WIFI was grayed out, but at that time was covered by warranty)!

     

    Let's see for how long this fix will last!!!

     

    Will my next phone be an I-Phone.... hhuuummm, not sure about that!