1 Reply Latest reply: May 9, 2013 11:28 AM by Eric Root
Jedibugs Level 1 (0 points)

Hi guys,


So, I've been having some problems with Mountain Lion lately, where my computer will randomly reboot several times a day. So, I decided that I would do an OS reinstall -- the basic one that keeps your files and settings in place. My reinstall never completes, though. It always shuts down and gives me the "Computer Restarted because of a Problem" screen. Sometimes it'll get to a point where it would normally reboot, but then show the circle with a cross through it that indicates it cannot find my hard drive, and then it boots to my Boot Camp partition. (I'm writing this on windows--ugh).


Here's what I've tried so far: I have gone into the OS X utilities and used disk utility to verify/repair the drive and the permissions. I have reset the PRAM/VRAM, and reset the SMC. No luck on any of it. I also tried to run a hardware test, but couldn't get it to work.


Despite the issues with booting to the drive, I can assure you that there's nothing physically wrong with the drive. The Windows partition I'm on right now is on the same physical drive. I can also access the MacIntoshHD from windows and I can browse and open files with no isssue whatsoever. It seems that the OS X Installer has just somehow made the OS X partition unbootable.


At this point, I just need to be able to boot to OS X, even if I keep having the rebooting issues that prompted this whole thing.


The machine is a 2009 15" MacBook Pro (the first Unibody). 1TB HD, 8GB RAM, 2.53GHz Core 2 Duo.


Any help would be greatly appreciated.





MacBook Pro (15-inch 2.4/2.2 GHz), OS X Mountain Lion (10.8.3)