13 Replies Latest reply: May 10, 2013 10:35 AM by Pedidudez
Pedidudez Level 1 Level 1 (0 points)

I upgraded from leopard to mountain lion for while.it connects to wifi but not the internet. I see the full bars but when i open safari it wont load any page. I used the "assist me" diagnose, wasn't any help (the light next to internet and server item is yellow)

I did anything i could with the router and everything. I even tried it on other wifi networks, the problem was the same, didn't work.

My device is a macbook pro 15. Core i5

Please help. This is been bugging me for months now...


MacBook Pro, OS X Mountain Lion (10.8.3)
  • Linc Davis Level 10 Level 10 (169,325 points)

    Click the lock icon in the lower left corner of the Network preference pane and authenticate, if necessary. From the Location menu at the top of the window, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

  • Pedidudez Level 1 Level 1 (0 points)

    Thanks for the tip, but i've already done that and it didn't work. I did it again now, just to be sure, still the same problem :(

  • Paul_31 Level 6 Level 6 (13,210 points)

    Wifi problems seem to crop up a lot on here and unfortunately there doesn't seem to be a 'one fix' solution.

    However, sometimes any one of the following can help although, unfortunately, not always - in no particular order:

    • Check wifi security - if it's WEP change it to WPA or WPA2 (preferably, as it's more secure)
    • Change the wifi channel on the router
    • Create a new Network Location: http://support.apple.com/kb/HT5289
    • Reboot the router

     

    Also take a look at this link and the links within the article for other ideas. They mainly reference Lion, but still seem to be relevant to Mountain Lion:

    http://osxdaily.com/2011/11/06/lion-wi-fi-problems-solution-mac/?utm_source=feed burner&utm_medium=feed&utm_campaign=Feed%3A+osxdaily+%28OS+X+Daily%29&utm_conte n t=FaceBook

     

    ...and this link:

    http://osxdaily.com/2012/11/30/resolving-stubborn-wi-fi-connection-problems-in-m ac-os-x/

  • Linc Davis Level 10 Level 10 (169,325 points)

    Boot into Recovery mode. From the OS X Utilities screen, select Get Help Online. A clean copy of Safari will launch. No plugins, such as Flash, will be available. While in Recovery, you'll have no access to your saved bookmarks or passwords, so make a note of those before you begin, if they're needed for the test.

     

    Test. After testing, reboot as usual and post the results.

  • Pedidudez Level 1 Level 1 (0 points)

    the intenet in recovery page works fine. But the won't work in the actual os.

    I even have a windows 7 on the device and the internet works fine on it.

    I ran a wifi diagnostic report and i have right on my desktop. Any use from that?!

    Paul_31 thanks, but i read those links before. They weren't much of a help.

    And another thing i need to mention is that i installed the os again, thinking that'll do it. But no changes occured...

  • Linc Davis Level 10 Level 10 (169,325 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, or by a peripheral device.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Post for further instructions.
       
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • Pedidudez Level 1 Level 1 (0 points)

    We're making progress...

    I ran i to safe mode. It was pretty slow, but the internet worked on safe mode. I did not tested any program, like yahoo messenger or anything else but safari worked. It loaded the apple main webpage, and the searching engine worked ok (a bit slower than my usual wireless speed)

    I restarted it to normal mood, opened safari and the loading bar went a little bit further than before and loaded the website's name, but it got stuck again. didn't load it fully.

    What i do now?

  • Linc Davis Level 10 Level 10 (169,325 points)

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then copy it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Triple-click the line of text below to select it:
    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}' | open -f -a TextEdit
     
    Copy the selected text to the Clipboard by pressing the key combination command-C. Then click anywhere in the Terminal window and paste (command-V). A TextEdit window will open with the output of the command. Post the contents of that window, if any — the text, please, not a screenshot. You can then close the TextEdit window. No typing is involved in this step.
        
    Step 2

     

    Repeat with this line:
    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}' | open -f -a TextEdit
     
    This time you'll be prompted for your login password, which you do have to type. It won't be displayed when you type it. Type it carefully and then press return. You may get a one-time warning to be careful. Heed that warning, but don't post it. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.

     

    Step 3
    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}' | open -f -a TextEdit
     
    Step 4
    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null | open -f -a TextEdit
      
    Important: If you formerly synchronized with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5
    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null | open -f -a TextEdit
     
    Remember, steps 1-5 are all copy-and-paste — no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • Pedidudez Level 1 Level 1 (0 points)

    Done. The first step opened a text with these notes:

    Com.proxifier.MacOSkext (1.3.5)

    Com.proxifier.MacOSkext.proxifierkextudp (1.3.5)

     

    Did other steps flawlessly. I copied all of the texts opened during the procedure. And at the end a text opened with the name of bunch of programs...

    What next?!

    Step 1:a

    1. com.Proxifier.MacOSX.kext (1.3.5)
    2. com.Proxifier.MacOSX.kext.ProxifierKextUdp (1.3.5)

     

    step  2:

    1. com.microsoft.office.licensing.helper
    2. com.adobe.SwitchBoard
    3. com.adobe.fpsaud

     

     

    step 3:

    1. com.adobe.CS5ServiceManager
    2. com.google.keystone.user.agent
    3. com.adobe.AAM.Scheduler-1.0

     

    step 4:

    /Library/Components:

     

    /Library/Extensions:

     

    /Library/Frameworks:

    1. AEProfiling.framework
    2. AERegistration.framework
    3. AudioMixEngine.framework
    4. NyxAudioAnalysis.framework
    5. PluginManager.framework
    6. iLifeFaceRecognition.framework
    7. iLifeKit.framework
    8. iLifePageLayout.framework
    9. iLifeSQLAccess.framework
    10. iLifeSlideshow.framework
    11. iTunesLibrary.framework

     

    /Library/Input Methods:

     

    /Library/Internet Plug-Ins:

    Flash Player.plugin

    1. JavaAppletPlugin.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    1. SharePointBrowserPlugin.plugin
    2. SharePointWebKitPlugin.webplugin
    3. Silverlight.plugin

    Unity Web Player.plugin

    Unused

    1. flashplayer.xpt
    2. iPhotoPhotocast.plugin
    3. nsIQTScriptablePlugin.xpt

     

    /Library/Keyboard Layouts:

     

    /Library/LaunchAgents:

    1. com.adobe.AAM.Updater-1.0.plist
    2. com.adobe.CS5ServiceManager.plist

     

    /Library/LaunchDaemons:

    1. com.adobe.SwitchBoard.plist
    2. com.adobe.fpsaud.plist
    3. com.microsoft.office.licensing.helper.plist

     

    /Library/PreferencePanes:

    Flash Player.prefPane

    1. Growl.prefPane

     

    /Library/PrivilegedHelperTools:

    1. com.microsoft.office.licensing.helper

     

    /Library/QuickLook:

    1. iBooksAuthor.qlgenerator
    2. iWork.qlgenerator

     

    /Library/QuickTime:

    1. AppleIntermediateCodec.component

    AppleMPEG2Codec.component

     

    /Library/ScriptingAdditions:

    Adobe Unit Types.osax

     

    /Library/Spotlight:

    Microsoft Office.mdimporter

    1. iBooksAuthor.mdimporter
    2. iWork.mdimporter

     

    /Library/StartupItems:

     

    /etc/mach_init.d:

     

    /etc/mach_init_per_login_session.d:

     

    /etc/mach_init_per_user.d:

     

    Library/Address Book Plug-Ins:

     

    Library/Fonts:

     

    Library/Input Methods:

    .localized

     

    Library/Internet Plug-Ins:

     

    Library/Keyboard Layouts:

     

    Library/LaunchAgents:

    1. com.adobe.AAM.Updater-1.0.plist
    2. com.google.keystone.agent.plist

     

    Library/PreferencePanes:

     

    Step 5:

    iTunesHelper, FaceTab Pro for Facebook, Proxifier, RockMelt, Dropbox, Android File Transfer Agent

  • Linc Davis Level 10 Level 10 (169,325 points)

    Please read this whole message carefully, especially the warnings, before doing anything.

    1. The changes to your configuration suggested here should be considered provisional; they may not solve your problem, or they may remove functionality that you find useful. If a third-party system modification that you want to keep is causing the problem, seek help from its developer.

    2. WARNING: Back up all data now if you haven’t already done so. Before proceeding, you must be sure you can restore your system to its present state, even if it becomes unbootable. If you’re not sure you can do that, STOP — DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not be able to help, if you ignore this warning.

    3. You should either remove or update the following system modification(s), if an update is available from the developer:

    N/A

    and definitely remove at least the following:

    Proxifier

    4. Whatever you remove must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool, if any, provided by the third-party developers, or to follow their instructions. If the software has been incompletely removed, you may have to re-download or even reinstall it in order to finish the job. I can't be more specific, because I don't install such things myself. Please do your own research.

    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickYourMac.” First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say www.brickyourmac.com. (That may not be the actual name of the site; if necessary, search the web for the product name.) If you don’t find anything on the website or in your search, contact the developer. While you're waiting for a response, download BrickYourMac.dmg and open it. There may be an application in there such as “Uninstall BrickYourMac.” If not, open “BrickYourMac.pkg” and look for an Uninstall button.

    Again, please don't ask me to do this research for you. You can do it better than I can, because I haven't installed the product and I may not even know what it is.

    If you can’t remove software in any other way, you’ll have to erase your boot volume and perform a clean reinstallation of OS X. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse. The same goes for "utilities" that purport to remove software.

    5. I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future OS X updates, so it may not be clear which one is at fault.

    6. If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

  • Pedidudez Level 1 Level 1 (0 points)

    I honestly can't thank you enough for the time your putting into this.

    The program you are speaking of, is a program to bypass website filtering in my country. Removing it is not such a problem cause its hardly an application!

    In the safe mode boot i browsed with the application mentioned before open. I don't think that is the problem...

    Anyway i deleted the program you said, and a few of useless internet programs. No changes still.

  • Linc Davis Level 10 Level 10 (169,325 points)

    Please repeat Step 1 and post the output.

  • Pedidudez Level 1 Level 1 (0 points)

    Good news its working:))

    I deleted the proxifier in the old fashioned way and rebooted the system, its now working. I can use the internet now.

    I didn't reboot after the deletion.

    Thanks. Your help is much appreciated.

    I surely didn't think it could be that program.