14 Replies Latest reply: May 11, 2013 8:28 AM by DLScreative
DLScreative Level 4 Level 4 (1,595 points)

I will not be adding any new images to Aperture for reasons that I am not allowed to disclose.

MacBook Pro, Mac OS X (10.7.4), 2.2GHz quad i7/8GB RAM/1GB VRAM
  • DLScreative Level 4 Level 4 (1,595 points)

    I had such high hopes for this program back in 2006, and I was on the cutting edge of it.  I invested heavily in it, and this decision saddens me greatly.

  • Kirby Krieger Level 6 Level 6 (12,510 points)

    Farewell.  Srsly.




    I'd be happy to work with anyone with your skills and outlook on any project.

  • DLScreative Level 4 Level 4 (1,595 points)

    OK, I can't leave until I solve this because I still have images that are not referenced.  I'm out on a road job, and I created a new library just for this job.   I've been getting the dialog below The whole time. ( I never saw this before this new library) It was just an annoyance before, but now it won't let me click through.  Creating a new library gives the same result.  Trying to run troubleshooting gives the same result.  Everything I do- and you know that I know what I'm doing- gives the same result. 


    I simply can't get past this "helpful" information.  I'm on the best gig I've had in years, and I can't get to my library!  Except for the personal stock I've shot, everything is referenced and backed up twice so I haven't lost anything.  However, this is still a disaster.


    I can't remember what version of A3 I'm on- and i can't find out- but I haven't updated in a while because I grew tired of two-three day library updates every time.  I considered updating this relatively small library, but that means I have to update my MONSTER library when I get back.


    This is the last straw for me, but I still need to fix it.  








  • Frank Caggiano Level 7 Level 7 (25,715 points)

    I can't remember what version of A3 I'm on- and i can't find out

    Why not? Locate the Aperture app in the finder and do a Get Info on it. The version is there.

  • DLScreative Level 4 Level 4 (1,595 points)

    3.2.4 I was too angry to remember that.  Does that information get me the answer I seek?  Why after all this time since MobilMe went away am I getting this dialog?

  • CorkyO2 Level 4 Level 4 (1,290 points)

    Not sure if this will help or not.


    Inside the Aperture library package in the 'Database' folder there may be a preference file named:




    There are three publishing account lines by default shown in the following text:


    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">














    I would suggest removing the text I have made bold and removing any space left over between lines > and then save the file (copy out the file to desktop first if you like). I just tried this on my machine and it doesn't create a problem on relaunch and the file remains as edited after relaunch.


    Note - not having ever published to my MobileMe account, I don't know if this is the file read on first launch, but I do know that MobileMe was removed from Web > Add Account list in Aperture sometime after MobileMe was discontinued.


    Good luck on your job, man.

  • DLScreative Level 4 Level 4 (1,595 points)

    And while we're on the topic of MobilMe, why is it still part system preferences in Lion?  I think I "caused" the problem when I tried to stop the pop up by logging out of MobilMe in system preferences.  Now I get this issue, and I can't log back in.



  • DLScreative Level 4 Level 4 (1,595 points)

    Thanks for your help, but I really shouldn't have to go under the hood to solve a problem that should have never existed.  I really do appreciate the help.




  • CorkyO2 Level 4 Level 4 (1,290 points)

    I noticed that too when I was still on Lion.


    I assume it had something to do with the transition period to iCloud and still allowing MobileMe subscribers to use the MobileMe functions that were not part of the new iCloud scheme (e.g., photo gallery and iWeb publishing).


    It may be that you will need to log into iCloud with your MobileMe info to allow Aperture to do it's thing (assuming Apple made the code work seamlessly to handle the message you are seeing - although that may be a stretch).

  • CorkyO2 Level 4 Level 4 (1,290 points)

    Thanks for your help, but I really shouldn't have to go under the hood to solve a problem that should have never existed.

    I absolutely agree with you on this one. The main reason I moved to Mac was the 'It just works' idea and the notion that as technology gets more advanced, it should be easier to use (a notion that I think Steve Jobs coined).


    I already know how to hack files due to working in the Windows environment for so many years, I also feel a reluctance to do that on the Mac platform. Who knows what the future will really bring?


    Whatever you decide, I hope you are successful with what you enjoy and you are certainly welcome for any help I can provide. After all, helping another person is - in my book - what life gives us an opportunity to choose to do.


    I hope your images turn out great whatever you end up using to get them there.

  • DLScreative Level 4 Level 4 (1,595 points)

    Thanks.  I have great admiration and even affection for the contributors on this forum.  The problem with the platform is that they have taken too much control from the user at this point.  IOW, they've taken the ease of use thing too far, and now it requires a hack to get things done.  I have to use a utility called Lion Tweaks just to do things that were once simple.  Thanks again for your help and good wishes.


    BTW: I'm pretty sure that MobileMe went away BEFORE I bought this computer.




  • léonie Level 9 Level 9 (79,605 points)

    I hope this is not a goodbye forever, DLS. I am sorry to see you go; all the best to you on your way!



    But do you still see the panel? If you do not want to patch property list files, you could try this first:


    • Quit Aperture - force quit if necessary,
    • Disconnect the internet (Wi-fi, Ethernet, whatever you have), before you launch Aperture again.
    • Now the panel should no longer appear - if it does, press the "Learn more" button, not o.k.
    • Then use the "File > Web Accounts > Manage Web Accounts" menu entry from Aperture's main menu bar and remove "MobileMe" from the list of accounts in the accounts pane by pressing "-".


    Good luck


  • DLScreative Level 4 Level 4 (1,595 points)

    I already tried it without being connected to the internet.  It doesn't work. None of the buttons are responsive.



  • DLScreative Level 4 Level 4 (1,595 points)

    I had no choice but to bite the bullet and run the update. It was very quick on this 30GB all referenced library, but I still fear what's going to happen when I update my 600GB mixed library that goes back to version 1.1.


    In any case, I can now get to my library, and I'm going to have to finsh this job with A3 because I've already done 35% of the work with A3.  I'm not going to mark this as solved because the only solution I found was to do an update that I didn't want to do, and someone might find another solution if I leave it unsolved.


    Thanks to all