3 Replies Latest reply: May 10, 2013 2:01 AM by Tom Wolsky
wildliveafrica Level 1 (0 points)

final cut pro x not opening at all, is updated, any idea what to do????


Final Cut Pro X, OS X Mountain Lion (10.8.3)
  • Tom Wolsky Level 10 (115,510 points)

    Did it ever open? First time using it? Start by trashing preferences. Hide the projects and events from the application and see if it will open without them.

  • wildliveafrica Level 1 (0 points)

    Hi Tom, thanx for replying. Yes it has opened many many times, have done many edits on the program and worked fine up to now. I have not used it for the last couple weeks, was busy with filming on different shoots. it says it is reading the projects, then gives me Projects and Events must be updated to work with this version of Final Cut Pro, I click ok and then after that, nothing happens. eventually i do the force quit and it says there fcp is not responding...

  • Tom Wolsky Level 10 (115,510 points)

    Did you trash the preferences? Did you hide the projects and events? Of the application still doesn't open, reinstall it.