5 Replies Latest reply: May 11, 2013 11:55 AM by Deeping_Dave
Deeping_Dave Level 1 Level 1 (0 points)

Hi there,


As it says I replaced my internal WD 250gb drive in my late 2006 2.16ghz imac . I followed the tutorials on the net to the tee yet upon trying to boot from Snow Leopard after firing it back up all I get is the Apple logo and the timer . I've tried holding C to no avail . I've held Alt to select the OSX disc yet it still won't boot to get me to Disc Utility . I've even put the old hard drive back in . When I hold Alt on start up it shows the drive and the disc but will boot from neither when selected . I've tried to get the Snow Leopard disc to eject so I can try my originals but it won't even do that . I'm convinced I haven't damaged anything but I'm at my wits end ! Does anybody have any ideas how to get the Leopard disc out so I can at least try from my originals ? The drive I've installed is compatible it's a 1tb WD . I also triple checked all the connections and they all seam sound . Really appreciate your help lads as I wanted to give the iMac to my daughter when we get a new one .

  • The hatter Level 9 Level 9 (60,905 points)

    What OS were you using? What version is on the OEM DVD? Your model iMac would have come with 10.4.x of some sort so 10.6 --- as long as it is retail (and you sound like you used that DVD before).



  • Eustace Mendis Level 7 Level 7 (25,320 points)

    This is a long shot, but I suggest you try a PRAM reset.


    1. Shut down your Mac.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.

    Excerpt from http://support.apple.com/kb/HT1379

  • Deeping_Dave Level 1 Level 1 (0 points)

    Cheers for the replies lads . I have the original 10.4 discs and used the Snow Leopard upgrade disc . When the original HDD went I put in Snow Leopard to get to disc utility to try and verify / repair the dsc to no avail . Nothing I do including going into verbose mode and trying to eject will get the snow leopard disc out for me to at least try the originals! There must be a way to get it out I can here it turning and working inside but nothing will eject it .

  • den.thed Level 7 Level 7 (25,365 points)

    You will first need to prep the new drive using Disk Utility on the original 10.4 Disc or Retail upgrade 10.6 DVD. It needs to be Partition GUID Partition Table and Format it Mac OS Extented (Journaled) before you can install and run OS X on it.


    1. Boot from your SL install DVD or Bootable Clone and open Disk Utility.

    2. Highlight the new HD in the list of drives and select the Partition tab.

    3. Under Volume Scheme select 1 Partition and click on the Options... button.

    4. Select GUID Partition Table in the drop down window and click OK.

    5. Set the Format to Mac OS Extended (Journaled) and click the Apply button.

    6. Once thats done, then you can do a clean Install, Restore from TM or a Bootable Clone.

  • Deeping_Dave Level 1 Level 1 (0 points)

    Success ! More by luck than judgement I think. I put my old HD back in and re installed Snow leopard on it . Took it out and put the new one in . For some reason if I tried to boot from Snow Leopard before it wouldn't . This time however it did and the drive showed as 1TB . Previously I was attempting to re boot from Tiger 10.4. It was showing as a 7.3TB drive under Tiger but correct under Snow Leopard . I had put a jumper on pins 5 and 6 not sure if this had any bearing at all but it seams to have worked this time so I'm not complaining . It's currently installing Snow Leopard on the new disc . Got 4gb memory coming soon so I may be back when I have problems trying to upgrade to Lion next week ! Thanks for all your help lads much appreciated .