Previous 1 2 Next 15 Replies Latest reply: Oct 28, 2013 7:13 PM by docparag
Thomas Koller Level 1 Level 1



currently I'm unable to install the latest thunderbolt firmware update on my i-mac 27" mid 2011.


I get the update via App store. I starts to install, reboots but there is no status bar after reboot. In the  App store again I get the update shown as new. Also trying install it manually did not work.

I already made a reset of PRAM and SMC.

Still no luck.


On my macbook air 13.3 the update installs fine.

Does anybody else have this issues?


AppleCare currently have no idea what to do.


What else can I try?


Best Regards,


iMac (27-inch Mid 2011), OS X Mountain Lion (10.8.3)
Solved by Thomas Koller on May 11, 2013 1:38 PM Solved

issue solved.


the partion table of the / volume was corrupted. after repairing this everything works fine.

  • rkaufmann87 Level 9 Level 9

    Worked fine on my system. I'd start by opening Finder - Go - Go to Folder... and copying and pasting:




    then once the file is located, drag it to the desktop. Restart the computer in Safe Mode  and re-try Software Update.

  • Thomas Koller Level 1 Level 1

    issue solved.


    the partion table of the / volume was corrupted. after repairing this everything works fine.

  • INTEKSWETRUST Level 1 Level 1

    This worked for me good work!!!

  • kipppo Level 1 Level 1

    perfect tipp. had the same issue. worked for me as well..

  • Fred Jin from Vegas Level 1 Level 1



    I have the same problem. Not quite understand your solution, would you please provide more details how to fix it? Thank you.

  • askurat1 Level 1 Level 1

    Some help with how you fixed this would be great.



  • kipppo Level 1 Level 1

    Open "Disk" (to be found in "Utilities") select on the left hand side of the window your boot volume (i.e. Macintosh HD) click in the main window on "Repair Volume". If the process shows you errors (which normaly are fixed), I suggest you click on "repair" or verify a second time, after the process is completed, to check if everything is fixed. You might get a "Volume can not be unmounted" error. Which is normal, since it's the boot volume.


    If the problems cannot be fixed (sometimes they only can be fixed, if it not the boot volume therefore the volume can be unmounted) you can boot with a Mac OS X Installation disk (if your Mac has a CD drive) and instead of starting the installation, you pick in the menu "Disk Utility" and do the steps above.


    If you have 10.8.x, boot your computer and hold down command-R to boot into the Recovery Mode. There you pick Disk Utility from the menu and do the steps above.

  • Fred Jin from Vegas Level 1 Level 1

    Thank you so much, I fixed the problem.

  • jcorbin69993 Level 1 Level 1



    This didn't work for me. I get to the status bar, it crashes and reboots without the installation finishing both before and after your tip. I have a perfectly healthy 'disk'. If anyone has any other suggestions I'd appreciate them.




    edit: I just realised I have to have it connected to power before it will update!


    Message was edited by: jcorbin69993

  • JoeWMpls Level 1 Level 1

    I just wanted to pay it forward with my find.  My issue has been the same as others with getting stuck on Thunderbolt firmware updates.  I had both the the 1.0 and 1.2 updates stuck in my Software Update queue. My built in trackpad mouse was also acting haywire after updates got stuck.  I have spent half the day trying every offered solution or solution that has worked for some and not others, to no avail.  I have tried PRAM reset, SMC reset, firmware download direct from Apple, erasing Software Update files, etc etc.  Unfortunately, this was a long fix and may not be feasible for some, but it may be able to be shortened a couple long steps.  The only thing that worked for me was to go back to 10.6.8, then to 10.7, then to 10.8.3.  i did not try simply a disk wipe with 10.8.3 re-install, but that could work, skipping 10.6.8 and 10.7.  Good luck!

  • geartalk Level 1 Level 1

    The repair to my partition table worked and finally this thunderbolt update has completely installed. This was driving me nuts. Thanks for the help.

  • Chris Cantrell Level 1 Level 1

    I had the same problem ... and go figure, I had a Thunderbolt drive plugged in and it seemed like the update worked.  Howerver, it kept prompting to install this update after I rebooted.  Uplugged the TB drive, updated and all worked great.  Maybe Apple could Error out the update with a message that the port is active and no updates can be applied ... even though it is very logical and firmware update is likely to fail if the port is active

  • Soda Level 1 Level 1

    Try to boot in safe mode. Press shift key immediately after you turn the computer on and hear the bell sound. Once you see the gray screen with the dark Apple, leave the keyboard alone. For me that caused the status bar to go from 0 to about 25% but never more than that. Several tries gave the same result.


    At the same time, I wanted to replace Norton Anti-Virus so I did and rebooted to finish the uninstall. Guess what? Suddenly, the firmware update went through to completion. Now everything is okay and I bought Kaspersky instead of reinstalling Norton... No issues.

  • maramok Level 1 Level 1

    So as much as i didn't feel like earsing and re-installing my operating system, that is what fixed it for me. I did a clean install with a freshly made Lion (10.7.5) install flash drive downloaded from the app store.


    It didn't make any sense at all becuase it should have been a "firmware" update and have nothing to do with the OS but what can i say, it fixed it.


    I do not know if a re-install would have worked as i opted to just erase completely.

Previous 1 2 Next