7 Replies Latest reply: May 12, 2013 7:49 AM by millerpe
millerpe Level 1 (0 points)

Today I purchased and downloaded Numbers.  For one user account on this iMac, Numbers and Pages have stopped responding!?!  I've read lots of similar threads from years gone by, but nothing recent.  I'm running a new iMac with the lastest Mountain Lion OS; everything is up to date.  Any ideas?!?

iMac, OS X Mountain Lion (10.8.3)
  • Wayne Contello Level 6 (16,935 points)

    Try rebotting the machine



    Also try:

    Quit all iWork applications


    navigate to the "Library" for the problem user account by selecting the menu item (in the Finder) "Go > Go To Folder..."


    then enter "~/Library/Preferences/"


    now locate the files:

    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Keynote.LSShare dFileList.plist

    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Keynote.LSShare dFileList.plist.lockfile


    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Keynote.plist.l ockfile

    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Numbers.LSShare dFileList.plist


    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Pages.LSSharedF ileList.plist

    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Pages.LSSharedF ileList.plist.lockfile


    file://localhost/Users/wayne/Library/Preferences/com.apple.iWork.Pages.plist.loc kfile



    And move them to the desktop


    now start Numbers again.


    If it launches then trash all of the files listed above (not if you only want to deal with Numbers filter the above list to just files that are "...com.apple.iWork.Numbers..."

  • millerpe Level 1 (0 points)

    NO JOY!  I tried this per previous posts from way back.  Cleaning up the "Preferences" files makes no difference.  There are four accounts on this iMac.  I determined that Numbers and Pages only works on one of them (?!?).  For the non-working accounts, these apps never start, it's just the spinning beach ball.  As a result, most of the files don't even exist for the account.

  • Jerrold Green1 Level 7 (29,955 points)



    You didn't happen to move the apps from where the App Store put them, did you?



  • millerpe Level 1 (0 points)

    No Jerrold,


    The only files I messed with are the "*.plist" files.  I removed and reinstalled the apps, but I did not mess with any specific files.


    Hmmm?  Being an ol' Windows guy, I was very impressed with the iMac up until now.  Some folks have been advocating the Office for Mac; rumor has it the iWorks apps are buggie.  I don't have time for that.  Any thoughts?

  • Jeff Shenk Level 4 (2,700 points)

    When you installed and removed and reinstalled the apps, were you logged in to the original administrator account that was first set up when you originally set the computer up?


    Is the one account that does work the one to which you were logged in when you purchased the apps, and might that account not be an administrator account? (Are the apps in the computer's Application folder, or are they in an application folder under a particular user?)

  • Wayne Contello Level 6 (16,935 points)

    I suggest trashing the iWork folder and reinstall.  This is the first account of this problem I have seen.  I would not consider the iWorks suite, in general, to be buggy.

  • millerpe Level 1 (0 points)

    Thank you all for your support and responses.  It all helped!


    While exploring various forums and chat sites I discovered two things:  First, if I turned off iCloud the iWorks apps worked fine, specifically if I turned off Documents and Data; second, after changing iCloud settings and logging off, I discovered the settings unchanged when logging back in.    Another post mentioned the permissions associated with the User Library folders and their children.  Similar to what Jeff mentioned above, I had changed the Administrator setting for other accounts between installing Pages and Numbers.  I suspected that the Library folders were not allowing the user accounts to modify various files; so I changed the permissions on the User Library folders such that the user and admin (me) had read & write for all the content.  That fixed everything:  Changes to settings stick and the iWorks apps are functioning.  The whole iMac is a bit snappier, too.  I suspect my admin change had things pretty hosed up.