Previous 1 2 Next 17 Replies Latest reply: Jun 24, 2006 5:44 PM by Tnalder
cloulee Level 1 Level 1 (0 points)
I'm having trouble getting my macbook pro to recognize my linksys router WRT54gs. A pc is currently plugged into the router and is connecting to the internet easily. I can't get my airport card to recognize the network. I've searched the other messages and have followed some of the suggestions as to how to set up airport, but I've still not managed to get anything to work. Any help would be appreciated...but keep it simple, guys...newbie here!!

MacBook pro
  • m_oody Level 1 Level 1 (40 points)
    Well before using the airport, do this :

    1) Plug the ethernet cable from your MBP to 1 of your 4 routers hubs (not the WAN one thats on its own)

    2) open safari or firefox and go to
    http://192.168.1.1/

    username : (leave empty)
    password : admin

    if you get this far then your starting to be in busniess, then you set up the wireless, make sure you secure it also.
  • strangelychimp Level 1 Level 1 (0 points)
    Unfortunately the problem may be that the router is using WEP security. I had (note the past tense) a MacBook last week and it wouldn't connect to my linksys router so I tried it without any security and it worked fine (OS 10.4.6). I think other people have had airport problems with the intel Macs and/or 10.4.6
  • galael Level 1 Level 1 (5 points)
    If you have WEP enabled, OS X will prompt you for a password. You need to prefix your WEP key with "0x" so you password will look something like this:

    0x1234567890...
    ^^^^^^^^^^^^^
    WEP key

    Galael
  • Rainiero Level 1 Level 1 (15 points)
    just select WEP instead of WAP. you can change that by connecting ur mbp via ethernet cable. and going to 192.168.1.1 it will as you for an id: (leave blank)
    and a password: which is (admin) if u didnt change it. once inside select the wireless TAB and choose WEP then on passphrase type any word you want. then copy the generated KEY 1 on a piece of paper. and hit "SAVE", and "continue".

    After that is completed. turn off your airport for 1 minute and disconnect the ethernet cable. wait for 1 minute.

    now come back to ur mbp and turn on ur airport. select your wireless network from the list. it will ask you for a WEP Key. in that box type the key 1 that u copied from your router.

    THAT will fix the problem. if u need more help let me know. i have all my computers pc and mac working perfectly with this router.
  • cloulee Level 1 Level 1 (0 points)
    Thanks for the reply : )

    If I understand you correctly, you're explaining how to get started configuring the router itself. The router is already up and running, connected to the pc by cable....it was configured on the pc, not the mac. I understood once it was configured, I didn't have to do it again.
  • cloulee Level 1 Level 1 (0 points)
    If you have WEP enabled, OS X will prompt you for a
    password. You need to prefix your WEP key with "0x"
    so you password will look something like this:

    0x1234567890...
    ^^^^^^^^^^^^^
    WEP key

    Galael


    Thanks for the info : )

    To restate, I need to go back to the PC and re-do the password with a prefix of 0x?

    I don't think my problem is a password issue, the airport isn't picking up the signal from the linksys...at least that I can tell...maybe I need to check if the linksys is broadcasting?
  • cloulee Level 1 Level 1 (0 points)
    just select WEP instead of WAP. you can change that
    by connecting ur mbp via ethernet cable. and going
    to 192.168.1.1 it will as you for an id: (leave
    blank)
    and a password: which is (admin) if u didnt change
    it. once inside select the wireless TAB and choose
    WEP then on passphrase type any word you want. then
    copy the generated KEY 1 on a piece of paper. and
    hit "SAVE", and "continue".

    After that is completed. turn off your airport for 1
    minute and disconnect the ethernet cable. wait for 1
    minute.

    now come back to ur mbp and turn on ur airport.
    select your wireless network from the list. it will
    ask you for a WEP Key. in that box type the key 1
    that u copied from your router.

    THAT will fix the problem. if u need more help let me
    know. i have all my computers pc and mac working
    perfectly with this router.


    I appreciate the reply : )

    It sounds like you are trying to help me reconfigure the router using the mac...the router was configured using the pc to start with...the airport doesn't seem to be finding the broadcast from the router. The router is being used currently with a pc and a cable...rather than wireless. Is it possible the router doesn't work both ways at the same time?
  • cloulee Level 1 Level 1 (0 points)
    I'm having trouble getting my macbook pro to
    recognize my linksys router WRT54gs. A pc is
    currently plugged into the router and is connecting
    to the internet easily. I can't get my airport card
    to recognize the network. I've searched the other
    messages and have followed some of the suggestions as
    to how to set up airport, but I've still not managed
    to get anything to work. Any help would be
    appreciated...but keep it simple, guys...newbie here!!



    I think I've stated the problem incorrectly. The router has been configured using the pc, the pc is using the router to connect to the internet by cable, not wirelessly. My understanding was that the airport card in the mac would automatically find the network that the router is broadcasting and then I could connect to the internet. Airport is finding my neighbors networks, but not mine.

    Seems like it might be a router issue rather than a mac issue to start with?

    Appreciate all the assistance...what a great place to come with questions!
  • tsvisser Level 3 Level 3 (755 points)
    There are instances where you might have heavy WiFi density from neighboring wireless networks that cause interference. There is no true science to this, unless you have the right equipment.

    Just some things that I have noticed in the past that have personally helped me...

    1) If you change the default SSID name from Linksys to something else, this might help a problem caused by another Linksys network in the vicinity from your computer from connecting and getting an IP address from the DHCP server.

    2) Most routers are set to default to channel 9 or 11. Sometimes, if you choose a channel (in the router's setup) different than 9 or 11, your computer might be able to connect. I have seen instances where 1 Sony Vaio was able to connect, despite the network density, but another Sony Vaio of a different model was not able to.

    3) Sometimes if there is a lot of density on channel 9 or 11, and you set your router to something other than 9 or 11, range drops to almost zero. This flies in the face of hint #2, but there are cases where it is better to broadcast on the same channel rather than trying a different channel. Why? I don't know.

    4) Make sure that there are no settings on the router that would prohibit the DHCP server from assigning an IP to identifiable MAC addresses only or limit the number of DHCP connections. (or DHCP turned off)
  • CompDude Level 1 Level 1 (0 points)
    If the network card can't see th network at all then I don't know how to solve this. But if it can see it and is just unable to connect try the different bits of the wep( eg. WEP 64 bit). This depends on what kind of encryption your router is using. My MBP couldn't connect to my wireless network when I first turned it on and it asked me to connect but when I booted into OS X I selected WEP 64 bit ascii and it worked.
  • Akamas Level 2 Level 2 (385 points)
    If your MPB is not seeing the wireless router signal, then it is possible that the router is not broadcasting the presence of its wireless signal. On the Linksys, the default is to broadcast the signal, but it could have been changed to disable somehow. Especially, if someone set it up for you because an open wireless broadcast is a pretty big security hole.

    I recommend you access the router and check the settings. Make sure the wireless broadcast is set to enable. There are some other settings to check, but right now we want to check if we can even see the wireless. Then, we can go through some other settings to get you up and running, if we have to.

    :))
  • Jodhi13 Level 1 Level 1 (0 points)
    I'm having the same issue as cloulee. My linksys is connected to a PC. The PC works fine on the internet. There's definitely a wireless signal since another laptop (also PC) recognizes the signal and can sign on without issues. For some reason, my Mac cannot detect it. It detects all the other secured wireless signals in the area BUT mine. I've even tried to set it up manually (i.e. manually typing in network name + password) and it still can't detect the signal i want. i don't have issues connecting my Mac directly to the ethernet. Am I having issues because of the way the wireless router is set up? Does the router need to be configured a certain way for my Mac to recognize it?
  • Jodhi13 Level 1 Level 1 (0 points)
    almost forgot. someone else in the area is running a linksys router too. except he/she didn't put any securities on it. i have no issues when using that signal to surf and stuff. is it possible that this is causing interference with my secure line? and yes, I checked, this other linksys signal is not mine. any help would be appreciated
  • frequent popsicle Level 3 Level 3 (640 points)
    if you are using wep encryption you have to put a $ in front of your wep key on the apple computer to get it to work with a linksys router.

    This is a fact. without it you'll never connect
Previous 1 2 Next