5 Replies Latest reply: May 12, 2013 10:42 AM by Tom Gewecke
Klaus Blume Level 2 Level 2

After a fresh install of 10.7.5, I cannot enable the keyboard & character viewer. Neither the checkbox will stay checked, nor does the option appear in the input sources menu...

 

Any ideas?

 

Thanks,

 

Klaus


MacBook Pro, Mac OS X (10.7.5)
Solved by Tom Gewecke on May 12, 2013 5:55 AM Solved

This used to happen in 10.5, and back then the fix was at

 

http://support.apple.com/kb/TS1896

 

You might try that or cleaning caches with something like Onyx.

  • Tom Gewecke Level 9 Level 9

    This used to happen in 10.5, and back then the fix was at

     

    http://support.apple.com/kb/TS1896

     

    You might try that or cleaning caches with something like Onyx.

  • Klaus Blume Level 2 Level 2

    Thanks, Tom, for your speedy reply.

     

    This is what the Terminal commands produced:

     

    Last login: Sat May 11 21:33:45 on console

    You have mail.

    Macintosh-7:~ klausblume$ sudo rm /System/Library/Caches/com.apple.IntlDataCache*

    Password:

    Macintosh-7:~ klausblume$ sudo rm /var/folders/*/*/-Caches-/com.apple.IntlDataCache*

    rm: /var/folders/*/*/-Caches-/com.apple.IntlDataCache*: No such file or directory

    Macintosh-7:~ klausblume$

     

    No such file or directory

     

    As far as Onyx is concerned, the homepage is flogging MacKeeper (ugh). Is Onyx MacKeeper in disguise?

  • Klaus Blume Level 2 Level 2

    I have a supplemental question: As I mentioned in my first post, this happened after a 'fresh 10.7.5 install.' What does that mean? Has the original system been replaced, or just repaired? What would happen, if I were to start up from an external HD, delete the system, and then do a fresh install? Or does 10.7 look for 10.6 to proceed?

     

    Thanks

  • Klaus Blume Level 2 Level 2

    I am hornswoggled!

     

    After I ran the Terminal commands, and got the No such file or directory, I gave up, closed the computer, and had a cup of coffee.

     

    After I re-opened it, I checked the Language & Text settings one more time, and, voilà, everything was there...

     

    So the sudo commands must have worked...

     

    Thanks,

     

    Klaus

  • Tom Gewecke Level 9 Level 9

    Klaus Blume wrote:

     

    After I re-opened it, I checked the Language & Text settings one more time, and, voilà, everything was there...

    Good news!