4 Replies Latest reply: Aug 19, 2014 10:04 PM by Macmazz
Bruce Polkowsky Level 1 Level 1 (5 points)

When I get a calendar invite via Mail on my iPhone 3GS (iOS 6.1.3) and accept it,  it puts

the appointment in the calendar based on the invite time basis (eastern time) rather than converting it

to my iPhone time zone (mountain time).    If I pull that same email invite up on my iMac Mail program and click on the

link then accept it, iCal on the iMac places it at the right time.   And, when I sync the iPhone with the iMac,  the appointments transfer correctly.

I have time zone support on settings set to mountain time on the iPhone.   Is there some other setting I have to make to

have the iPhone "read" these invites correctly?  Any clues as to getting this corrected would be appreciated. 


iPhone 3GS, iOS 6.1.3
  • sheila_m. Community Specialists Community Specialists (3,265 points)

    Hello Bruce,

     

    Thank you for posting in the Apple Support Communities.  You may need to turn off the Time Zone Support for the calendar entries to match your current time zone on your iPhone:

     

    If you do not use Time Zone Support, your iOS device will default to the current clock setting. iOS devices that are location aware will automatically set their time zone, date, and time using Location Services. You can verify your current date and time settings in Settings > Date & Time.

    To disable Time Zone Support for calendars

    1. Tap Settings > Mail, Contacts, Calendars.
    2. Scroll down to Calendars.
    3. Tap Time Zone Support.
    4. Slide the slider for Time Zone Support to OFF.

     

    You can find the full article here:

    iOS: How to adjust Time Zone Support for calendars

    http://support.apple.com/kb/HT4576

     

    I hope this helps get you back on track! 

     

    All the best,

    Sheila M.

  • Prosper168 Level 1 Level 1 (0 points)

    Sheila,

    I have the same problem (on my iPhone 4S) that Bruce describes. Sorry, but your solution does NOT work. I have always had my Time Zone support Off. Yet my calendars (on my iPhone and my original model iPad) both keep the time entry in the time zone of the Sender. My devices do not convert them to my time zone. This happens consistently.

     

    The Apple store Genius bar guy was not able to solve this. He said it cannot be fixed in Apple mobile devices. Is that true??? It's a big problem doing global business conference calls, especially if you don't know which time zone the Sender of the invitation is in.

     

    Please help!

    Thanks so much,

    Kel

  • roly1 Level 1 Level 1 (0 points)

    Hi, 

     

    Do you have a Gmail account?

     

    I've just solved this issue, it had to do with my gmail account calendar.  Go into gmail, select calendar, settings and select the country you are in.

     

    It had nothing to do with time zone support on the device.

  • Macmazz Level 1 Level 1 (0 points)

    The Gmail fix worked like a charm.  you have to log into your gmail account on a desktop. Change the calendar settings from there.  If you started a gmail account in a different time zone and then moved, it won't automatically update it.  you have to manually. 

     

    Thanks roly1.