6 Replies Latest reply: Nov 6, 2013 6:36 AM by Author48
Rubiao Level 1 Level 1 (0 points)

I am using Itunes 11, Windows 7 and manually managing all my music on my iphone.  I tried to add and delete some ringtones lately and ran into trouble.  All my ringtones are listed in Itunes as Tones, all functional, all are under 40 seconds, etc.  I can add music to my iphone without any issues so it can't be space related.  I have tried renaming files, checking, unchecking, etc, nothing works.  They are listed in itunes on my iphone section, but are all grey with the grey circle to the left that usually indicates they are about to start transferring, but they never do.  If you delete them and start over again, it does the same thing.  The other strange part is that they all used to be on my iphone, but I accidentally deleted them trying to play around with new ones the other day.  Now they won't go back.


Any ideas?

iPhone 4S, Windows 7
  • Ocean20 Level 6 Level 6 (13,525 points)

    Tones have to be 30 sec or lessand maybe that is part of your problem.  Also you might want to read this user tip https://discussions.apple.com/docs/DOC-3792

  • Rubiao Level 1 Level 1 (0 points)

    All the tones are under 30 seconds (though that article mentioned 40 seconds as the threshold).  Some are only 5 seconds, some are 15, some are 25.  I had found that article, but it didn't really apply to my situation.

  • thehillnl Level 1 Level 1 (0 points)

    I solved my problem after I sarted having issues with ringtones syncing after switching to IOS5. I have struggled with this ever since and had to make do with the few ringtones I could load. I am computer savy but I just don't have a lot of time to spend. So after reading through several fourms with all sorts of solutions offered and finding some of them help but didn't solve all of my issues I begin to realize that perhaps there was more than one issue. I have tried all of the common things like:


    1. having all items checkd in Itunes (bell) at top on side bar

    2. having sync on the device checked

    3. Right clicking  and selecting "get info" in Itunes (bell) at top on side bar and making sure that the type is "ringtone"

    4. Unchecking "sync all" and selecting "sync checked" on the device ring tone tab and selecting the ring tones

    5. making sure all ring tones are under 30 seconds (40 according to apple) (mine under 20)

    6. unselecting Sync ring tones in the device tab then syncing then reselect and resync with tones checked.


    No of these did more than allow me to load more then four ring tones at once. So as I suspected there was more.


    One of the other solutions mentioned was to basically recreate or at least reload the ring tones into the itues library. Some say this helps while other said it did not. I did not try this although I now understand how this might solve some peoples issues. But here is what I did in addition to the steps above and now all of my ring tones now load. So I wanted to pay it back to those who posted and hope this helps others yet to figure it out.


    I went into "get info". To find this go the view menu and select view side bar (to fix the new itunes format so it looks like the old format and so you can find the ring tones). With the side bar exposed, look for the bell next to tones. This will be where your find your ring tones for your tunes library. Click on ring tones. Then click on the top ring tone. right click on "Get Info" and look under kind and make sure it says ring tone. Click next and go down through all of your ring tones to verify that all say kind for the ring tone. If it says that it can not find the file for a ring tone select find file and search to find the file it was created from. If you do not find it you will have to delete it and then recreate it. Next still under "Get Info" click on the "Info" tab. Make sure the name and artist is filled in. If so and you still have issue change the artist name (doesn't matter what I used unknown 1, unknown 2, etc.).  Now make sure all steps above are completed and then sync without Sync tones under device checked and then resync with sync tones checked using the sync only checked tones.


    The issues I still had after trying everything else is that a few files were missing and the artist name was missing. Apparently in IOS5 the artist name is required and it wasn't before. Hope this helps!

  • Author48 Level 1 Level 1 (0 points)

    I have been having the same issues with ringtones.  i.e., Sometimes they move over from the library, and sometimes they don't.  They are all less than 40 seconds, all identified as Ringtone, all in m4r format, and it didn't make any difference.  But  thehillni came up with a solution that no one else, either at Apple, EHow, or any other source discovered.  I just went in to the tones in my iTunes library, gave them all new artist names ... I used unknown, but it doesn't make any difference what you use ... and they all came over to the phone except one. I went back to that one in the library, made another slight change in the artist name and it moved right over.  I'm psyched and synced. Thanks thehillni.

  • 39A Level 1 Level 1 (0 points)

    i have the problem syncing the ring tones to iphone. i just could not find the check button to select the tones in the music library. appreciate your help!

  • Author48 Level 1 Level 1 (0 points)

    1. Make sure the tone is in m4r format (by putting tone on desktop and "renaming" it to m4r).

    2. Make sure tone is less than 40 seconds long (can be adjusted/customized when you open "get info").

    3. In "Get Info", make sure you insert the artist name and composer. Make something up if you don't know.

    4. Change type to "Ringtone" in the same "Get Info" area. So now on the info screen under "get info" you should see that there's a name of an artist and the name of a composer and it has to be under 40 seconds and listed as a m4r file and as a "Ringtone". If that's what you see,keep going to #5.

    5. If you are in Ringtones, it should have check boxes on the left. Click each one you want to sync.  And then try it.

    I was very frustrated with this whole thing but now I have no problem with it. Contact again if this doesn't fix the problem.