Previous 1 2 Next 18 Replies Latest reply: May 22, 2013 8:27 PM by Ascherose
Ascherose Level 1 Level 1 (0 points)

I've lurked on these forums for a while, and had a mostly problem-free experience with my Mac, but I believe I have some circumstances which warrant creating my own topic. Here's my system specs:


iMac 21.5, mid 2011

2.7Ghz Intel Core i5

AMD 6770m 512mb

12GB RAM (2 2GB Apple default DIMMS, and 2 4GB Crucial DIMMs.)

OS X 10.7.5 Lion (the product listing in my username was made before the .5 update.)


I have had my mid-2011 iMac for 17 months, and began experiencing random kernel panics about once a day, for the last week or so. At first I suspected it to be an issue with the sound card because most of these panics happened while I was in Skype calls. I ran AHT and everything came up clean: I checked Skype, iTunes and Software Update (no updates were found for any of them.)


Even though AHT passed my RAM, I read up on kernel panics again--and even though my computer had no signs of being slow at the time of the panics, I dreaded that that might be the issue. I ran Rember, a frontend for memtest, with all of my RAM installed, and the computer panicked during the block sequential test. No other programs were running at the time. I have been using the 8GB of Crucial RAM for nearly a year without issues, but I still removed the bottom pair of DIMMS, which turned out to be the Apple-installed RAM. (It is likely that my father switched the Apple sticks to the bottom while helping me install the upgrade.)


I ran Rember again and found that the Crucial RAM passed all tests; since no other programs were running at the time, it leads me to believe the factory DIMMs may be faulty. My plan is to use the computer with only Crucial RAM for a day and make sure no panics occur, then run memtest with only Apple RAM installed; if a panic occurs, then I will know they're faulty.


My iMac has AppleCare, but the nearest Apple Store is about 3 hours away (no AASPs here, rural area.) Is it possible to get in contact with Apple and have them shipme some new RAM, in exchange for the old? Can I contact the store and UPS or mail the computer in for service and have it shipped back? If the RAM turns out to be faulty, should I just replace it with more Crucial RAM?


In case someone can pinpoint the issue as something other than a RAM problem, here's my latest kernel panic log, which occurred during memtest. During all of these panics, I was multitasking (games, iTunes, Skype) but hardware temperatures were never beyond what they usually are under load (Processor below 50c, GPU below 70.) The "BSD process in active thread" has varied from kernel-task to cider, as well as Skype.


Wed May 15 13:15:05 2013

panic(cpu 2 caller 0xffffff80002c4794): Kernel trap at 0xffffff800063d4b1, type 13=general protection, registers:

CR0: 0x000000008001003b, CR2: 0x00000001000dc000, CR3: 0x0000000000100000, CR4: 0x00000000000606e0

RAX: 0x000e050e5193c9d8, RBX: 0x0000000000000000, RCX: 0xffffff80196d8480, RDX: 0x0000000000000000

RSP: 0xffffff81600dbf00, RBP: 0xffffff81600dbf30, RSI: 0x00000000283baec0, RDI: 0xffffff801a6cf780

R8:  0xffffff7f80fd0523, R9:  0xffffff7f80fd0534, R10: 0x8000000000100000, R11: 0xffffff80002dad00

R12: 0xffffff7f80a1d258, R13: 0x0000000000000000, R14: 0x0000000000000000, R15: 0x0000000000000000

RFL: 0x0000000000010206, RIP: 0xffffff800063d4b1, CS:  0x0000000000000008, SS:  0x0000000000000010

CR2: 0x00000001000dc000, Error code: 0x0000000000000000, Faulting CPU: 0x2



Backtrace (CPU 2), Frame : Return Address

0xffffff81600dbbb0 : 0xffffff8000220792

0xffffff81600dbc30 : 0xffffff80002c4794

0xffffff81600dbde0 : 0xffffff80002da55d

0xffffff81600dbe00 : 0xffffff800063d4b1

0xffffff81600dbf30 : 0xffffff800063c250

0xffffff81600dbf70 : 0xffffff800063c0f4

0xffffff81600dbfb0 : 0xffffff8000820057



BSD process name corresponding to current thread: kernel_task



Mac OS version:




Kernel version:

Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64

Kernel UUID: FF3BB088-60A4-349C-92EA-CA649C698CE5

System model name: iMac12,1 (Mac-942B5BF58194151B)



System uptime in nanoseconds: 5297713283430

last loaded kext at 48556268997:          1.9.5d0 (addr 0xffffff7f81d21000, size 28672)

last unloaded kext at 175520151624:          5.1.0 (addr 0xffffff7f80a7d000, size 65536)

loaded kexts:

com.razer.naga.driver          2.0.0          1.9.5d0          3.0          122          1.59          3.5.9          2.2.5a5          2.2.5a5          7.3.2          100.12.75          1.0.0d1          5.0.0d8          4.0.8f17          7.0.0          2.0.1d2          5.0.0d8          1.2.3          3.1.33          1.6.0          7.3.2          170.2.2          1.0.33          7.3.2          4.0.8f17          2.0.3          312          3.2.1          3.0.6          1.0.0d1          1.0.0d1          33          404          2.1.0          5.1.0          4.9.0          505.67.1          3.2.4b8          1.6.1          2.3.1          5.1.0          1.5          1.5          1.7          1.9          1.5          1.6          195.0.0          3.2.30          1.4          8          195.0.0          160.7          160.7          4.0.8f17          1.0          2.2.5a5          80.0.2          10.0.5          2.2.5          5.0.0d8          3.1.3d10          1.8.6fc18          1.3          2.2.5a5          2.2.5a5          5.1.1d6          3.1.33          1.0.10d0          1.1.8          1.1.8          1.0.4          1.0.10d0          7.3.2          7.3.2          2.3.4          7.3.2          2.3.4          1.8.5          1.8.5          1.8.5          1.2.5          4.0.8f17          4.0.8f17          3.2.1          1.7          1.7.1          1.7.1          5.0.0          3.2.1          3.0.3          3.2.1          5.1.0          5.0.0          1.6.0          2.0.3          5.0.0          4.4.8          420.3          1.0.1b1          2.1          2.0.8          5.1.0          1.6.1          1.7.1          1.1          177.9          1.0.0d1          331.7          1.7.2          28.18          1.5          2.7          1.4


Thank you for reading. I apologize for the long post.

iMac, Mac OS X (10.7.3)
  • babowa Level 7 Level 7 (28,320 points)

    If you have Applecare, you can request in home service, but only if you are located within 50 miles of the nearest AASP. So, if you're rural, I'd assume that is not an option. However, if you call Applecare, they will no doubt go through some troubleshooting steps on the phone (tell them what you've done already) and, if they determine that it's the RAM (RAM can go bad just like anything else), this might be a do it yourself repair: they'd send out new RAM and you have to return the old after uninstaling it. At least that is what I'd be trying for at this point. If the new RAM does not make a difference, then I'd call back Applecare to proceed to plan B (whatever they might suggest that would be).

  • Mike Sombrio Level 6 Level 6 (13,730 points)

    More likely is this kernel extension

    com.razer.naga.driver          2.0.0

    You should remove it and see ifthe panics stop.

  • Ascherose Level 1 Level 1 (0 points)

    Hi Mike, thanks for the reply:


    I am hesitant to remove the Naga driver because I use my Razer Naga as a replacement for the Apple mouse. I have used the mouse and its driver since getting this computer, and haven't had any issues with it before. It might sound a bit odd, but I have issues with my fingers and nearly require the Naga's side buttons to play Guild Wars 2 and other games, which I do often.


    I don't use any custom keymaps, which is mostly what that driver enables, but I do have the DPI settings set as high as they can go, and I'm concerned about losing those settings when I uninstall the driver. I do recognize that a lot of non-Apple kexts can create issues, and I will attempt to remove the driver if I still get panics after testing the Apple RAM by itself later tonight.


    (The good news is that I've been running at normal load for some time: no panics and very few page outs. While it would definitely be nice to receive a set of replacement DIMMs shipped to my home, and I will keep AppleCare contact in mind, I may wind up replacing the Apple RAM with Crucial if I can get the money for it, as some people suggest using same-vendor memory in all slots.)

  • babowa Level 7 Level 7 (28,320 points)

    I've had a combination of both the OEM RAM plus OWC ( RAM in the last 5 of my Macs/MBP's without any negative effect. There was an issue with the late 2009/early 2010 iMacs which would only work reliably if maxed out at 16 GB of OEM RAM or a lower number with a combination of RAM; other than that, I've not heard that having the same mfr in all slots is better - matching the size is more important, i.e. 2 x 4 GB plus 2 x 2 GB (that is the combo I have) and, of course, having the exactly correct specs.

  • Ascherose Level 1 Level 1 (0 points)

    Interesting, and good to know. When I upgraded the RAM, I went with Crucial because that brand came recommended on multiple forums, and OWC RAM was more expensive at the time. I was concerned about having an "odd" number of RAM (12 versus 16GB), but then I read your post again and you mentioned using the same combination. The friend who bought the RAM for me (after I linked the correctly researched kind) had suggested I max myself out, but 16GB feels like overkill--and I've only gotten a handful of page outs (maybe 100 per half a million page ins) when all 12 GB were working.


    Conversely, the stock 4GB is not enough for what I use the Mac for (all of it was in use under typical load).


    On topic: I tested the original 2x2 sticks, without the upgrade RAM, and they somehow managed to pass all tests. I find this very strange. I filled all four slots again and am going to test under normal use for a while. If I get another kernel panic, I'll try removing the mouse driver as Mike suggested. I also reset the SMC when reinstalling all the RAM.


    Although AHT came up clean, I didn't run it in extended mode (there still is the fact that both sets passed memtest seperately.) Maybe one of the DIMMs became slightly unseated, as occasionally happens with PCs. There also may have been a bit of dust in the RAM slots (yes, I know, dust is very, very bad for an iMac, but I've little control over my environment, stuck in the Midwest.) Were it possible in my current situation, I'd be much more thorough when it came to maintaining my hardware--I expect to move to Washington state before my AppleCare expires, and take my iMac in for a full cleaning (and possible screen replacement due to the infamous "gray smudge" issue) when I get there.


    Regardless of whatever caused these panics, I'll keep this thread updated if they reoccur. I appreciate any further advice anyone can offer about the logs as well.


    Message was edited by: Ascherose Reason: clarified SMC reset was performed

  • babowa Level 7 Level 7 (28,320 points)

    Good luck with your move; if you have Applecare and live within 50 miles of an AASP, remember to ask for in home service - it's a treat not to have to lug a 27" anywhere... as for the RAM: matching it horizontally is important. Mine is a 2010, so I decided not to gamble and stuck with 12 GB which has been fine even though I do a fair share of video editing/rendering/burning. And, as for the tests: AHT is not 100% reliable; Apple stores or AASPs have far better testing equipment, but you really should run the extended test at least 3 times before dismissing AHT results.

  • ~Bee Level 7 Level 7 (31,270 points)

    You could delete the razer driver just to test.

    If the KPs continue, then just put it back.

  • Ascherose Level 1 Level 1 (0 points)

    Well, I was going to post earlier that the issue had been resolved after resetting the SMC and dusting the RAM slots, but two strange things happened today:


    1. Randomly, all my apps quit. Even the Finder went blank, leaving only my desktop background for a few seconds. There was no kernel panic or boot sequence: when my dock and menu bar reappeared three seconds later, all my programs were closed and opened up as if doing a Lion Resume. This hasn't happened before.


    2. About fifteen minutes ago, I got another panic, after having none, with the computer having been on for 12 hours without issue. After rebooting, I removed the Naga kext/preference pane. While I was putting my password in to authorize removal of the panel, my computer went to a gray screen and displayed the message "You shut down your computer because of a problem."


    After this, I was able to remove the software and restart gracefully as instructed. The mouse and side buttons still function without the driver, which is good. There is now no preference pane in my System Preferences window for the mouse, and Activity Monitor does not list the RazerNagaHelper process anymore, and there are no kexts with "razer" in /System/Library/Extensions, so I've removed the driver as best as I can.

  • ~Bee Level 7 Level 7 (31,270 points)

    And so, since doing that, have you had any more KPs?

  • Ascherose Level 1 Level 1 (0 points)

    There have been no immediate issues, but it's only been an hour or two, so it's hard to tell. Most of the time, the panics occur when I'm in a Skype call, although I've had a few that happened when I was not. I repaired disk permissions and am in the process of doing a clean reinstall of Skype (I deleted Skype's preferences and plist as instructed on Microsoft's site), so we'll see if that fixes it.


    Earlier today, I turned the display off while napping, and the computer didn't panic, which leads me to think it must be some sort of software issue. I hope removing the driver and reinstalling Skype will help.

  • Ascherose Level 1 Level 1 (0 points)

    Had another kernel panic: this time during Skype, as usual. When the kernel panic occurs, the sound will skip and loop while the alert displays--and it always seems to happen when either me or my contact is speaking. I can be in call for several hours before this happens. The only major contributor to these panics I can see now is my headset.


    I am using a Razer Carcharias headset (I know, Razer is starting to fail me), that has no drivers, and standard 3.5mm jacks. The mic doesn't work, as the iMac is only line-in, but that never bothered me because I prefer to use the built-in one. The headset is set as an output device both in Skype and in System Preferences -->Sound. I've gone several days without being on Skype, and still using the headset for iTunes and so on--no panics. But after a few hours of Skype, no matter what I'm doing as long as that's running: panic. Every time.


    Some people on these forums have reported issues with panics when plugging in headphones or removing them, but I've never had that sort of problem. The log which I post below makes mention of a razerhid text that did not appear before I removed the mouse. I removed that kext by uninstalling another Razer driver before making this post, and testkext does not show any kext by that name running now.


    But I can't figure out why a HID kext or driver would interfere with sound devices. It must be the headset somehow, which greatly disappoints me, as I've used the external speakers in calls for a year without issue.


    Others have mentioned fears that these kinds of panics might be an issue with the logic board. I severely hope it's not a logic board issue: because of the wait times with Apple repair, I'd probably have to have my parents drive the machine in, drive back, wait a week, and repeat. This computer is quite literally my livelihood, but I can't ask them to drive two to three hours one way just for that. (Sadly, the only shops in a 50 mile radius that even mention Mac repair are those that have techs, in some cases uncertified, do repairs. Can't void my AppleCare like that.)


    I am considering contacting Razer support and seeing if they have any advice on the issue. Here's my latest kernel panic log (ignore the razerhid kext, removed it already)


    Fri May 17 16:02:25 2013

    panic(cpu 0 caller 0xffffff80002c4794): Kernel trap at 0xffffff80003d401c, type 14=page fault, registers:

    CR0: 0x000000008001003b, CR2: 0xffffff80ffffff98, CR3: 0x0000000000100000, CR4: 0x00000000000606e0

    RAX: 0x00000000366789ce, RBX: 0x0000000000008168, RCX: 0x00000000005976b6, RDX: 0xffffff8019bf2220

    RSP: 0xffffff8160293f20, RBP: 0xffffff8160293f70, RSI: 0xffffff8160293ee8, RDI: 0xffffff8019bf2220

    R8:  0x7fffffffffffffff, R9:  0x7fffffffffffffff, R10: 0x8000000000100000, R11: 0xffffff800063dc04

    R12: 0xffffff80003d3fc0, R13: 0x0000000000000000, R14: 0xffffff80ffffff80, R15: 0xffffff80ffffff80

    RFL: 0x0000000000010282, RIP: 0xffffff80003d401c, CS:  0x0000000000000008, SS:  0x0000000000000010

    CR2: 0xffffff80ffffff98, Error code: 0x0000000000000000, Faulting CPU: 0x0



    Backtrace (CPU 0), Frame : Return Address

    0xffffff8160293bd0 : 0xffffff8000220792

    0xffffff8160293c50 : 0xffffff80002c4794

    0xffffff8160293e00 : 0xffffff80002da55d

    0xffffff8160293e20 : 0xffffff80003d401c

    0xffffff8160293f70 : 0xffffff800023dbbc

    0xffffff8160293fb0 : 0xffffff8000820057



    BSD process name corresponding to current thread: kernel_task



    Mac OS version:




    Kernel version:

    Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64

    Kernel UUID: FF3BB088-60A4-349C-92EA-CA649C698CE5

    System model name: iMac12,1 (Mac-942B5BF58194151B)



    System uptime in nanoseconds: 69769850451127

    last loaded kext at 33439879880:          160.7 (addr 0xffffff7f81d2f000, size 20480)

    last unloaded kext at 141596393685:          5.1.0 (addr 0xffffff7f80a72000, size 65536)

    loaded kexts:

    com.razer.common.razerhid          1.5          1.9.5d0          3.0          122          1.59          3.5.9          2.2.5a5          2.2.5a5          100.12.75          7.3.2          5.0.0d8          1.0.0d1          4.0.8f17          7.0.0          2.0.1d2          1.2.3          3.1.33          5.0.0d8          1.6.0          7.3.2          170.2.2          1.0.33          7.3.2          4.0.8f17          312          2.0.3          3.2.1          3.0.6          404          2.1.0          1.0.0d1          1.0.0d1          33          5.1.0          505.67.1          3.2.4b8          1.6.1          4.9.0          2.3.1          5.1.0          1.5          1.5          1.7          1.9          1.5          1.6          195.0.0          3.2.30          1.4          8          195.0.0          160.7          160.7          4.0.8f17          1.0          2.2.5a5          80.0.2          10.0.5          2.2.5          1.8.6fc18          1.3          2.2.5a5          2.2.5a5          3.1.3d10          5.0.0d8          5.1.1d6          1.0.10d0          3.1.33          1.0.4          1.1.8          1.1.8          1.0.10d0          7.3.2          7.3.2          2.3.4          7.3.2          2.3.4          4.0.8f17          4.0.8f17          1.8.5          1.8.5          1.8.5          1.2.5          3.2.1          1.7          1.7.1          1.7.1          5.0.0          3.2.1          3.0.3          3.2.1          5.1.0          5.0.0          1.6.0          2.0.3          5.0.0          420.3          1.0.1b1          2.1          4.4.8          2.0.8          5.1.0          1.6.1          1.7.1          1.1          177.9          1.0.0d1          331.7          1.7.2          28.18          1.5          2.7          1.4

  • Mike Sombrio Level 6 Level 6 (13,730 points)

    I would definately contact Razer, but before I did that I would eliminate everything Razer, hardware and software to make sure that it's ne of their products causing the panics. Razer is more than likely going to tell you that it's an Apple problem and you should take it up with Apple. Apple will tell you, as most users on here will, to remove everything non Apple to see if the panics go away.

  • Ascherose Level 1 Level 1 (0 points)

    All of the Razer drivers are gone, and I decided against contacting them, as I think the problem is occuring whenever sound is played through anything conneted to the jack. As you said, I doubt they'd have any advice or even be experienced enough with Macs to know too much about the issue. I got another panic, about 5 minutes after plugging the headphones in while iTunes was on. I'm wondering if there's something wrong with CoreAudio or any audio drivers, but I know that anything like that can't really be resolved except by reinstalling the OS.


    I ran the AHT in extended mode, and in normal mode--neither found anything. I also reset the PRAM.


    Reinstalling the OS presents its own set of problems. While I'd like to start over with a new filesystem because it's been about a year, I'm on a slow 1.5mbps DSL connection, and the last time I needed to reinstall, the computer was unusable for the entire day while it downloaded the OS. I've considered upgrading to Mountain Lion for several reasons (security, graphics drivers, so on). Since I want to do a clean install, that becomes more complicated: I don't have a large enough flash drive to make a bootable ML image. I have some blank DL-DVD's laying around, but I'm concerned that something will go wrong with the burning process. If I find out the burn was faulty after erasing my HD, I won't have an OS.


    I've backed up all my important programs and data, and I'm testing the system under typical use without the headphones in, to see if I get any more panics. I've left the headphones in overnight while downloading things, and the computer hasn't crashed. It seems to only occur when a program is passing audio through the jack.

  • Mike Sombrio Level 6 Level 6 (13,730 points)

    Lion had some bugs early on but I thought they had them all worked out, I never used it, I went straight from Snow Leopard to ML. So do the panics persist if you're not using a Razer device? Can you use Skype without any Razer stuff just to test? I really think if you keep introducing their stuff into the equation you're never going to figure it out.

Previous 1 2 Next