9 Replies Latest reply: Apr 8, 2014 1:21 AM by Loc Kim
whippersnapper80 Level 1 (0 points)



I am using my own monitor profiles (calibrated with a Spyder).

In the past, OS X always displayed the colors with the correct profile - the ones I told it to use.


After buying an SSD for my MacBook Pro I have installed Mountain Lion from scratch. No big deal. Everything runs smoothly.

But all of a sudden it doesn't remember the custom profiles although they are in the same old ColorSync folder.

OS X boots and picks the generic profiles instead of my own profiles.


Strangely enough, when opening the System Preferences and going to the Display section, OS X switches to the right profile the moment I click on the Color pane.


I have seen other community members writing about such a phenomenon. However, I haven't seen anyone giving a solution to this strange behavior.


PLEASE HELP, if possible.




MacBook Pro, OS X Mountain Lion (10.8.3)
  • Eric Root Level 9 (50,299 points)

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.


    Isolating an issue by using another user account


    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application unistaller. For each disable/delete, you will need to restart if you don't do them all at once.


    Safe Mode


    Safe Mode - About


    General information.


    Isolating issues in Mac OS X


    Troubleshooting Permission Issues



    Step by Step to Fix Your Mac

  • Linc Davis Level 10 (192,529 points)

    Problems such as yours are sometimes caused by files that should belong to you but are locked or have wrong permissions. This procedure will check for such files. It makes no changes and therefore will not, in itself, solve your problem.

    First, empty the Trash.

    Triple-click the line below to select it, then copy the selected text to the Clipboard (command-C):

    find ~ $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID -o ! -perm -600 -o -acl \) 2> /dev/null | wc -l

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear.

    The output of this command, on a line directly below what you entered, will be a number such as "41." Please post it in a reply.

  • whippersnapper80 Level 1 (0 points)

    @ Linc Davis and Eric Root


    Repairing the Disk Permissions did the trick. Thanks a lot.

    Verifying the permissions already showed that the ColorSync folder had incorrect permissions.

  • scottl31 Level 1 (5 points)

    I've been using Snow Leopard for 2 years (Mac Mini) and had two different monitors in that time. I just got an Asus VE228 monitor and it was really bright and washed out. So I made a setting that looks good but it won't stay selected after a reboot.


    Same thing happened. When opening the System Preferences and going to the Display section, it switches to the right profile the moment I click on the Color tab.


    Repairing permissions did not fix it. I tried making a new user and it does the same thing with that user. I tried a system reinstall and it didn't help.


    I tried that terminal thing above but I don't get a new line ending with $. I just get a new line with a 0.


    Can anybody help me get my monitor setting to stick?




  • Eric Root Level 9 (50,299 points)

    You might want to consider starting a new discussion. Since this one is marked solved, less people are likely to look at it.

  • scottl31 Level 1 (5 points)

    oops, I didn't notice that. Thanks!

  • Loc Kim Level 1 (0 points)

    Hi Scott,

    did you found an answer to your problem? I'm stuck with the same problem and cannot seems to find a solution.


  • scottl31 Level 1 (5 points)

    I did find a way to fix it, but I just can't remember how. I forgot I had posted here, otherwise I would have come back and put it in here. I think it involved editing some plist files. Sorry I can't be more help. Scott

  • Loc Kim Level 1 (0 points)

    Hi Scott,

    thank you for your answer. I finally solved my permissions problems with "Cocktail". I fanilly could save my Calibration through ColorSync Utility as well as Spyder4Elite. I recommend it.