8 Replies Latest reply: Nov 22, 2014 5:52 PM by Norman Turrill
andycswain Level 1 Level 1 (0 points)

I am consistently getting this pop up window when I return to my contacts. Can anyone advise what this means and if there is a solution. I never normally get messages that lead to no solution?

 

Contacts error message.png


MacBook Pro, OS X Mountain Lion (10.8.3)
  • Linc Davis Level 10 Level 10 (164,640 points)

    Please try again to post your screenshot, or post the exact, complete text of the error message.

  • andycswain Level 1 Level 1 (0 points)

    the pop up box says.

     

    "The operation could not be completed

    No other information is available about the problem."

     

     

    Screen Shot 2013-05-19 at 00.05.26.png

  • Linc Davis Level 10 Level 10 (164,640 points)

    Launch the Console application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.

     

    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select

    View Show Log List

    from the menu bar.

     

    Click the Clear Display icon in the toolbar. Then try the action that you're having trouble with again. Select any messages that appear in the Console window. Copy them to the Clipboard (command-C). Paste into a reply to this message (command-V).

    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.

    Please do not indiscriminately dump thousands of lines from the log into this discussion.

    Important: Some private information, such as your name, may appear in the log. Anonymize before posting.

  • andycswain Level 1 Level 1 (0 points)

    This might have done it. The dialog box has disappeared once I cleared display in console. Thanks!

  • Linc Davis Level 10 Level 10 (164,640 points)

    I'm glad the issue is resolved, but what I told you to do couldn't possibly have resolved it.

  • bug00 Level 1 Level 1 (45 points)

    I have been having this *exact* problem as the Original Poster. 

     

    It is not a particular action that I take that triggers the error message (which is exactly as the OP showed in his screen shot)...but rather it seems to occur when Contacts is synchronizing with iCloud.  For instance, if I leave Contacts running in the background, when I return to the application, the error message will already be displayed, even though I haven't taken any manual actions within the application.

     

    It seems to have begun (if memory serves) after I had merged some contact cards (so that I would only see one card and photo for people who already had existing contact cards in my data base and also had Facebook-generated cards after the new OX began including them). 

     

    I followed the instructions you posted above, and perhaps it does seem to be Facebook related from the info in the error code.  (I had to laugh at the portion that "the user deserves better" than a generic error code.  haha)  If you wouldn't mind taking a look at this and seeing if there is anything I can do to clear it up, I would certainly appreciate it.  (I anonymized my doman and user id to paste in here...but they were correct in the log.):

     

    5/27/13 1:52:59.602 PM Contacts[18123]: [CardDAVPlugin-ERROR] -getHomeInfo:[_controller containersAtURLs:{(

        https://tracey%40anonymizeddomain.com@webdav.facebook.com:443/anonymizeduserid/c ontacts/

    )}] Error Domain=CoreDAVHTTPStatusErrorDomain Code=401 "The operation couldn’t be completed. (CoreDAVHTTPStatusErrorDomain error 401.)" UserInfo=0x7fa35639ead0 {CoreDAVHTTPHeaders=<CFBasicHash 0x7fa3563577e0 [0x7fff77a74110]>{type = immutable dict, count = 10,

    entries =>

              0 : Case Insensitive Key: Pragma = <CFString 0x7fa35632a460 [0x7fff77a74110]>{contents = "no-cache"}

              1 : Case Insensitive Key: X-FB-Rev = <CFString 0x7fa3566de1c0 [0x7fff77a74110]>{contents = "827944"}

              2 : Case Insensitive Key: Content-Type = <CFString 0x7fa35639b950 [0x7fff77a74110]>{contents = "text/plain; ; charset="utf-8""}

              3 : Case Insensitive Key: Connection = <CFString 0x7fa35666cb00 [0x7fff77a74110]>{contents = "keep-alive"}

              6 : Case Insensitive Key: Date = <CFString 0x7fa356359120 [0x7fff77a74110]>{contents = "Mon, 27 May 2013 20:53:00 GMT"}

              8 : Case Insensitive Key: X-FB-Debug = <CFString 0x7fa356353950 [0x7fff77a74110]>{contents = "UEoD+e8lZhiO6IO8jnKSyFzYtFhYZ3gqMG3kMrrDwTg="}

              9 : Case Insensitive Key: Www-Authenticate = <CFString 0x7fa356692560 [0x7fff77a74110]>{contents = "OAuth realm="Facebook WebDAV", Basic realm="Facebook WebDAV""}

              10 : Case Insensitive Key: Content-Length = <CFString 0x7fff77a4e0a0 [0x7fff77a74110]>{contents = "40"}

              11 : Case Insensitive Key: Cache-Control = <CFString 0x7fa356322240 [0x7fff77a74110]>{contents = "private, no-cache, no-store, must-revalidate"}

              12 : Case Insensitive Key: Expires = <CFString 0x7fa3563d0660 [0x7fff77a74110]>{contents = "Sat, 01 Jan 2000 00:00:00 GMT"}

    }

    }

    5/27/13 1:52:59.614 PM Contacts[18123]: -[NSAlert alertWithError:] called with nil NSError. A generic error message will be displayed, but the user deserves better.

    5/27/13 1:52:59.839 PM Contacts[18123]: -[ACAccountStore renewCredentialsForAccount:withHandler:]: unrecognized selector sent to instance 0x7fa356584810

  • Norman Turrill Level 1 Level 1 (5 points)

    I had this exact same error dialog box from Contacts:

     

    ContactsDialog.png

     

    I agree that your procedure in Console could not have resolved the problem. I found the following lines in my Console log:

     

    11/22/14 6:59:04.710 AM Contacts[50284]: AOSKit WARN: Invalid url: https://nturrill%40mac.com@carddav.linkedin.com/v1/carddav/1533478///nturrill%40mac.com@carddav.linkedin.com/v1/carddav/1533478/

    11/22/14 6:59:04.920 AM Contacts[50284]: [CardDAVPlugin-ERROR] -[CDXAccount acAccount]: Failed to find ACAccount for identifier: 43D27D4A-7C0B-48F8-B8B0-B0FDB098C42E

    11/22/14 6:59:04.921 AM Contacts[50284]: [CardDAVPlugin-ERROR] -[CDXAccount acAccount]: Failed to find ACAccount for identifier: 43D27D4A-7C0B-48F8-B8B0-B0FDB098C42E

    11/22/14 6:59:04.976 AM Contacts[50284]: [CardDAVPlugin-ERROR] -getPrincipalInfo:[_controller supportsRequestCompressionAtURL:https://nturrill%40mac.com@carddav.linkedin.com/v1/carddav/1533478///nturrill%40mac.com@carddav.linkedin.com/v1/carddav/1533478/] Error Domain=CoreDAVHTTPStatusErrorDomain Code=401 "The operation couldn’t be completed. (CoreDAVHTTPStatusErrorDomain error 401.)" UserInfo=0x618000671f80 {CoreDAVHTTPHeaders=<CFBasicHash 0x618000671dc0 [0x7fff71fd3cf0]>{type = immutable dict, count = 14,

    entries =>

      0 : Content-Type = <CFString 0x61000025cdd0 [0x7fff71fd3cf0]>{contents = "text/xml;charset=UTF-8"}

      1 : X-Li-Pop = PROD-ELA4

      2 : x-li-format = xml

      3 : X-LI-UUID = <CFString 0x610000448f70 [0x7fff71fd3cf0]>{contents = "8PmAlloEqROA0kn0jisAAA=="}

      5 : Content-Encoding = gzip

      6 : Server = <CFString 0x610000455480 [0x7fff71fd3cf0]>{contents = "Apache-Coyote/1.1"}

      7 : Set-Cookie = <CFString 0x61000012cc60 [0x7fff71fd3cf0]>{contents = "lidc="b=LB89:g=118:u=1:i=1416668344:t=1416754744:s=2086930976"; Expires=Sun, 23 Nov 2014 14:59:04 GMT; domain=.linkedin.com; Path=/"}

      8 : Transfer-Encoding = <CFString 0x7fff72c70598 [0x7fff71fd3cf0]>{contents = "Identity"}

      9 : x-li-request-id = <CFString 0x610000420d40 [0x7fff71fd3cf0]>{contents = "NCR28GO65T"}

      13 : Date = <CFString 0x610000258360 [0x7fff71fd3cf0]>{contents = "Sat, 22 Nov 2014 14:59:04 GMT"}

      15 : X-Li-Fabric = PROD-ELA4

      17 : Connection = <CFString 0x610000420d60 [0x7fff71fd3cf0]>{contents = "keep-alive"}

      21 : Vary = *

      22 : Www-Authenticate = <CFString 0x610000463f40 [0x7fff71fd3cf0]>{contents = "OAuth realm="https://api.linkedin.com""}

    }

    }

    11/22/14 6:59:04.984 AM Contacts[50284]: [CardDAVPlugin-ERROR] -[PHXCardDAVSource renewAccountCredentials]: Unable to fetch account for identifier 43D27D4A-7C0B-48F8-B8B0-B0FDB098C42E

     

    An important clue was the first line showing LinkedIn and CardDAV were involved. The last line says "renewAccountCredentials". I then noticed that in the System Preferences, Internet Accounts panel, that the entry for LinkedIn was not logged in or perhaps had a old password. I completed the LinkedIn login and have not had the problem since.

     

    Clearly, part of the problem is that the error dialog message in Contacts must be changed to be more specific and to name the internet account that is the problem.

  • Norman Turrill Level 1 Level 1 (5 points)

    I take it all back. Quite some time later I returned to my computer to find Contacts had the same error dialog message. Logging into LinkedIn apparently did not solve the problem, although it seems possible that LinkedIn is still somehow involved.

     

    This problem started when I logged out of iCloud and then back in (under directions from Apple telephone support). My Contacts apparently were preserved On My Mac as well as in iCloud. I later noticed that every one of my contact entries had a new section labelled "cards" which listed both On My Mac and iCloud. These duplicate "cards" occurred on my MacBook Pro, but not on any of my other iCloud connected devices. Some of my contact entries also had "cards" for Facebook and LinkedIn. I tried to remove some of the duplicate cards for On My Mac (because I thought these entries might be needlessly taking up space on my hard drive). This caused duplicate contact entries in Contacts for these contacts. This is also when the error dialog messages started, and I do not know what to try next.