7 Replies Latest reply: May 20, 2013 9:15 AM by keisaiguy
keisaiguy Level 1 (0 points)

iMac 2.66 GHz Intel Core 2 Duo, 4 GB 1067 MHz DDR3 running Mac OS X 10.8.3 and Safari 6.0.4


On Friday 5/16/13 while searching for a method to get rid of advertisements for Google Chrome and Google Plus and the Google black toolbar, Safari was hijacked by YP.com, the  AT&T Yellow Pages"service". When I succeeded finally in getting rid of this uninvited inerlopeer, my Safari toolbar disappeared, too. Now I have no Back Button and no Search Field. On the Menu Bar, "Show Toolbar" does not work, and "Customize Toolbar" is greyed-out. I have to invoke File/New Window to perform, a search or query.


I reinstalled with the Safari6.0.4Lion.pkg, ran the huge OSXUpdCombo10.8.3 file, and rerpaired permissions -- all to no avail.


FireFox runs fine.


How can I restore Safari's functionality?

iMac 2.4GHz Intel Core 2 Duo, Mac OS X (10.5.4)
  • Linc Davis Level 10 (184,615 points)

    From the Safari menu bar, select


    Safari Preferences Extensions


    Turn all extensions OFF and test. If the problem is resolved, turn extensions back ON and then disable them one or a few at a time until you find the culprit.

  • keisaiguy Level 1 (0 points)

    Yesterday I jettisoned Adblock, NY Times Update, and Add to Amazon Wsh LIst. I have no longer have any extensions for Safari.

  • Linc Davis Level 10 (184,615 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, or by a peripheral device.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including Wi-Fi on certain iMacs.  The next normal boot may also be somewhat slow.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • seventy one Level 6 (12,640 points)

    Can't add anything to linc's excellent advice but, of course, you have to get rid of Chrome (if you haven't already).  Caused me no end of problems for a while, even MacKeeper reared its ugly head.

  • keisaiguy Level 1 (0 points)

    Step 1: Test as Guest: No joy, same result, no toolbar, etc.


    Step 2: Boot in Safe Mode, log in as Me: Same outcome.


    Interestingly, upon reboot after Test #2 an Apple page replaced my Google.com homepage that I had specified some time ago.

  • Linc Davis Level 10 (184,615 points)

    Back up all data.


    Boot into Recovery mode. When the OS X Utilities screen appears, follow the prompts to reinstall the OS. You don't need to erase the boot volume, and you won't need your backup unless something goes wrong. If your Mac was upgraded from an older version of OS X, you’ll need the Apple ID and password you used to upgrade, so make a note of those before you begin.

  • keisaiguy Level 1 (0 points)

    Thank you, Linc, for patiently wallking me through the remediation drill. My Safari app nows works as it should, and I am ever so grateful.