Previous 1 2 3 Next 32 Replies Latest reply: Oct 12, 2014 5:53 AM by sh60pilot
dickdutch Level 1 Level 1 (0 points)

Hi,

 

This is a really strange problem, or it seems it to me, and I'm not that familiar with Macs, even though I have one, so will explain it as best as I can.

 

When I connect to a wireless network, whether this is because the wireless has been out of range, switched off, or when my mac book wakes, Safarai launches a window trying to connect to http://vodafonemobile.wifi, with a popup login box stating "To view this page, you must log in to area “level_15_access” on vodafonemobile.wifi:80." Below is a screenshot.

 

If I cancel, sometimes it comes back, but either way, i'm still able to connect to the internet or browse the network etc, so it doesn't seem to effect performance, it's just really irritating.

 

I've tried resetting Safari, clearing the dns cache and changing proxy settings, I've also tried running console whilst I turn off and on the wireless, but there's nothing obvious it could be.

 

I need to add that I don't have anything vodafone on any of the networks I use, so I don't think it's that.

 

Your help would be really appreciated, if you need more info, let me know.

 

Thanks

 

Richard

 

grab.jpg


MacBook Pro (13-inch Late 2011), OS X Mountain Lion (10.8.3)
  • Topher Kessler Level 6 Level 6 (9,515 points)

    This may be an access page for an "Captive Portal" wifi network, where you have to log on before the wifi service will allow you to access. Go to your Network system preferences and then click "Wi-Fi." In here, see what network is being used in the "Network Name" menu, and if it's not your home or work network then try changing it to the desired one.

     

    If the problem persists, then click the Advanced button and in the "Wi-Fi" tab select and delete all "Preferred Networks" except those that you wish to use, and then order them in terms of preference. When finished click OK and try seeing if the network connection sticks with the one you prefer to use.

  • dickdutch Level 1 Level 1 (0 points)

    Thanks very much for your swift response. I've already tried that, I've removed all but 1 network and even turned off captive network.

  • Topher Kessler Level 6 Level 6 (9,515 points)

    This appears to be a login page to a vodafone wireless access point. Is that what you are using as your network router? It seems the device is available on the network since it's prompting you for a username and password.

     

    If this is the case, then you might have to adjust the device itself, either by restarting it, resetting it to factory defaults, or otherwise changing some settings on it. My guess is when you lose your network connection the access point re-establishes its connection and instructs your computer to access the device first.

  • dickdutch Level 1 Level 1 (0 points)

    No, I don't have any vodafone devices on the network, and this wouldn't explain why it happens wherever I am, it even happened when I was in a different country last week.

  • Topher Kessler Level 6 Level 6 (9,515 points)

    When you are connected to the intnernet without this message popping up, try opening a new tab in your browser and then entering the "vodafonemobile.wifi:80" address to see if you can connect. Let me know if the same password prompt shows up. Additionally, try opening the Terminal utility and run the following command:

     

    ping vodafonemobile.wifi

     

    If the ping command starts showing responses, press Control-C and then select and copy the responses to a message here.

  • dickdutch Level 1 Level 1 (0 points)

    When i'm connected to the internet and enter that address, it tries to connect and brings up the login box too.

     

    Pinging it gives this

     

    64 bytes from 10.68.17.1: icmp_seq=0 ttl=255 time=60.371 ms

     

    This is the address of the router, but it's not a vodafone device. And this happens regardless of which router i'm trying to connect to.

  • Topher Kessler Level 6 Level 6 (9,515 points)

    Somehow your system is configured for remote access or other direct access to the device. The vodafonemobile.wifi address is used for the Vodafone Mobile internet gateway, such as its R205 device, or perhaps its other phone systems. These are mobile Wi-Fi hotspots that connect you to a cell network, and for some reason your system is connecting to one. The fact that the ping is a ~60ms delay shows it's not some loopback to your computer, so somehow you are connecting to an external device. Additionally, the device is on your network since it cannot be accessed from a remote location such as where I am. Attempting to connect or ping it from California gives a timeout, and attempts to locate it suggests that it's behind a router or LAN.

     

    As a result, even though you might not think you have a vodafone device on the network, you very likely do. It may be someone's phone or perhaps be a service in your router you are not aware of.

     

    One option you can try is to reset your system's network configuration, by going to the Macintosh HD > Library > Preferences > SystemConfiguration folder and removing the following items:

     

    com.apple.airport.preferences.plist

    com.apple.network.identification.plist

    com.apple.RemoteAccessServers.plist

    NetworkInterfaces.plist

    preferences.plist

     

    In addition, remove the folder called "CaptiveNetworkSupport" and then restart your system and try setting up your Wi-Fi again.

  • Linc Davis Level 10 Level 10 (143,315 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, or by a peripheral device.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.
       
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including Wi-Fi on certain iMacs. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • dickdutch Level 1 Level 1 (0 points)

    Thanks for the help but this didn't work. I lost various things, but not the vodafone login page.

     

    I've restored the files, so things are back again, but I still have the issue.

  • dickdutch Level 1 Level 1 (0 points)

    Thanks Linc, I'll give this a go tomorrow when I get home and post the results.

  • dickdutch Level 1 Level 1 (0 points)

    Hi,

    Thanks to you both for the help. I've now solved the problem, I bought a new retina display mac book! A bit extreme, I know, but I was considering it anyway, and this was a good excuse.

    I used the migration tool, but worried it would pull across the file that was causing the issue, but it hasn't, so issue resolved.

    And the new mac book is really nice!

    Rich

  • jul3 Level 1 Level 1 (0 points)

    I have this problem as well, have had it since Sept when I had to connect to a Vodafone Mifi device at an offsite work event.  Only used it for 1 evening but have had this irritating window ever since.  I no longer work there, am currently over 16miles away from the Mifi, which is off anyway, and yet still anytime I start Safari or open the MacBook Pro lid and Safari was already open, a new window opens with the popup: "To view this page, you must log in to area “Thomson” on vodafonemobile.wifi:80."

     

    I removed all the extra wifi networks I don't know or use anymore, and when I search for "vodafone" in Finder nothing comes up.  I'm fairly sure to use the mifi I had to download some software, but I guess the first time I saw the popup I deleted it.  I'm thinking it's a page Safari has remembered (if I type vodafonemobile.wifi:80 into the address bit it brings up the same popup so am assuming Safari has an instruction somewhere to access this page and keeps trying to access it every time it opens. 

     

    If it is Safari, my homepage if set to google.com, and the vodafone link is not in a bookmark or anything else I can see, how do I get rid of it?

     

    Many thanks,

    Julia

  • Topher Kessler Level 6 Level 6 (9,515 points)

    Go to your Network system preferences and see if there is more than one WiFi connection set up in the list of network services. If so then remove all but the one that is named "Wi-Fi." Additionally, for this connection, click the Advanced button and remove any entries in the "802.1X" tab that are present, uncheck any proxies that are configured, and remove any preferred networks.

     

    If this still does not work, then try creating a new location in the menu at the top of the Network system preferences by selecting the "Edit Locations" option and clicking the plus button to add a new one. Then give it a name like "test."

     

    With this location selected, try configuring your Wi-Fi connection, and then apply the changes to see if the same login page shows up.

  • jul3 Level 1 Level 1 (0 points)

    Thanks so much for your help.  I am not sure I am doing this right, should I be in this window? I can't see WiFi or the 802.1X tab:

     

    I setup a test location and it still came up with the login screen, although please check I've set it up correctly:

    Is there anything else I can try?

Previous 1 2 3 Next