4 Replies Latest reply: May 23, 2013 2:47 AM by fluffytom82
fluffytom82 Level 1 (0 points)

After installing iTunes 11, it started acting weirdly. First it got really slow (and I mean really slow), and then it started closing on itself from time to time, leaving me with the message "iTunes doesn't work anymore. We are trying to find a solution." But not very often.

Since I ran an update last week, I got this same message upon launching the program, I don't have access at all now. It just closes right after opening.


I tried removing and reinstalling iTunes 11, but that wouldn't help. I tried going back to iTunes 10.7, but it says it can't read my library because it was made with a newer version of iTunes. I tried starting iTunes in the "safe mode", but the same problem persists and I can't even open the save mode.

I also checked I have the latest version of Quicktime (I do).

One strange thing: I have a 64-bit operating system, I downloaded iTunes for Windows 64-bit, and it was automatically installed in the 64-bit program folder. But when I start iTunes with the Configuration window open, I see that the process it runs says "iTunes 32-bit".


I have over 70 000 tracks and put a lot of time in importing and correcting titles, covers and performers (for classical music the online database is all but complete...), adding information and standardizing the format of the way titles/composers/performers are written. I really don't want to loose that work swapping to another application, and anyway iTunes is - for me - the best way to browse and classify my library.

So... If anyone can help me, please do

Windows 8
  • keeferaf Level 4 (1,075 points)
  • fluffytom82 Level 1 (0 points)



    thanks for your reply.


    Yes, except n°1 - empty Temp directory, I had tried/checked all of those.

    I emptied the local temp folder tonight, but it still won't work.


    Please note: the installation doesn't give me any problem. The program was working fine, until at one point *plouf* it stopped working. I can re-install it without any problem, it just crashes when opening.


    \\edit\\ I seem to have located the problem, it's in the library files. If I re-install iTunes without my library, it works fine (though there is no music in it, yet). As soon as I import my library, or replace the My Music\iTunes folder with the old one, it stops working.

  • fluffytom82 Level 1 (0 points)

    Ok, getting closer to the source of the problem...


    1) starting iTunes with an empty library: OK

    2) starting iTunes with my library imported, but with the external drive containing the actual music deactivated: OK

    3) starting iTunes with my library, and the external drive containing the actual music connected: BUG!


    So iTunes suddenly doesn't recognise the hard drive, or recognises it but crashes trying to read it.


    Looking at the processes, iTunes goes up to using 15% of my CPU before crashing. To compare: Firefox with 4 tabs open, including a streaming video, only takes about 0,4%...

  • fluffytom82 Level 1 (0 points)

    Ok, it seems to be working for the moment.

    While "re-ordering" my library, iTunes has changed a bunch of file names from Greek/Arabic/Russian to incomprehensible chatter. I renamed the files by hand, one by one (took me over three hours), giving them their original name, and iTunes seems to be functionning again.

    I was lucky to be able to locate all of them...


    Subject closed! (for now...)