Previous 1 2 Next 17 Replies Latest reply: Jun 13, 2013 2:32 PM by Jayas
Jayas Level 1 (0 points)

Hi - I wonder If anyone can help - I recently purchased a 500 GB WD Elements portable hard drive. I reformatted it on my brother macbook which has mac os Snow leopard 10.6.8 and it shows and works on there but when I try to use it on my powerbook G4 17" laptop which has mac os x ( leopard ) 10.5.8 it does not mount at all on the desktop and does not even show when I use disk utlity - in addition it keeps making a clicking sound - does anyone know what the problem might be ?.


I went onto the WD websiite knowledge pages but could not find anything to help - closest solution was that there was not enough power in 2.0 usb port but this works when i use my lacie porsche hard drive no problems so I am a little stuck


Also can recommend a good portable hard drive to use with my powerbook - 10.5.8 mac os x - 2.0 USB - 500 GB storage - which is simple to use and works with Time Machine - thanks for any help - Jayas.

PowerBook, Mac OS X (10.5.8)
  • BDAqua Level 10 (122,242 points)

    Hello, bus powered drives are real iffy, I think you need an AC powered USB Hub with a high amp port on it...


  • Jayas Level 1 (0 points)

    Hi BDAqua - thanks a lot for the reply and info on the USB hub. I will check it out - not sure If because I fornatted the drive on my brother's laptop that its not mounting on my laptop - on his laptop it works fine and makes no noise at all but on mine its just keeps making a clicking sound - so I was thinking maybe that its locked ? anyway I will look into your suggestion - and will also have a read up on bus powered drives - thank you so much for your help - thanks Jayas.

  • BDAqua Level 10 (122,242 points)

    Hi Jayas,


    10.4.11 & up should understand any drive formatted on a //////Mac, just maybr not boot from it... I really think it's a USBpower issue at this point, normally it only supplies 500mA to a device.

  • Jayas Level 1 (0 points)

    Hi BDAqua - thanks again for reply - I'll definitely look at the USB hub here in London so fingers crossed that solves the problem - thanks for the advice and help - Jayas.

  • BDAqua Level 10 (122,242 points)

    Good luck!


    Make sure it has at least one high power port.

  • Jayas Level 1 (0 points)

    Hi BDAqua - hope all Ok - I looked into the newertech USB hub and here it works out to around $50 from their distributor but I can buy direct from Newertech and they will ship for $35 so much better deal. I also found these but not sure If they are as good as what you are suggesting - what you think :



    I forgot to mention that I have some old lacie Porsche hard drives bought 2005/6 ( the chunky brick ones ) that I have been using with time machine to back up and recently when I backed up my whole mac to one it took around 5/6 hours to transfer across 76GB and on the other lacie it took about 3 hours just to transfer around 33 MB ! so I'm now starting to think its as you say and its my 2.0 USB port on the powerbook - what do you think?


    My powerbook spec is :


    Model Name:          PowerBook G4 17"

      Model Identifier:          PowerBook5,9

      Processor Name:          PowerPC G4 (1.5)

      Processor Speed:          1.67 GHz

      Number Of CPUs:          1

      L2 Cache (per CPU):          512 KB

      Memory:          1.5 GB

      Bus Speed:          167 MHz

      Boot ROM Version:          4.9.5f3

        Hardware UUID:          00000000-0000-1000-8000-0014512278AC

      Sudden Motion Sensor:

      State:          Enabled


    Really appreciate your help - thanks Jayas

  • BDAqua Level 10 (122,242 points)

    Hi, neither of those has a high power port, which may be needed for USB drives.


    What App were you using to backup with?


    At the Apple Icon at top left>About this Mac, then click on More Info, then click on Hardware>USB, what does it report for speed & mA used?


    U3 Cruzer Micro:


      Capacity:    14.93 GB

      Removable Media:    Yes

      Detachable Drive:    Yes

      BSD Name:    disk6

      Product ID:    0x5406

      Vendor ID:    0x0781  (SanDisk Corporation)

      Version:    2.00

      Serial Number:    07745218FA42EE93

      Speed:    Up to 480 Mb/sec

      Manufacturer:    SanDisk

      Location ID:    0x4b200000

      Current Available (mA):    500

      Current Required (mA):    200

  • Jayas Level 1 (0 points)

    Hi BDAqua - thanks a lot for replying - really appreciate your help. I was using Time machine to back up on the old lacie drives that I have - I just backed up on both lacies and they backed up faster for some reason but that might have been because they were very small back ups as I did full back ups on Tuesday night - this is the info under the USB section > hardware > about my mac - it didn't show the speed like the example you gave me though but it still backed none the less  :


    USB Bus:


      Host Controller Location: Built In USB

      Host Controller Driver: AppleUSBOHCI

      PCI Device ID: 0x0035

      PCI Revision ID: 0x0043

      PCI Vendor ID: 0x1033

      Bus Number: 0x15


    Bluetooth USB Host Controller:


      Product ID: 0x8207

      Vendor ID: 0x05ac  (Apple Inc.)

      Version: 19.65

      Speed: Up to 12 Mb/sec

      Manufacturer: Apple Inc.

      Location ID: 0x15200000

      Current Available (mA): 500

    Current Required (mA): 0


    I also got a reply back from WD on the hard drive and they said the following - exactly the same as you about it being a problem with the power supplied hence why the disk won't mount - so you were spot on - so I'm thinking I should go ahead and get the newertech 7 USB port 4 amps as you suggested - let me know what you think and then I'll just order it - and thank you - really do appreciate your help on this - thanks Jayas



    Dear Jayas
    Thank you for contacting Western Digital Customer Service and Support. My name is James.
    If the drive is working fine on one system but failing on another especially with the "clicking" sound this is an issue with the system not being able to supply enough power to power the device.
    These devices require power from the machine to make them operate if there isn't enough power supplied the drive will fail to work. This is why you are having no issues with one system but are on another.
  • BDAqua Level 10 (122,242 points)

    Yes, I think that is your best bet, & use the...


    One dedicated 2.1Amp port for charging high powered USB chargeable devices.


    For the Drive, that's 4 times the power of the built-in ports.

  • Jayas Level 1 (0 points)

    Hi BDAqua - thanks for the email and reply. I have ordered the Hub direct from the link you gave me. I'll do as you say and will use the dedicated 2.1 amp port for my hard drive - THANK YOU so much for all your help on solving this - I really appreciate it - have a good weekend - thanks Jayas

  • BDAqua Level 10 (122,242 points)

    Great news, thanks, & I sure hope we're on the right track, do ost back with the outcome.

  • Jayas Level 1 (0 points)

    Hi BDAqua - I'll let you know as soon as I get the USB hub - should be with me in 14 days max. Thanks again for all your help on this - really much appreciated - Jayas.

  • Jayas Level 1 (0 points)

    Hi BDAqua - hope all Ok - the USB hub is working perfect - picked it up yesterday as it was delayed in customs - tried it out last night and now my hard drive is mounting and also backing up - strangely enough it doesn't work on the 2.1 amp USB hub but on the sync hub - so THANK you for helping me sort this out - did a back up the new WD hard drive and it worked seamlessly - thanks again Jayas

  • BDAqua Level 10 (122,242 points)

    Well, great to hear anyway, thanks for the report!

Previous 1 2 Next