14 Replies Latest reply: Aug 9, 2014 11:50 AM by King George!
zoody123 Level 1 (0 points)



I need help with the Remote App for iTunes and ipad. Up until a couple of days ago, I connected just fine, I think with the old pin system that allowed me to access and control my itunes library through the phone.

I just got the latest patched update for iTunes and now I can no longer connect through my phone. The new iTunes no longer allows the 4 digit pin to be used, so I tried through home sharing, but my phone and ipad still will not connect to my computer's itunes.

I tried rebooting everything, installing the app again, signing in and out etc. and it still will not work.

Can anybody offer a solution to this? Is anybody having the same problem?

I don't understand it could not have just been kept simple as it had done before to be honest!


Any help would be appreciated. Thanks guys.

  • pedro d Community Specialists (2,865 points)

    Hello there, zooy123.


    There is a Knowledge Base article that seems just right for you:


    Remote app for iPhone, iPad, or iPod touch can't connect to iTunes or Apple TV



    Thanks for reaching out to Apple Support Communities.



    Pedro D.

  • zoody123 Level 1 (0 points)



    I have seen and gone through that page multiple times before and has proved of no use in this situation. I have a feeling the latest iTunes update caused it, because since then, I can no longer connect at all.

  • Gonzo1210 Level 1 (0 points)

    Im also having the same issues as zoody as specified .  


    my Remote App will allow me to connect to my macbook pro itunes libary using iTunes (10.0.4) (4)




    but it wont allow me to connect via my iMac which im using iTunes (11.0.2) (26)


    which leads me to believe that its a problem with a new update on iTunes ?


    i have tried all the troubleshooting advise to no avail .   the message i get on my iPhone App is -


    Remote cant connect to your iTunes libary . Check your network settings and try again .


    but i know the issue is nothing to do with my network as i have full signal and as i mentioned previously it allows me to connect to other iTunes libaries . 


    any help would be appreciated

  • uneek777 Level 1 (0 points)

    hi gonzo


    i am experiencing the same problem since a couple of weeks. i was on the phone with apple support hotline for 6 hours today, but they weren't able to help me. i had a date at the apple store genius bar as well, but they couldn't help me either.


    but: the guy at the apple store told me, he had the exact same problem with his private iphone and remote app since about 2 weeks. it worked perfectly fine before. he said to me that the problem might be the remote app.


    we restored the iphone now, and lost another 2 hours (of my precious vacation time). then, for a few seconds i could see the iphone in the left sidebar of itunes, was able to enter the code, but then itunes said the code was wrong. after that the iphone icon disappeared and again everything is as before - simply NOT WORKING.


    and: i tried it with the mac pro, with the macbook pro, with my iphone 5 and the old iphone 3gs. nothing was working.


    we tried so many things during 6 hours, nothing worked. i had to send my system infos to with a little program the supporter sent me, and he will send this to the engineers now. i hope, i will get more info tomorrow regarding this issue. anyway, all these problems are occurring only since itunes version 11. before, everything worked fine, and itunes 11 is just a huge pile of cr@p. no multiple windows, no genius side bar, no cover flow, all the functions are hidden, so you don't find anything. it's really a p.i.t.a.


    i already sent at least 10 feedbacks to apple directly. and so did probably thousands of other users. but they don't react. nothing happens. it's just this crippled itunes version and nothing works anymore.


    any hint what i could try?


    my systems: mac pro, os x 10.7.5; macbook pro, os x 10.7.5; iphone 3 gs, iOS 6.1.3; iphone 5, iOS 6.1.3

    on both computers itunes 11.0.4.


    so, everything is up-to-date. my wifi lan is working perfectly well, everything else is working. only remote app is not working.

  • Gonzo1210 Level 1 (0 points)

    i really wish i could give you some advice ,


    but sadly im still stuck in the same situation as you, and there has been no change on my end either
    with only one itunes/remote sync working and not the other .


    also like you apple havent been able to help me either . 


    im a semi pro Dj/Producer and itunes is a royal pain in the backside. hate everything about there new updates i wont go into what is wrong with it as this is a topic for the Remote APP .



    i wonder if maybe trying to get intouch with the Remote App designers and tell them about the problem, hopefully someone on there end may be able to shed some light or work on an update that allways the sync with itunes 11.clusterf**k.2 


    untill then i have no faith that apple will sort this mess.....lets face it there customer support network is lame and there geniuses are far from that .   ive been with apple for 10years or so and every problem ive faced its been other memebrs whom have solved the problems, and never once has an apple member helped . 

  • uneek777 Level 1 (0 points)

    thanks, i have posted the issue also on other platforms, it seems, we are not alone with it.


    and, yes, i usually solve problems within the communities, not with apple support members...


    BUT THERE IS MAYBE A SOLUTION: patience! i started the remote app, and enabled home sharing and nothing happened. i did something else in the meantime, and after 20 minutes suddenly the media library appeared on the remote app - magic!!??


    so - maybe this will help you, too? just wait long enough, maybe it's because our libraries are too big and this is why it takes ages to load over the wifi lan? i'm a hobby dj too, and i have 250 GB of songs.


    pls let me know if the patience helped you...


    good luck!

  • Gonzo1210 Level 1 (0 points)

    so today its decided to work .   no hassle . no lag . no waiting time .  just straight connected to both imac and macbook pro iTunes with no problems .   didnt try anything new or different from previous attempts either

  • uneek777 Level 1 (0 points)

    really weird... i don't understand this...

    maybe it was too hot for the computers yesterday...?

  • thomashu Level 1 (0 points)


    I have the same problem. I know this article, but let me point out, the article is wrong!   Sorry

    In itunes there no Look for iPod touch, iPhone and iPad Remotes in the devices tab under the menu point preferences.

    For me, it looks like bonjour protocol problems. This is in my eyes consumer only protocol, and the root case for many connection problems.

    I often have connection problems from iPad and iphone to itunes (windows) and apple TV. Under best circumstances switching wifi off/on helps, but sometimes it simply won’t work. Yes of course it is a flat network no routers or vlans in my way at home.

    As nice as apple products are standalone, if you try to connect them, the nightmare starts. With Itunes sync especially wifi sync, the pain starts.

    I wonder why the xbox smartglass remote works seamless as it should and remote control a Xbox 360 is fun. That is what I expected. Also other apps like PoketCloud, VMWare View, Citrix receiver, all have now problem to find their counterpart, even though VPN connection.

    Oh, I forgot, they use normal network protocols instead of bonjour. It requires having working name resolution and some configuration work, but it is reliable.

    I hope that apple will fix the network mess, but I doubt. it will not happen.



  • thomashu Level 1 (0 points)

    Ok, I found the cause. I use a range extender in my home. So, this stupid multicast mDns that bonjour uses, is not able to work with this boundary.

    So can Apple have a recommendation on this? For me it is not exactable how apple is limiting the functionality. Design is not everything, it also should work!

    I know some ways to solve this, but the solutions cost serious amount of money.

    For sure a cisco wireless LAN controller and cisco aironet access points and some configuration can help.


    But I think the best way to avoid this mess is not buying Apple products again and selling all Apple hardware.

  • QuintoYYC Level 1 (0 points)

    I tried everything, but rebooting my routed fixed the issue.

  • SBlue Level 1 (10 points)

    helped me too! thanx!

  • King George! Level 1 (0 points)

    thomashu wrote:


    I often have connection problems from iPad and iphone to itunes (windows) and apple TV. Under best circumstances switching wifi off/on helps, but sometimes it simply won’t work. Yes of course it is a flat network no routers or vlans in my way at home.



    Same here. But rebooting my router is rather annoying, because I mostly start the music from my pc and later in the day want to connect to iTunes using my iPad (remote app). So, only way to get a connection is to walk to my router or pc and reboot the router. But there is no point in that, because since I am at my pc at that moment I simply can control iTunes directly from there. But, maybe I should be grateful: thank you Apple for contributing to my fitness /health by making me get up or walk more.

  • King George! Level 1 (0 points)

    Firewall, it's your firewall, guys! I'm running Panda Cloud Antivirus Pro and had the firewall of  the trial pro version switched on. After a lot of trial and erroring I turned it off and poof!..... there was my iTunes library in the remote app again! I've kept it disabled and I am now running the Windows (7) firewall with no complaints.