7 Replies Latest reply: Aug 13, 2014 9:12 PM by dotmap235
TPFleck Level 1 (0 points)

What am I running?


Well based on the forum I'm posting in, I'm running the follow:


Mac OS X v10.6.8 Snow Leapord

2 GHz Intel Core i7

8 GB 1333 MHz DDR3


Boot Camp w/ Windows 7 Ultimate

It should be noted though that I am using OS X when I wrote this message and I'm talking about my CMD key not working in OS X.



What is Happening?

Oddly enough, it seems my cmd key and option key are remapped permanently?


Steps I've taken:


  • System Pref > Keyboard > Modifier Keys > Default (I also made sure the cmd key was set to command and option as option)


  • System Pref > Keyboard > Change Keyboard Type... (still no luck)


  • Reset PRAM


  • Safe Mode Boot (my cmd keys worked properly in Safe Mode, but when I restart into normal it doesn't work)


  • Created a new user (no luck still)


  • Went through the Apple Support forums and deleted some .plist files that people said helped and fixed their problem.




I feel like I'm one step short to throwing this thing through a window. Seeing as I'm a web developer, I feel that my cmd key is almost essential as it is my quickest way to copy and paste current and previous lines, save, and anything else you might think of. Oh did I mention cmd + f to search files? Oh yeah, big help for us developers.


Anything else anyone can think of? Please I'm all ears, I feel I am technically SAVY with my MBP, but obviously I'm not.

MacBook Pro, Mac OS X (10.6.8)
  • christopher rigby1 Level 4 (2,122 points)

    Purely a guess, but as you're also running Windows via BootCamp, is this article any help?



  • ds store Level 7 (30,325 points)

    Perplexing problem, it seems to be a OS X software issue as it's occurs in another user but not in Safe Mode or at boot time (like Command V or S) on a wired/built in keyboard.


    Was some sort of third party keyboard software installed? Have you tried a wired keyboard or another one?


    It sounds like OS X has gotten the keyboard map wrong somehow, like that check that occurs when one connects a new keyboard?



    The #12/#13 OnyX cache cleaning and corrupt preference file check might cure/find the problem


    ..Step by Step to fix your Mac



    Perhaps the #8 Reinstall Just OS X over itself to give you a new fresh copy



    I've arranged the Steps in order as to be systemmatic until you find something that works

  • TPFleck Level 1 (0 points)

    Christopher, I haven't changed any type of configurations and I do use a Logitech G110 Keyboard, but the thing is I haven't changed anything.


    DS Store, I use an external keyboard yes, and I am having the same issue. I'd really like to not have to reinstall OSX, I don't want to lose all the applications and sorts. If I unplug my keyboard it has the same issue, even if I restart it after unplugging it. Again, the keyboard has never really been the issue so I am a little confused myself as to what could of caused it. I did the Onyx clean and still having the problem.


    Help from anyone else would be appreciated also.

  • LittleDuckAlex Level 1 (0 points)

    I was having the same problem with my G11. Spent ages looking around for a fix, couldn't find anything. I have now fixed it and feel a bit dumb. The gaming switch was enabled on my keyboard which disables those keys. Not sure if this is your problem too but I thought I might mention it seeing as your keyboard also features the gaming switch.

  • chrisjbrough Level 1 (0 points)

    This was exactly my problem.  Switched gaming mode off and fixed it!  I'm on the Logitech G15 keyboard.  Thank you for your help!!!!

  • Alex Chaffee Level 1 (0 points)

    That was it! The little joystick icon at the top is next to the "gaming mode" switch on my Logitech G110 keyboard. Thanks.

  • dotmap235 Level 1 (0 points)

    It may be a bit late, but I had a similar issue with two users on our home iMac and a Kensington pilotboard.  After inspecting my account settings which let me use Command and Option, I discovered the Kensington keyboard worked because two modifier keys were swapped (Option <--> Command, and Command <--> Option).  Once I did this modifier key swap for the other users, they were able to use Command and Option keys properly.  It should have been more apparent with these users beforehand when I had tried to logout with Cmd+Shift+Q and got the symbol Œ in an open terminal (this meant that Command mapped as Command, was really acting as Option - 'Opt+Shift+Q = Œ').  Seeing as this Kensington keyboard has Win/Alt mapped for Opt/Cmd, it may be a similar issue with other usb keyboards built for Windows computers.