1 2 Previous Next 16 Replies Latest reply: Jan 13, 2014 6:03 PM by somenothing
James Jackson5 Level 1 Level 1 (5 points)

I was trying to partition my new iMac hard drive to have a seperate partition to run some of my programs on Snow Leopard. Although, I was told I would be able to do this by a Mac Genius at the Apple Store, I have found out this can not be done. Which is fine, I am willing to live with that. The problem now is that I am unable to erase the partition I created.

 

When I go to Disk Utilily and click on Partition I have two partitions both called Macintosh HD (not sure why because I called one Snow Leopard). One is 2.2 TB and the other is 801.44 GB. That  801.44 GB is no longer available on my drive.  Each partition I click on has grayed out options.

Partitions.jpg

I have tried erasing the hard drive from Disk Utilities and then restoring from Time Machine, but it didn't help. I still have the unusable 801.44GB partition.

 

Thank you in advance.


iMac, OS X Mountain Lion (10.8.3), 3.2 GHz Intel Core i5, 16 GB RAM
  • 1. Re: I can't remove a partition on my new iMac
    Kappy Level 10 Level 10 (226,730 points)

    In order to post an image click on the Camera icon in the toolbar of the message editor. When the dialog appears select the image you wish to post, then click on the Insert button.

     

    The image you tried to post is not visible. I'm not sure what the condition of the drive is as of now. Am I to assume the smaller partition is the one you want to get rid of? In order to do this you must first boot the computer from the Recovery HD:

     

    Boot to the Recovery HD:


     

    Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alternatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.


  • 2. Re: I can't remove a partition on my new iMac
    James Jackson5 Level 1 Level 1 (5 points)

    Hey Kappy,

     

    That is how I attached the image. Sorry it didn't appear. But you are correct, I want to remove the smaller partition.

     

     

    I have already done what you have suggested, but when I use the Disk Utilitly from the Recovery HD the options (including the "-" are stilled grayed out).  I also erased the drive from Disk Utility in the Recovery HD before I restored it from Time Machine.

  • 3. Re: I can't remove a partition on my new iMac
    Kappy Level 10 Level 10 (226,730 points)

    After you open Disk Utility:

     

    Select the drive's main entry (mfgr.'s ID and size) from the sidebar list. Click on the Partition tab in DU's main window. Then click in the rectangle of the smaller partition:

     

    Screen Shot 2013-05-27 at 5.35.13 PM.png

     

    Both the Add [+] button and Delete [-] button buttons should be active. The Delete [-] button is not active in my image because that partition happens to be my boot partition.

     

    You should be able to delete the partition.

  • 4. Re: I can't remove a partition on my new iMac
    James Jackson5 Level 1 Level 1 (5 points)

    Looks like I might have a bigger problem.

     

    I have tried that but The Delete [-] option is still grayed out and I can't click it. I wish you could see my image-I will try posting again. What I saw in your image that was not in mine was that  under the main Disk which is called "Macintosh HD", I only have one listing called "Macintosh HD". Is it possible that my computer has a partition but it doesn't think it does??

     

    SmallerPartition.jpg

  • 5. Re: I can't remove a partition on my new iMac
    LowLuster Level 6 Level 6 (11,905 points)

    You have one of the new fusion drive imacs, right. Well I have never worked on one but making a partition might of broken the fusion drive setup and there might not be a way to combine them back together.

     

    I suggest you pack the system up and take it to a apple store and let them figure it out.

  • 6. Re: I can't remove a partition on my new iMac
    Kappy Level 10 Level 10 (226,730 points)

    I would concur with LowLuster. You've done something to screw up the Fusion Drive configuration. Take it to an Apple retailer and let them sort it out for you.

  • 7. Re: I can't remove a partition on my new iMac
    LowLuster Level 6 Level 6 (11,905 points)

    The reason you have 2 drives named the same is because the top entry is the combination of both a ssd and a standard rotating drive in a logical storage volume. You need to go to apple.

  • 8. Re: I can't remove a partition on my new iMac
    Kappy Level 10 Level 10 (226,730 points)

    See Mac mini (Late 2012) and iMac (Late 2012)- About Fusion Drive. I would also suggest a Google search for how to create a new partition and how to remove one from a Fusion Drive.

  • 9. Re: I can't remove a partition on my new iMac
    James Jackson5 Level 1 Level 1 (5 points)

    Hey LowLuster,

     

    Thanks for your reply. I wasn't suppose to get the fusion drive (it was delivered last Friday).  I did upgrade to the 3TB drive but it shouldn't be the fusion drive. It should be the 3TB Serial ATA Drive @ 7200 rpm drive which was only $150 more, not the $250 more for the 3TB Fusion Drive.

     

    Can you help me out? Where do I find out what kind of Hard Drive I have? I can't find it in "About this Mac"

     

    Thanks


  • 10. Re: I can't remove a partition on my new iMac
    Kappy Level 10 Level 10 (226,730 points)

    Open System Profiler in the Utilities folder. Select Serial ATA which will provide information on the HDD and SSD as separate entries on the right.

  • 11. Re: I can't remove a partition on my new iMac
    LowLuster Level 6 Level 6 (11,905 points)

    Well in one way consider yourself lucky, you got the fusion drive for the regular price. Now you have to go back to a apple store to get it straightened out.

     

    There is a way for you to fix it. Do a google search on breaking up and making a fusion drive. There are several articles on it. The bad part is, even if apple does it, all your data will be wiped from the drives.

     

    You must have a fusion drive or apple installed 2 1.5TB drives and then combined them into a logical storage volume to make it look like one 3TB drive. But I don't think there is enough room in the new imacs for 2 standard size HDD and there are no notebook size drives over 1TB.

     

    I didn't even know apple offered a 3TB drive without fusion. I just checked and they do offer a 3TB standard drive. And the 3TB fusion is a extra $400, $250 over the upgrade you ordered.

     

    I really don't understand how you could have a logical storage volume without the fusion option.

     

    Go to about this mac then more info then system report. Look under serial ata. That should list all the drives in your system.

  • 12. Re: I can't remove a partition on my new iMac
    James Jackson5 Level 1 Level 1 (5 points)

    Ok, Thanks.

     

    But I need some help translating...

     

    Is "APPLE HDD ST3000DM001"  a Fusion Drive???


  • 13. Re: I can't remove a partition on my new iMac
    Kappy Level 10 Level 10 (226,730 points)

    That is a Seagate 3 GB HDD.

  • 14. Re: I can't remove a partition on my new iMac
    LowLuster Level 6 Level 6 (11,905 points)

    Is that the only listing? That is a apple branded Seagate hard drive. So it is not a fusion drive. I have no idea why it was setup as a logical storge volume.

1 2 Previous Next