1 Reply Latest reply: May 30, 2013 12:32 PM by sterling r
Elphie7 Level 1 Level 1

I am having a very difficult time connecting my macbook air to my work's wireless Ricoh Afficio 3035 printer. At first it simply wouldn't show up in the System Preferences under the add a printer option, so I tried to change the sharing preferences. No luck.


Then I decided to try and connect with the printer over IP address. I entered the printer's IP with no problem. The printer showed up in the system preferences, and I thought it would work. Unfortunately it didn't; when I tried to print I got about fifteen blank sheets and some strange writing - not code, but strings of numbers.


I really just want to connect to the printer, any help would be absolutely appreciated, but my real question is, is there any way to install drivers for this printer, and if so, how will that then help me connect to the printer?


Also, if anyone else has any advice on how to simply connect to the printer I would be eternally grateful. Thank you!

MacBook Air, OS X Mountain Lion (10.8.2)
  • sterling r Community Specialists Community Specialists

    Hello there Elphie7,


    I have an article here about troubleshooting printer issues named Troubleshooting printer issues in OS X found here http://support.apple.com/kb/ts3147 that should help you out here.


    USB printers and Bonjour-enabled network printers

    Follow these steps until the issue is addressed:

    1. Make sure that the printer is powered on, has ink / toner, and that there are no alerts on the printer’s control panel. Note: If you cannot clear an alert on the printer's control panel, stop here and check the printer's documentation or contact the manufacturer for support.
    2. Ensure the printer is properly connected to a USB port on the Mac or AirPort base station / Time Capsule. If the printer is a network-capable printer, make sure that it is properly connected to your home network.
    3. Use Software Update to find and install the latest available updates. If an update is installed, see if the issue persists.
    4. Open the Print & Scan pane or Print & Fax (Snow Leopard) pane in System Preferences.
    5. Delete the affected printer, then add the printer again.

    If the issue persists, try these additional steps:

    1. Reset the printing system, then add the printer again.
    2. If the issue still persists, reset the printing system again.  Download and install your printer's drivers. Then, add the printer again.
    3. Contact the printer vendor or visit their website for further assistance.


    All the very best,