12 Replies Latest reply: Sep 3, 2013 9:59 AM by Jaccov
_Explicit Level 1 Level 1

Hi guys,


Having a strange issue with my ATV 3 Airplay function.


I have the following devices:

-Apple TV 3 (Model MD199LL/A, iOS version 5.2.1)

-Apple iPhone 4S (iOS version 6.1.3)

-Macbook Air 11inch (OS X 10.8.3)


The problem is as follows. When my Apple TV has been asleep or not used for a period of time, my iPhone is unable to access it using the Remote App, and is not able to Airplay to it. I can use the normal IR remote to wake the ATV up, but still, im unable to access it using the Remote App, and I am unable to Airplay to it. I am forced to restart the ATV, and also disjoin then rejoin the Wifi on my iPhone to get the connection back.


Now, if i wake up the ATV using the IR remote, and open my Mac, straight away i can Airplay to the device, so the device and network are capable of Airplay from my Mac without the need to reboot the ATV.


I have tried:

-New ATV 3 (mine was recently replaced due to a faulty Wifi chip)

-Restore ATV back to default

-Restore iPhone back to Default

-Reboot router

-Reset router back to factory default

-Tried a different router

-Reinstall Remote App


I'm unsure if the problem lies with the phone or ATV. Considering my MacBook Air has no problem finding the ATV and Airplaying to it makes me think the issue is with my iPhone.


I have also read and tried all steps in the following support articles:




Anyone have any suggestions?

Apple TV (3rd generation)
  • _Explicit Level 1 Level 1

    Bumping this back to the top, the problem persists. I have seen a few other posts in here relating to this issue, so I don't seem to be alone!


    The warranty for my iPhone runs out this month, so I would like to explore all avenues of troubleshooting to try and resolve the issue. Otherwise I may have to take my phone in to see if someone at the Apple Store can diagnose the issue (i'd like to have concrete evidence that its the phone at fault).

  • dhodeltoro Level 1 Level 1

    I'm also having this issue and its super frustrating.  I need to re-connect the wifi every time I want to use AIrplay.  Someone from Apple, please help!!


    I also am using iPhone 4S w/ latest os.

  • cveen Level 1 Level 1

    Same issue here.  Apple Powerbook Pro and Iphone 4s. All with latest software.  One the Apple TV goes to sleep and I use the remote to wake I need to shut off wifi and them turn on wifi for either device to find the AppleTV as a airplay device.

  • _Explicit Level 1 Level 1

    Bumping back to the top, we have multiple people with this issue, I have seen numerous threads reporting the same symptoms. Does anyone have a permanent fix? I've updated my ATV iOS to the latest version just now, i'll report back any findings.

  • Jaccov Level 1 Level 1

    Same issue here for a few months and with the latest firmware and software updates on all equipment. Re-booting the router works, but only for a day.

  • _Explicit Level 1 Level 1

    I'm still experiencing the issue even after the latest iOS update. I've basicall given up on trying to use AirPlay as it require a daily reboot of my ATV.


    Anyone having any luck on getting this working? Seems like i'm not the only one..

  • Jaccov Level 1 Level 1

    I'm still rebooting my router every day before I use my ATV

  • bluebowtie Level 1 Level 1

    My Atv3 has been having serious connection issues too. They randomly began a few weeks ago. No settings of any kind have been made to bring this about. I'm using an AirPort Extreme router and iPhone 5, though other iPhone 4's and 5's have the same problem. My retina MacBook pro connects eventually but had some snags with the sound at first. All these devices worked very well weeks ago but now only pictures from my photos seem to display. All video taken my the phone seems to play eventually, but an 11 second video had to buffer for about 30 seconds, then played half before buffering again. ? Video from YouTube, etc., does not work at all now. I'm crossing my fingers for an update soon but haven't seen anything yet. Come on Apple, you're making AirPlay seem stupid. That's iHome's job..

  • MrMatt Level 1 Level 1

    I have the same issue too. This means that when I want to use the great iPhone remote app I need to first find the little ATV remote to reset the thing and then I can use the better device. Any fix out there? This was not an issue when I had ATV2.

  • BrandonsApple Level 1 Level 1

    Same issues here. After inactivity I can't AirPlay or use remote app. I have to force restart ATV and sometime reconnect to wifi. Hope a fix comes soon and I will be selling my AppleTVs.

  • scottr3 Level 1 Level 1

    I have similar hardware:


    Apple TV 3

    iPhone 4S

    WiFi via apple extreme router


    After waking the ATV from sleep I could not access iTunes content or use airplay. To reconnect the ATV to the network I'd have to unplug it. Plugging it in again solved the problem temporarily.


    In my frustration I called Apple tech support. He had me do a restore and that finally solved the problem permanently.


    Restore is found in the menu General > Reset > Restore


    Hope that helps.



  • Jaccov Level 1 Level 1

    Thanks Scott. Restore does seem to work, I've had no problems accessing my ATV for 2 days now!! Fingers crossed...