1 Reply Latest reply: Jun 1, 2013 3:19 PM by sheila_m.
Genovix Level 1 Level 1 (0 points)

I'm used apple software update to update to the latest drivers which is version 1.4

I'm running mac OS X10.7.5 lion, i've also tried setting up the printer using the IPP protocol

with zero success, and when i used LPD that's when it prints the garbled prints.

any help will be appreciated..


MacBook Pro, Mac OS X (10.7.5)
  • 1.
    sheila_m. Community Specialists Community Specialists (3,245 points)

    Hello Genovix,

     

    I found an article with steps to troubleshoot issues with setting up a printer on your MacBook Pro:

     

    Follow these steps until the issue is addressed:

    1. Make sure that the printer is powered on, has ink / toner, and that there are no alerts on the printer’s control panel. Note: If you cannot clear an alert on the printer's control panel, stop here and check the printer's documentation or contact the manufacturer for support.
    2. Ensure the printer is properly connected to a USB port on the Mac or AirPort base station / Time Capsule. If the printer is a network-capable printer, make sure that it is properly connected to your home network.
    3. Use Software Update to find and install the latest available updates. If an update is installed, see if the issue persists.
    4. Open the Print & Scan pane or Print & Fax (Snow Leopard) pane in System Preferences.
    5. Delete the affected printer, then add the printer again.

    If the issue persists, try these additional steps:

    1. Reset the printing system, then add the printer again.
    2. If the issue still persists, reset the printing system again.  Download and install your printer's drivers. Then, add the printer again.
    3. Contact the printer vendor or visit their website for further assistance.

     

    You can find the full article here:

    Troubleshooting printer issues in OS X

    http://support.apple.com/kb/ts3147

     

    Thank you for posting in the Apple Support Communities.

     

    Best,

    Sheila M.