Previous 1 2 Next 16 Replies Latest reply: Oct 30, 2014 7:02 PM by travisdbq
MidnightXMonster Level 1 Level 1 (0 points)

I recently moved into an apartment, and we got our internet installed this month. My iPhone will not connect to our wifi. Whenever I enter the password, it just says: "incorrect password" even though I have entered it correctly over and over again.

 

I have done multiple things to see if I could fix this problem:

I have entered the Gateway address into the URL on my browser and then gone into the router settings and changed the WEP to OPEN.

I made sure my iPhone was up to date.

I cleared all cookies and history in Safari.

I made sure my cellular data was turned off.

I turned airplane mode on and off.

I tried entering all the codes on my modem into the password bar.

 

I don't know what to do now. It still says incorrect password. It doesn't even seem to TRY to see if it's a correct password, it just seems to know immediently and without even waiting a second, the error pops up. What do I do?

-Noelle

 

As an additional side note: There are 3 laptops in use, all of which can connect to the wifi as well as some game consoles.


iPhone 4S, iOS 6.1.3
  • Ralph Landry1 Level 8 Level 8 (37,950 points)

    Noelle, go to Settings > General > Reset > Reset Network Settings.  That will delete the network information.  Check to see if the password for the network, may be shown as WEP or WPA key, is printed on the router's label, if you have not changed that, then go to Settings WiFi and choose your network and re-enter the password.

     

    If that doesn't help, some have found it necessary to turn Airplane mode and Do Not Disturb mode ON, power down the iPhone and wait about 5 minutes before powering up again, turn Airplane and Do Not Disturb OFF and see if it will now connect.

     

    Others have also found it necessary to make a backup of the content, the Erase All Content and Settings, then restore from the backup.

  • MidnightXMonster Level 1 Level 1 (0 points)

    Hi Ralph, thanks for taking the time to answer my question.

    I forgot to mention that the person that set up everything didn't give us a key. We set up a password while he was still here and our router does not display a WEP or WPA key. So we've been using the password we set up the internet with.

    Is there a way to find the key after logging in on your browser?

     

    I just tried the turning on both airplane mode and do not disturb then powering down. I'm currently waiting a little before I turn the phone on again.

     

    If nothing else works I will have to back up my phone then reset everything to factory presets. Which I need wifi to do so I have to go somewhere else.

  • Ralph Landry1 Level 8 Level 8 (37,950 points)

    Ok, we may be mixing things here: make sure I understand what you have setup.

     

    There should be two passwords for internet access.  The first is for accessing the wireless network created by the router, the WEP or WPA key.  The second is the password for your internet service provider for your email and account they are providing.

     

    What I am trying to understand is, when the router was installed, and you setup a password, was that password for the router/wireless network?  That is the password your iPhone has to give the router to access the internet via WiFi.

     

    If your service technician did not give you that information, look on the label stuck on the router, maybe on the bottom, or back side, and see what the name of the network is that it is creating.  There is usually on that same label WEP o WPA key...that is the password to access the network it is creating.

     

    I am not trying to be simplistic about this, but trying to make sure we are not talking past each other.

  • MidnightXMonster Level 1 Level 1 (0 points)

    Right, I have two labels on my router. But non of them have a WEP or WPA key. There's something called a Pre-Shared PIN which I tried entering into my phone once and it didn't work. And there are a lot of other numbers too. But nothing that says WEP or WPA key. It was originally a WPA2-PSK before we changed it to OPEN.

  • Ralph Landry1 Level 8 Level 8 (37,950 points)

    If you changed it to OPEN, then you should have taken off password protection and security.  Try attaching to the network without using anything in the password field for the WiFi, click OK or just give it an ENTER however it comes up.

  • MidnightXMonster Level 1 Level 1 (0 points)

    If I try to connect without a password, it still comes up as: incorrect password

  • Ralph Landry1 Level 8 Level 8 (37,950 points)

    Noelle, since you were able to login to the router and change the setting to OPEN, I assume you have a computer with ethernet connection to the router.  Does that computer connect to the router by wireless?  Or is it only wired?

     

    Do you have anyother devices connecting to the WiFi network?

     

    If the iPhone is the only wireless device, then we cannot say what is going on and if it is only the iPhone that is having problems.  So, assuming the iPhone is the sole wireless device, when you login to the router by your computer, as the admin user of the router, do you have the ability to change the name of the wireless network being created?  Can you set the security to WEP and give it a password?  One hopes you have to type that password twice to prevent mistakes

     

    If that is possible, change to WEP encryption, create an easy to remember password, make sure you have it exactly as typed, that is caps if used, and then try again with the iPhone.

     

    Remote troubleshooting of network issues is not easy so thanks for your patience and willingness to try things.

  • MidnightXMonster Level 1 Level 1 (0 points)

    All our laptops can connect to wifi. I typed in my gateway address and logged into the router on my browser and coukdn't find any options that allow me to change the security key

    I assure you I've typed in the correct password we chose numerous times, caps and all and it doesnt work

  • Ralph Landry1 Level 8 Level 8 (37,950 points)

    With all you have tried, the computers connecting ok, sure sounds like there is a problem with the iPhone.  Have you been able to connect to other WiFi networks with the iPhone?  Is this the only network it will not connect with?  If this is a general problem, sounds like it is time to take the iPhone to an Apple store genius bar and have the techs run their diagnostics to see what the problem is with the iPhone.  There just isn't much left to try with it.

  • MidnightXMonster Level 1 Level 1 (0 points)

    Thank you, I will probably be running to an apple store here soon. My phone can connect to the wifi at a couple other houses and the college i go to. But for some reason it just doesn't want to connect to this one.

  • Ralph Landry1 Level 8 Level 8 (37,950 points)

    And that gets to be really, really frustrating.  If there isn't an inherent problem with the iPhone then troubleshooting the mismatch with that router can be a real pain, as you have seen.  See what the geniuses can find, if anything and if you have time, post back with the results...I would be interested in how this can be resolved.

  • bpringle1a Level 1 Level 1 (0 points)

    I had the same problem: my iPhone recognised my home wifi as available, but would not accept the password ("incorrect password" message). I use Airport Express as my router, and had tried resetting that.

     

    I downloaded Airport utility through my mobile data, and opened it. When the orange light beside the word 'Internet' turned green, I tried again to enter my password for my home wifi, and it connected the iPhone to the network. It now reconnects automatically when I switch on wifi on the iPhone.

     

    Don't know why this works, but try it if you have Airport or Airport Express.

  • jnsmth Level 1 Level 1 (0 points)

    i am having the same problem with my iphone4s. it is also up to date.

    my password keeps saying incorrect.

    however, i am able to connect, wirelessly, to both my macbook pro and my imac.

    JUST NOT MY PHONE! sorry, very frustrated. :}

    my network is recognized, and i can type in the password, just getting an "incorrect" error.

    i've reset the network, i've turned wifi on and off.

    it seems this is a pretty consistent problem by just browsing this forum...

    and other forums as well.

    apple! what's the problem?

    eta; i recently replaced my modem (from time warner) because of the same problem.

    did a hard reset on that router... no phone connect, but other wireless devices are connected.

    purchased a new router... but having the same issue.

    OP: did a trip to the store fix the issue for you?

  • A14151 Level 1 Level 1 (0 points)

    I have the same problem on my iphone 4S (started yesterday). IOS 6.1.3 (10B329) AT&T.

     

    This is a new phone (bought mid-Oct 2013) and everything was working fine until yesterday Nov 26 2013. There has not been any changes to the software that could have caused this.

     

    First my bluetooth stopped working - it lost all connections and when the bluetooth is turned on, it just keeps "searching" forever without finding anything. I tried the soft boot, hard boot and also reset networks, but this ahs not resolved the problem.

     

    My wifi was working fine, but after I reset the network to fix the bluetooth issue, I find that now my wifi will not accept passwords - it keeps coming up with "Incorrect password" ...does not work even if I change passwords to the simplest form. I have tried this different routers and passwords, and while all my other computers and devices can connect with the passwords, my iphone 4s now will simply not accept any password for wifi. I tried network reset a few times now.

     

    Please advise - how can I fix this problem - both with my wifi and my bluetooth

Previous 1 2 Next