2 Replies Latest reply: Nov 24, 2014 11:13 AM by Texas_Man_Luvs_His_mac
thinkingthought Level 1 Level 1

I have a 2nd-generation Apple TV in my living room, and it's currently connected to my router via an Ethernet cable. I need to move it into my bedroom, and for that it can only hookup with Wi-Fi.


I hookup the AppleTV to my bedroom TV, and try to connect it to my Wi-Fi network, and nothing happens. No Ethernet cable is plugged into the AppleTV, only an HDMI and power cable.


I'll go into Settings>General>Network, and WiFi is never available. The only two options are 'Ethernet' and 'Test Network'. It acts like it has retained the previous IP address from when it was plugged in.


I've tried reseting the device, restarting it, and all sorts of other things. I could have sworn this thing used to connect by Wi-Fi all the time before I had an Ethernet cable hooked up to it.


What am I doing wrong? This thing does have a Wi-Fi card in it, right? Why aren't there any options for getting this thing on a wireless network?

  • braden85 Community Specialists Community Specialists

    Hi Ed!


    I have two articles that can help you troubleshoot this issue further. They both deal with troubleshooting the Wi-Fi connections on your Apple TV, and can be found right here:


    Apple TV (2nd and 3rd generation): Troubleshooting Wi-Fi networks and connections



    That article is the one that I feel will be most relevant for your issue, but there is another article that has some different information in it that may reference something specific that you are seeing. The other article can be found right here:


    Apple TV: Troubleshooting wireless connections



    Thanks for coming to the Apple Support Communities!




  • Texas_Man_Luvs_His_mac Level 1 Level 1

    I am having the same issue. I have done the following:

    1. Restart the Apple TV (Settings > General > Restart).
    2. Restart the Apple TV by removing ALL the cables for 30 seconds.
    3. Restart your router. (Also try removing it’s power cord for at least 30 seconds)
    4. Reset the Apple TV (Settings > General > Reset > Reset all settings)


    I tried doing the restore option, but it gives an error message indicating it cannot download the content to restore the device.

    I am not sure why the network settings is defaulting  to ethernet only. I cannot seem to obtain a Wi-Fi option. I have reset all routers and every device including unplugging power and waiting 


    All computers, iPads, and iPhones are working flawlessly.

    the first screen to appear states home sharing, it has two options below I can select. One is computers and the other is settings. I never make it to any sort of basic home screen.

    I am not able to connect or activate home sharing since there is no Internet connection. When I choose settings, go to Gen. and then network, the only option is ethernet below ethernet it says testing network below that it has an IP address of


    On the same screen it says router not applicable DNS not applicable. it does have an ethernet address


    I have connected and ethernet cable hoping that would work, but that made no difference whatsoever.


    I'm lost. Help?