Previous 1 2 Next 20 Replies Latest reply: Apr 3, 2014 10:48 AM by andrius3000
sarahfelldown Level 1 Level 1

i'm trying to redeem a code (or access my itunes account at all) and itunes won't accept my password. it IS entered correctly. when i enter it incorrectly, the red text informs me that i entered my id or password incorrectly, but in my current situation, no error message is shown. it just pops up the login box again and again.

 

my id and password are working on my phone and ipad, and here on the forums (as i was able to log in to post this message).

 

has anyone else had this problem? i recently updated to the latest version of itunes, maybe it's related?

 

if anyone else has had this problem and was able to fix it, i'd love to hear how you did it.


iMac, OS X Mountain Lion (10.8.2)
  • joe1953uk Level 1 Level 1

    I have a similar problem in that even though I am logged into the itunes store it repeatedly asks for my password. The only way round it I have found is to quit itunes and open it again - it then stops asking.

  • Ruvinio Level 1 Level 1

    Had the same problem here. Your tip with closing and opening iTunes again worked fine.

     

    But when the re-opened iTunes asked for the password, i saw a checkbox "remember password" in the login-window, that wasn't there before.

    anyone else witnessed this?

  • sabatica Level 2 Level 2

    You probably have a keychain issue.

     

    Quit iTunes

     

    Simply launch the app called Keychain access from spotlight

    its in your /Applications/Utilities

     

    Under your login keychain you have your iTunes Store Password saved. DELETE IT

     

    Reopen iTunes renter your itunes store password when you attempt to connect to the itunes store and choose to remember this password in the keychain. Hope this helps. 

  • stepj Level 1 Level 1

    What is this "Keychain" thing?  Do I have it in Windows 7?  If so, how do I get to it?

  • Jimzgoldfinch Level 6 Level 6

    Hi,

    This is iTunes for mac forum. Keychain is a mac feature.

     

    Jim

  • Jimzgoldfinch Level 6 Level 6

    Hi,

    Problem fixed in iTunes 11.0.4 update. Also update OS X to 10.8.4.

     

    Jim

  • stepj Level 1 Level 1

    Apologies Jim,

     

    Not sure how I ended up in the Mac forum as I found this thread via the Windows forum.  I had actually just updated to 11.0.4 when the problem started for me, so maybe there is a separate Windows issue.  I will report to Apple and see if I can get direct help.  Thanks for your input. stepj

  • Jas. Cox Level 1 Level 1

    I'm having the exact same problem. I'm signed into iTunes with my Apple ID. However, when I try to redeem anything, it asks again and again for my Apple ID, which is the same that got me signed in in the first place. I quit iTunes. And got back in. Same problem. Signed out, got out, signed back in. Same problem. Never asks me to save password. Looked at Keychain thing and deleted the only iTunes thing I saw. Still loop of asking for Apple ID.

  • sabatica Level 2 Level 2

    Delete Keychain file from Keychain access for iTunes.

     

    Delete  all of your iTunes your ~/Library/Preferences these are .plist files. that say com.apple.iTunes blah blah.plist

     

    Relaunch iTunes and sign in again.

     

    IF PROBLEM STILL PERSISTS

     

    Create a new iTunes Library . http://support.apple.com/kb/HT1589

     

    Then sign in as normal.

    Make sure in the iTunes Menu preferences under the advanced tab that the checkbox to keep iTunes media folder organized...blah blah blah is selected.

     

    Once Itunes is working and not giving you that prompt every 5 seconds  you need to move all of your previous iTunes Music from your ~/Music/iTunes/iTunes OLD Library and drag and drop onto iTunes icon in your dock. All the files will now be copied to the new location.

     

    Once completed and working remove the old iTunes Library

     

    Done.

  • Jas. Cox Level 1 Level 1

    I couldn't find a single com.apple.iTune  .plist file to delete. Searched several libraries, did a search. I finally deleted iTunes Library Extras.itdb. I'm not even sure why other than it was the latest thing to update. Kept failing to sign in. Finally went to movies (which I wanted to redeme) and did the button at the bottom. Played this game for awhile and it finally just let me redeem the thing. I have no idea what I did, but it was an ordeal.

  • Jringe01 Level 1 Level 1

    This issue has to do with cookies. ITunes and Safari are interconnected to a certain degree in that when you open Itunes the cookies necessary to enable full functionality are stored on Safari. Check your cookies settings. This happened to me a while ago and I came across another post talking about it so i tried it.

     

    I was trying to redeem a gift card in ITunes when it kept prompting me for my password even though I was entering it properly. After some google searching I learned that ITunes will store it's cookies in Safari so I  set my preferences in Safari to block cookies from third parties and advertisers (I had it set to never)..then opened ITunes again and "presto" it works fine.

     

    As a rule I use Firefox but even if you don't use Safari and keep it closed the cookie for ITunes will still work as long as ITunes is allowed to put it there

     

    In fact this happened to me again tonight (Oct 25th 2013, round about 9:55pm). The other day after upgrading to OS Mavericks I was doing a search and, not having McAfee site advisor on the Mac, I changed my cookie settings to never as a precaution...and forgot to switch it back after I finished. So tonight I went to redeem another gift card and viola, continous password prompts. I changed the cookie settings and redeemed my card with no problems.

  • Jas. Cox Level 1 Level 1

    This has been the most helpful thing thus far. I also had all cookies blocked on Safari and use Firefox. I changed it to thrid party block and signed in and had no problems, but I don't have anything to redeem so I don't know if it's the perfect solution yet, but seems to be. Thanks!

  • Enrique1969 Level 1 Level 1

    I cant instala any App. That just Came in , even though they c say its free it Asís for Apple id and tales me to account and say si have no fundes ,,,, but its free !!! What to do?

  • John Macdonald2 Level 1 Level 1

    Same problem, iTunes wouldn't accept password, and also using Firefox with Safari cookies always blocked. I made the change recommended above and it works. THANK YOU!

Previous 1 2 Next