Previous 1 2 3 4 Next 49 Replies Latest reply: Jan 10, 2014 11:56 AM by SolonaSanDiego
abnospam Level 1 (0 points)

Hi Everyone,


I just applied 10.8.4 and suddenly noticed my Outlook 2011 (14.3.4 & connected to exchange) search stopped working. It never finds any results. I do see Spotlight results for outlook email files, but no results within outlook. Things I have tried:


  1. Reindex entire drive
  2. Reindex Identities folder
  3. Rebuild Identity
  4. Create brand new identity
  5. Deleted some sync services plists


Nothing has worked. This was flawless yesterday before I applied 10.8.4. Has anyone seen this and can provide some help??

  • homli Level 1 (0 points)

    Same problem here.  It appears Spotlight may be looking for messages in, even when Microsoft Outlook is set as the default email reader.

  • mobidutch Level 1 (5 points)

    Same problem here. Started right after 10.8.4 update. I tried:


    1) Dropping "Microsoft User Data" folder onto Spotlight Privacy tab, and then removing it

    2) A re-index of entire drive via terminal command

    3) Completely removing Identity with all cached files, and creating new Identity

    4) After 3 I even tried a repeat of 1 and 2


    Nothing. It's broken. Very inconvenient!

  • abnospam Level 1 (0 points)

    UPDATE: I created a new identity (which redownloads all emails) and forced an entire Spotlight reindex via terminal. I deleted all old identities I was no longer using. I also had my Microsoft User Data folder in Library/Preferences, so I moved it back to Documents (I had done this previously cause I didn't like it in Documents). It did not work immediately, but I left it overnight and in the morning search began to work again! Maybe it just needs some extra time, who knows?

  • mobidutch Level 1 (5 points)

    Did you FIRST move your User Data folder back to Documents and THEN force a reindex via terminal, or the other way around? If the latter, the full reindex may not be necessary, and perhaps it is just an issue with the User Data folder not being in the orginal location?

  • abnospam Level 1 (0 points)

    It is a bit wild. I had previously moved MUD folder and it didn't work. I had also previously added that folder to Privacy and out again and still No Results. In fact, I created a new temp identity, moved the MUD into Library/Preferences and a draft email was showing up in Outlook, but not Spotlight as I expected.


    Who knows what broke the camel's back. It may have been waiting all night or a combination of waiting and something else. When it finally worked, I followed this order:


    1. Close Outlook
    2. Move Microsoft User Data (MUD) folder to Documents
    3. Create a new identity, set as default
    4. Open Outlook and configured my Exchange account
    5. Executed the spotlight reindex command in terminal
    6. Let it sit all night


    I should mention that before all email had downloaded, but after the index had completed, search was not working, but somehow worked when I woke up. It is as if Outlook has to build some index of meta data in conjunction with Spotlights index to work. That is just speculation though.


    p.s. I also tried this, but thought it wasn't necessary: -working-on-outlook-2011-for-mac-tried/47248d42-5fb1-466a-b098-8980d394ac45?msgI d=abb991a8-56e6-4f0b-aa3e-22129cc74995

  • mobidutch Level 1 (5 points)



    So I'm curious...are you planning on moving your MUD folder into ~/Library/Preferences again? Wondering if it will add new emails to the index after that...

  • abnospam Level 1 (0 points)

    right now I am totally paranoid of losing my search I ain't changing a thing. Without search, I am about 30% as productive. Maybe in time, I will have the confidence to go back.


    Prior to this update moving MUD to Library/Preferences was beautiful. Outlook search worked, but outlook emails stayed out of Spotlights search (though they must have been in the index). I hated outlook files in Spotlight because it had no usefulness without a QuickLook option from that search result list.

  • mobidutch Level 1 (5 points)

    I hear you...


    Without search there's no way I'll find my stuff in my convoluted archived email folder structure. But also don't want to move the MUD back into Document, because then I have to start messing with selective Dropbox syncing. Pain. I may have no choice....

  • mobidutch Level 1 (5 points)

    So..does Apple Support monitor these posts? Thsi was defintely caused by the 10.8.4 update, so it seems to me that Apple should be the one to investigate this initially, not Microsoft. The eventual fix may still have to come from MS if Apple changed some default behavior, but someone needs to start. I'll see if I can submit a bug report.

  • Nobby San Level 1 (0 points)

    This is one of most annoying problems in OSX. I moved the MUD on my computers when the search methodology changed in Outlook to Spotlight. (I could not cope with hundreds of e-mail results when doing a simple file search.) And I don't want to have to change the MUD location, as we will end up with the original issue.


    In addition to the other items people have tried. I also tried un-hiding the ~/library directory and re-indexing Spotlight, this didn't help either.


    Has anybody been able to find any documents on what changed in Spotlight in the 10.8.4 release?

  • mobidutch Level 1 (5 points)

    I gave in. I deleted my Identity and moved my MUD back under Documents. That was a bit of a pain, since I sync my entire Documents folder to Dropbox. Evertime I unchecked the MUD folder in the Dropbox selective sync settings, it would also delete the MUD folder locally, but keep its online copy. Weird. Finally got that to work, and used terminal to hide the MUD folder so I don't have to see it. Then created a new Identity, and now search within Outlook works again. Whatever 10.8.4 changed here....I hope they'll reverse that.

  • Prat P Level 1 (0 points)

    I got it back and this is what I did.


    But first, some history.

    1. A year ago, I moved my MUD (Microsoft User Data) to the ~/Library/Preferences because main Spotlight search shows outlook messages which I do NOT want to see.  By moving my MUD (which for most people is in the Document folder ), the Spotlight search no longer shows email.   Outlook 2011 search continues to work after you force re-index.  .. All good.
    2. Then I upgraded to 10.8.4.  This broke my search in Outlook, although spotlight search for everything else works.  I re-index but Outlook Search returns "No Results".
    3. The fix is to move the MUD back to Documents folder (in my case, /Users/prat/Documents/Microsoft User Data/Office 2011 Identities)
    4. Then to force the re-index, I go to System Preferences -> Spotlight -> Privacy tab.  Add my Document folder..  Wait 30 seconds.  Then remove it which trigger the index (mds process in Activity Monitor)


    My guess that OSX 10.8.4 fixed the issue that I had a work around for in step 1.  My MUD folder is 14GB so I guess my local emails should be in my Documents folder after all.   Hope this helps someone.


    I did NOT have to re-create new identity.

  • ass6ca Level 1 (0 points)



    I am experiencing the same problem. As a result I have:

    0) Rebuilt Identity

    1) Moved MUD back into Documents

    2) Added and then subtracted Documents from Spotlight which is now causing re-indexing of Spotlight.

    3) There was a backup identity created which was causing some problems. I have moved that Identity into Trash.


    Currently, Spotlight is returning Outlook message and contact results. So at least I can access the data once again. Two questions:


    A) However Outlook is still not returning any search results. Anyone have any suggestions?

    B) Is it now possible to move MUD out of Documents?



  • abnospam Level 1 (0 points)

    I had the same behavior. Solution was to wait    after I left it overnight it began working. Good luck.

Previous 1 2 3 4 Next