0 Replies Latest reply: Jun 6, 2013 12:57 PM by SquizzyMacKnutt
SquizzyMacKnutt Level 1 Level 1 (0 points)

The USB external hard drives attached to my Mac Pro, which is running 10.6.8, are not allowing me access, saying I do not have permission. There is a lock on the desktop icon for each of them. I tried changing them in the Get Info box but all permission settings revert back to saying "custom" immediately. I also tried using Disk Utility to repair permissions and repair the disks without success.

 

It all started after I tried to share the drives on my local network using the Sharing control panel in System Preferences. There were many, many messages that came up saying such and such file (each file name was different) could not be modified but I thought I clicked on the option that would not affect those files, leaving them unchanged.

 

One of the drives is used primarily as a Time Machine back up drive. the other has a lot of irreplaceable data on it. I would like to recover the latter rather than reformat it. I could reformat the Time Machine drive if necessary, but I would rather not.

 

Also, I cannot perform an fsck -yf in single user mode (command & S at start up) and my drawing tablet is no longer available for use.

 

Perhaps the system on the Mac Pro is hosed and needs to be reinstalled. Do you think that will fix it?

 

All help would be greatly appreciated.

 

Thanks.


Mac Pro, Mac OS X (10.6.8)