Previous 1 2 Next 19 Replies Latest reply: Jun 11, 2013 3:33 PM by PrintTech
PrintTech Level 1 (115 points)

Just installed Adobe CS6 on OS 10.6.3 and the OS isn't recognizing account permissions so I can't open the software. I have tried the following with no success:

 

• Restarted computer

• Updated OS software

• Deleted student account and created a new one

• Repaired disk permissions

 

Any solutions, suggestions???


MacBook Pro, Mac Minis, Mac OS X (10.5.8)
  • Kurt Lang Level 8 (36,660 points)

    CS6 requires 10.6.8 as the minimum OS for it to operate. Update Snow Leopard.

  • ds store Level 7 (30,325 points)

    Apple Menu > Software Update until clear.

  • WZZZ Level 6 (12,855 points)

    Software update until clear not needed and overkill. You may not need or want all those. Just get the 10.6.8 Combo Update and install. But do run the Java and Security Updates after installing the Combo.

    http://support.apple.com/kb/DL1399

  • PrintTech Level 1 (115 points)

    Didn't work. See my reply to WZZZ below.

  • PrintTech Level 1 (115 points)

    I had already updated to OS 10.6.8 so I updated the Java and Security updates, to no avail. Found this rather lengthy post on Adobe's website regarding the issue: http://forums.adobe.com/thread/1020522?start=40&tstart=0

    Seems the easiest (yet still questionable) fix is to update to Mountain Lion. Some other suggestions are listed in the post and I am slowly working through these until we can upgrade to ML.

     

    Issue is that only those accounts with Admin privileges allow CS6 to open. Seems to be a widespread issue among school settings where managed student accounts are necessary. I have noticed that Apple's system prefs do not retain the permissions I set as well.

  • Kurt Lang Level 8 (36,660 points)

    Seems the easiest (yet still questionable) fix is to update to Mountain Lion.

    That shouldn't be necessary. I've been running CS6 in Snow Leopard since the day it was released. Still am.

  • PrintTech Level 1 (115 points)

    Yes, a few of the posters in the Adobe thread link I posted previously indicated they too were running CS6 on OS 10.6.8, but it clearly isn't working for us. Some of the other recommendations were to wipe the hard drive and do a clean install of both the OS and CS6; or revert back to CS 5. Not looking forward to either of those options but upgrading to 10.6.8 did not work.

     

    And as I mentioned earlier, when I allow the student accounts permission to open Illustrator, InDesign and Photoshop, those settings aren't retained in Parental Controls. I've had this same issue with Parental Controls for some time now, but it's never prevented us from accessing the software (usually Always Allow would work; now it doesn't).

     

    So, I'm still searching for an efficient solution. Thanks for your help.

  • Kurt Lang Level 8 (36,660 points)

    The last couple of Adobe Creative Suites had a bad habit of causing problems like files not having a desktop icon when saved, even when you have it checked on in Photoshop's prefs. I did a ton of testing (erased a partition many times and installed various versions of OS X and the CS6 Master Collection) to try and find where the fault occurred.

     

    In all cases, installing the CS6 Suite was the culprit. There's a very long discussion about this on Adobe's PS forum. Also in all cases, reinstalling the OS after the Adobe software solved the problem. I even did a checksum of the drive after installing CS6 and compared it to a checksum after reinstalling the OS. The files that changed really didn't pinpoint anything. There was nothing altered by the Adobe software that raised a flag. Chris Cox at Adobe looked at the output and pointed out a couple of minor things, but nothing was conclusive.

     

    Why installing the CS6 suite causes some issues like this for some users is still unknown. All I know is that, for us, reinstalling the OS and its updates afterwards fixed it.

  • PrintTech Level 1 (115 points)

    I reinstalled OS 10.6.3 and updated to 10.6.8 but am still having the same issue. Looks like my only options at this point are to either spend another $400 for upgrades to Mountain Lion, or reinstall CS5, which means the $13k we spent to upgrade to CS6 is wasted until we find a solution.

     

    As long as student account is given Admin permissions, no problem. But as soon as any Parental Control limits are applied, we get messages that the student account doesn't have permission to use the software (even though students have been given permission in System Prefs). Choosing "Always Allow" does nothing; choosing "Allow Once" causes another 'no permissions' message referencing "adobe_licutil" (and once I received on referencing "dynamic link manager").

     

    I'm calling Adobe.

  • andyBall_uk Level 7 (20,490 points)

    calling Adobe sounds wise - but did following #39 on the thread you referenced earlier not work ?

  • Kurt Lang Level 8 (36,660 points)

    But as soon as any Parental Control limits are applied, we get messages that the student account doesn't have permission to use the software (even though students have been given permission in System Prefs).

    Missed that above where you mentioned only an Admin account works. That's a known issue. Only an admin account works with CS6, at least in Snow Leopard. I haven't tried it with Mountain Lion to see if the same thing happens in a Standard, or other account.

  • PrintTech Level 1 (115 points)

    Anyone try CS6 on Mountain Lion to see if AI, ID, or PS launch on a managed (non-admin) user account?

  • PrintTech Level 1 (115 points)

    Adobe was almost zero help. Basically said I would have to pay $30 for any support (though we only quite recently purchased the software), that the issue wasn't with the software (since it works via Admin acct), and that I would need our IT dept to provide all Adobe folders with Admin permissions. Even if our IT dept would actually touch a Mac, I don't think that's a reasonable solution. Still may try it though.

     

    As for the solution offered in the #39 post of my aforementioned link, I didn't try that because I couldn't find the interface the poster referenced. As I understood it, he was using WGM, but my WGM looks very different. If you can point me in the right direction to where I can find the image below, I will try it:

     

    It is all very simple. One more time, just allow following:

    /Library/

    /Applications/

     

    Then just disallow any applications that you want.

     

    Whitelist.gif

     

    The problem described here is that non-admin users cannot run Adobe Creative Suite 6, correct? So, if the users are not admins, then they cannot copy anything to those folders. Hence, there is no issue. They cannot run applications from any other folder, either. Test it

    .

  • PrintTech Level 1 (115 points)

    Aw heck, that image didn't show up. It's #39, should be at the bottom of this page:

     

    http://forums.adobe.com/thread/1020522?start=0&tstart=0

     

    I'm going to lunch and will take another look at this later.

Previous 1 2 Next