6 Replies Latest reply: Jun 11, 2013 7:09 PM by mary janehomeandaway
mary janehomeandaway Level 1 Level 1 (0 points)

The Warning I am getting says;


"/Users/maryjanebarry/pictures/Aperture.aplibrary" cannot be loaded because it is from a newer version of Aperture.


I have updated latest version of Aperture since the warning. I have tried clicking on Aperture in Finder, same warning.

Help please

MacBook Pro, Mac OS X (10.7.5)
  • mary janehomeandaway Level 1 Level 1 (0 points)

    I have just seen an old post in the sidebar. My version of apperture and my library versions are the same. I do not appear to have a previous version of Aperture. When I click open with , there is only on Aperture.

  • firstlaunch Level 3 Level 3 (620 points)

    Have you tried to open a new library by holding down the option key on launch?


    I suggest opening 2 finder windows. One finder window displaying your Aperture application and the other displaying your Aperture library. Then, select each one to confirm they both show the same version in the info area (or command+i to get info). Once you know for sure they are the same, drag that library onto the Aperture application in that folder.


    I suggest making sure your Aperture and systems are updated to the latest.

  • mary janehomeandaway Level 1 Level 1 (0 points)

    Aperture Library Info says 3.3

    Aperture Info application says 3.3

    I have tried dragging the library into the Aperture but it still says library is from a newer version of Aperture.

    I assume you mean to drag the flower icon onto the Aperture icon when both info panels are open.

    Sorry not much of a teckie, treading softly here.Screen Shot 2013-06-08 at 9.01.32 AM.pngScreen Shot 2013-06-08 at 9.04.10 AM.png

  • léonie Level 9 Level 9 (77,660 points)

    Trash Aperture's "preferences" file: it may be locked to a wrong library.


    Then try to double click your Aperture library to open it directly.


    Remove the Aperture's user preferences from the User Library as described here:

    Aperture 3: Troubleshooting Basics




    Your User Library is hidden by default in 10.7.5 - to open it in a Finder window use the "Go" menu from the Finder's main menu bar.

    • Quit Aperture, if it is running. Log off and on again.
    • Open the user library by using the Finder's "Go > Go to Folder" menu and hold down the options-key, until "Library" appears in the drop down menu. Select it.
    • In the widow that will open, scroll down to "Preferences"
    • From the "Preferences" folder  remove "com.apple.Aperture.plist".

    Then try to launch Aperture again.


    But deleting the "Preferences" file will cause Aperture to forget the preferences settings. Be prepared to have to reset all options you set using the Aperture Preferences panel.




  • firstlaunch Level 3 Level 3 (620 points)

    Hi Mary,


    Did you get your libray to open? You might try upgrading Aperture to 3.4.5 and then try opening it.

  • mary janehomeandaway Level 1 Level 1 (0 points)

    Thank you. This solved my problem. I had done an update relatively recently but obviously not the very latest. Sometimes I wish Apple would just leave things as they are for a while.

    Much appreciated