12 Replies Latest reply: Aug 16, 2015 3:37 PM by jackzero
JohnGrover Level 1 (0 points)

A few days ago, I noticed that my hard disks (both built in and external) failed to appear in the sidebar. I double checked Finder Prefs, and the checkmarks are correctly checked to "show Hard Disks / External Disks" etc. But they still do not show. I have rebooted in safe mode. verified the disk, reset the PRAM to no avail.

 

If I gesture up and show the spaces mode and choose an EMPTY desktop (not one with open finder windows), I can see the icons of the drives on the desktop and work from there. But I much prefer being able to access my finder items from any finder window. Weird, I know....

 

Any help would be appreciated.

 

MBP 17" 2.5GHz Intel Core i7

16 GB 1333 MHz DDR3 Memory

OS 10.8.3


MacBook Pro, Mac OS X (10.7.5), 2.5 GHz Intel Core i7 16GB RAM
  • Linc Davis Level 10 (192,897 points)

    Movethe cursor over the DEVICES line in the sidebar. If the word Show appears on the right, click it. Otherwise, from the Finder menu bar, select

     

    Go > Computer

     

    Drag the volume icons into the sidebar under DEVICES.

  • JohnGrover Level 1 (0 points)

    "Devices" does not show in the sidebar...nor do connected servers. All that shows is "Favorites". Any thoughts on that? I have rebooted again, and the preferences for the finder definitely have all the choices above clicked...

  • petermac87 Level 5 (7,365 points)

    Top Menu > Finder > Preferences > Sidebar > make sure Hard Drives etc. are ticked.

     

    Pete

  • JohnGrover Level 1 (0 points)

    They are....no show.

  • Linc Davis Level 10 (192,897 points)

    Back up all data.

    Triple-click the line below to select it:

    ~/Library/Preferences/com.apple.sidebarlists.plist

    Right-click or control-click the highlighted line and select

    Services Reveal

    from the contextual menu.* A folder should open with an item selected. Move the selected item to the Desktop, leaving the window open. Relaunch the Finder and test. If there's no change, put the item you moved back where it was, overwriting the one that may have been created in its place. Otherwise, delete the item you moved.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

  • JohnGrover Level 1 (0 points)

    That worked beautifully. Thanks! Now can you fix my mail issues

  • Dan Bryant1 Level 1 (30 points)

    This did not work for me.  My external disks appear on my desktop but nothing in the sidebar.  In fact, none of the items which should appear under devices are there.

  • Eric Root Level 9 (50,612 points)

    You might want to consider starting a new discussion. Since this one is marked solved, less people are likely to look at it.

     

    Try going to Finder/Preferences/Sidebar to make sure the appropriate items are checked.

  • fonsr Level 1 (10 points)

    Your advice - "Movethe cursor over the DEVICES line in the sidebar. If the word Show appears on the right, click it. Otherwise, from the Finder menu bar, select"


    So simple...Thanks! Had checked my Finder preferences, Sidebar prefs, restarted...nothing worked. Did what you said - bingo!

  • DallasDeckard Level 1 (0 points)

    My wife had this problem, too. I did all this, and nothing worked. Then... I hovered the mouse pointer over the "Favorites" label in the sidebar and an item appeared that said "show"... I clicked on that and suddenly all of the folders and disks showed up. Try hovering your mouse over the "Favorites" label in the sidebar, click on "Show" and see if that doesn't work.

  • Horsnaround Level 1 (0 points)

    I am having the same problem.  I finally got to the sidebar list but oh my gosh!  What a lot of typing.  What am I supposed to do with that???  I can't get my devices to show up on the sidebar and I do have them checked in the preferences.  When I hover over the 'favorites' at the top of the sidebar it will allow me to hide or show but this is all I get.

    Screen Shot 2014-12-25 at 6.59.46 PM.png

    no devices.  Can you pls walk me through step by step on how to fix this?

     

    Thank you so much,

     

    Horsnaround

  • jackzero Level 1 (0 points)

    Thank you, such a simple fix. This was driving me crazy. Your suggestion worked perfectly!